Merge cryptsetup 2:1.4.3-2 (main) from Debian unstable (main)

Bug #1015753 reported by Jean-Louis Dupond on 2012-06-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cryptsetup (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

Please sync cryptsetup 2:1.4.3-2 (main) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
As i'm the co-maintainer of cryptsetup in debian, I took care that ALL ubuntu changes are in debian.
This is now the case, so the package can be synced now.

Changelog entries since current quantal version 2:1.4.1-2ubuntu4:

cryptsetup (2:1.4.3-2) unstable; urgency=medium

  * fix the shared library symbols magic: so far, the symbols file for
    libcryptsetup4 included just a wildcard for all exported symbols, with
    libcrypsetup4 (>= 2:1.4) as minimum version. This was wrong. Symbols
    that were added later need adjusted minimum versions. Thanks for the
    great help in #debian-mentors. (closes: #677127)
  * remove emtpy directory /lib from cryptsetup-bin package.
  * compile askpass and passdev with CFLAGS, CPPFLAGS and LDFLAGS.

 -- Jonas Meurer <email address hidden> Tue, 12 Jun 2012 21:26:18 +0200

cryptsetup (2:1.4.3-1) unstable; urgency=low

  [ Jonas Meurer ]
  * mention limitations for keyscripts in crypttab(5) manpage: keyscripts
    must not depend on binaries/files which are part of the to-be-unlocked
    device. (closes: #665494)
  * bump versioned build-dependency on debhelper now that we install
    upstart initscripts in debian as well.
  * change versioned breaks/replaces for cryptsetup-bin on cryptsetup to
    1.4.3-1~, fixing upgrades in debian.

  [ Jean-Louis Dupond ]
  * New upstream version. (closes: #670071)
    - Fix keyslot removal (closes: #672299)
    - Add -r to cryptsetup.8 (closes: #674027)
  * Split up package in cryptsetup and cryptsetup-bin.
  * I'm now co-maintainer (closes: #600777).
  * Start cryptdisks-enable upstart job on 'or container', to let us
    simplify the udevtrigger job.
  * debian/cryptdisks.functions: handle the case where crypttab contains a
    name for the source device that is not the kernel's preferred name for
    it (as is the case for LVs). (Thanks Steve Langasek)
  * debian/cryptdisks.functions: fix a race condition in some cases by
    adding and udevadm settle before rename.
  * debian/cryptdisks.functions: add UUID & LABEL support to do_start.
  * debian/copyright: really fix lintian warning.
  * debian/rules: also include upstart files in debian.

 -- Jonas Meurer <email address hidden> Fri, 08 Jun 2012 13:42:51 +0200

cryptsetup (2:1.4.1-3) unstable; urgency=low

  [ Jonas Meurer ]
  * finally add back support for configuration of custom rootfs-devices through
    the boot parameter 'root' to initramfs cryptroot script. Thanks a lot to
    August Martin for the bugreport as well as continuously debugging and
    providing patches. (closes: #546610)
  * use blkid instead of fstype to detect the content of devices in initramfs
    cryptroot script. Unfortunately fstype doesn't recognize md-raid devices,
    which leads to errors with encrypted devices on top of software raid.
  * check whether $NEWROOT already exists before actually invoking cryptsetup
    in initramfs cryptroot script. (closes: #653241)
  * fix conditions for prechecks at do_noluks() in cryptdisks.functions. Should
    prevent data loss with encrypted swap in most cases. (closes: #652497)
  * change default value for tmpfs and examples from ext2 to ext4.
  * minor code cleanup.
  * update debconf translations:
    - russian, thanks to Yuri Kozlov. (closes: #661303)
    - spanish, thanks to Camaleón. (closes: #661316)

  [ Jean-Louis Dupond ]
  * fix watch file.
  * always add aesni module to initramfs if we have hardware aes support.
    (closes: #639832).
  * debian/copyright: fix lintain warning.
  * add upstart scripts for ubuntu.
  * silent warnings on kernels without kernel/{arch,crypto}.
  * add crypttab_start_one_disk in function script to handle udev startup
    in ubuntu.
  * bump standards-version to 3.9.3, no changes needed.

 -- Jonas Meurer <email address hidden> Wed, 11 Apr 2012 23:55:35 +0200

Clint Byrum (clint-fewbar) wrote :

Hi Jean Louis. Thanks for submitting the request, and for getting things in sync in Debian!

One thing I'm concerned about is the upstart jobs. It seems like cryptdisks-enable.upstart was renamed to cryptdisks.upstart, and cryptdisks-udev.upstart renamed to cryptdisks-udev.upstart.

On upgrade from precise to quantal, users who have modified these (they are conffiles) will not have their modifications preserved. In order to do that dpkg-maintscript-helper will be needed.

It should be fairly simple to handle, though I'm not *entirely* sure how to resolve that with dh_installinit, I think it should just require careful thought with regard to the order of the debhelper tags in postinst/preinst.

Marc Deslauriers (mdeslaur) wrote :

Marking incomplete as per Clint's comment.

Changed in cryptsetup (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Since there's still work needed on this, I'm going to unsubscribe sponsors for now. Once the problems are addressed, please re-subscribe ubuntu-sponsors for us to take another look.

Changed in cryptsetup (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Changed in cryptsetup (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
status: Incomplete → In Progress
summary: - Sync cryptsetup 2:1.4.3-2 (main) from Debian unstable (main)
+ Merge cryptsetup 2:1.4.3-2 (main) from Debian unstable (main)
Launchpad Janitor (janitor) wrote :
Download full text (5.3 KiB)

This bug was fixed in the package cryptsetup - 2:1.4.3-2ubuntu1

---------------
cryptsetup (2:1.4.3-2ubuntu1) quantal; urgency=low

  * Merge from debian unstable (LP: #1015753), remaining changes:
    - debian/control:
      + Bump initramfs-tools Suggests to Depends: so system is not
        potentially rendered unbootable.
      + Depend on plymouth.

    - init/upstart jobs:
      + Add debian/cryptdisks-{enable,udev}.upstart for bootup.
      + debian/cryptdisks{,-early}.init: Make the 'start' action of the init
        script a no-op, this should be handled entirely by the upstart job;
       and fix the LSB header to not declare this should be started in
       runlevel 'S'.
      + Do not install start symlinks for init scripts
      + NB! shutdown is still handled by the SystemV init scripts

  * Rename cryptddisks{,-early}.upstart jobs back to
    cryptdisks-{enable,udev}.upstart, as we need both init & upstart jobs
    for now.

  * Dropped Changes, included in Debian:
    - debian/control:
      + Split up package in cryptsetup and cryptsetup-bin. (LP: #343363).

    - debian/cryptdisks.functions:
      + Do not overwrite existing filesystems when creating swap (LP: #474258).
      + Add aesni module when we have hardware encryption.
      + Call 'udevadm settle' before 'dmsetup rename' http://pad.lv/874774
      + Suppress "Starting init crypto disks" message in "init" phase, to
        avoid writing over fsck progress text.
      + new function, crypttab_start_one_disk, to look for the named source
        device in /etc/crypttab (by device name, UUID, or label) and start it
        if configured to do so
      + handle the case where crypttab contains a name for the source
        device that is not the kernel's preferred name for it (as is the case
        for LVs).

    - debian/initramfs/cryptroot-hook:
      + Quiet warnings from find on arches that don't have all the
        kernel/{arch,crypto} bits we're testing for.

cryptsetup (2:1.4.3-2) unstable; urgency=medium

  * fix the shared library symbols magic: so far, the symbols file for
    libcryptsetup4 included just a wildcard for all exported symbols, with
    libcrypsetup4 (>= 2:1.4) as minimum version. This was wrong. Symbols
    that were added later need adjusted minimum versions. Thanks for the
    great help in #debian-mentors. (closes: #677127)
  * remove emtpy directory /lib from cryptsetup-bin package.
  * compile askpass and passdev with CFLAGS, CPPFLAGS and LDFLAGS.

cryptsetup (2:1.4.3-1) unstable; urgency=low

  [ Jonas Meurer ]
  * mention limitations for keyscripts in crypttab(5) manpage: keyscripts
    must not depend on binaries/files which are part of the to-be-unlocked
    device. (closes: #665494)
  * bump versioned build-dependency on debhelper now that we install
    upstart initscripts in debian as well.
  * change versioned breaks/replaces for cryptsetup-bin on cryptsetup to
    1.4.3-1~, fixing upgrades in debian.

  [ Jean-Louis Dupond ]
  * New upstream version. (closes: #670071)
    - Fix keyslot removal (closes: #672299)
    - Add -r to cryptsetup.8 (closes: #674027)
  * Split up package in cryptsetup and cryptsetup-bin.
  * I'm now co-ma...

Read more...

Changed in cryptsetup (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers