add support for application indicator

Bug #571473 reported by Γουργιώτης Γιώργος (aka Gourgi) on 2010-04-28
296
This bug affects 85 people
Affects Status Importance Assigned to Milestone
cryptkeeper (Ubuntu)
High
Alberto Milone
Nominated for Raring by Adolfo Jayme

Bug Description

Binary package hint: cryptkeeper

cryptkeeper isn't integrated with ApplicationIndicator

Related url:
https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators

http://gould.cx/ted/blog/Having_a_tidy_systray

description: updated
tags: added: indicator-application
Alexandre Rosenfeld (airmind) wrote :

Added basic support for appindicator

Still missing is support to detect new stashes, so Cryptkeeper must be restarted when new stashes (encrypted folders) are added.
Also, support for actions on stashes are not availiable, such as delete, information and rename, due to the way appindicator uses
menus, it is not possible to show a right click menu in a stash.

Changed in cryptkeeper (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2010-06-24
tags: added: patch
MartinE (martin-engbers-gmx) wrote :

The patch doesn't work for me. I applied the patch to cryptkeeper 0.9.5 and compiled it (using ./configure --enable-appindicator=yes). No error messages, but indicator is still in the notification area, not in the indicator applet; nothing has changed. Is there something else I need to do to ensure that cryptkeeper is compiled with indicator support? Maybe a missing *-dev package that ./configure doesn't check for?

Alexandre Rosenfeld (airmind) wrote :

I think you should use "./configure --enable-appindicator" and install libappindicator-dev, but other then that I'm not sure why it isn't working.

I'm attaching a patch that should be applied after the first one, that keeps the menu updated after mounting so let you umount folders, which wasn't working before but I didn't notice.

MartinE (martin-engbers-gmx) wrote :

The patch still doesn't work for me. I'm sure I'm doing something wrong, but I would really like to get this done correctly. When compiling cryptkeper (version 0.9.5) with your patch applied, I get the following error message:

main.cpp:46: fatal error: libappindicator/app-indicator.h: No such file or directory
compilation terminated.

Please note that libappindicator-dev is installed. I symlinked /usr/include/libappindicator-0.1/libappindicator (which contains the aforementioned header file) to cryptkeeper/src/libappindicator and tried again. This time, installation finished without any errors. But cryptkeeper still doesn't use the indicator menu. It still shows up in the old notification area, and only there. I'm at a loss here.

Would you mind posting some detailed instructions on how to compile and install cryptkeeper with your patches applied? Any idea what mistake I'm making here?

Thanks, Martin

MartinE (martin-engbers-gmx) wrote :

Please ignore my above comments. Ignorant as I am, I didn't realize that I had to update the 'configure' script using autoconf. No wonder it didn't work without that. I can now confirm that your patch works absolutely fine, with no problems whatsoever.

Thanks a lot!
Martin

MartinE (martin-engbers-gmx) wrote :

This patch corrects some errors with AppIndicator support. It is meant to be applied
after the first and second patches. The following changes were made:

(1) The function sico_activated() was missing a call to app_indicator_set_menu(),
so all menu updates added by the first and second patch had no effect at all.
This has been fixed.

(2) Some other conditional calls to sico_activated() have been added in places
where the mount status of stashes may have changed.

(3) All markup is removed from menu labels if cryptkeeper is compiled with
AppIndicator support.

AppIndicators (currently) don't support markup in menu labels. Some tags, such as <b>,
are stripped from the text, while others such as <span> are simply rendered as text (which
leads to a problem with the first patch, since unavailable stashes use <span> in their menu
entries to set the foreground color to grey). To my knowledge, it has not been decided (yet)
whether AppIndicators will support markup in the future, or if all tags will be stripped, or if all
tags will be rendered verbatim (see Bug #498725 or Bug #522149 for more information).
Removing all markup seemed the most reasonable thing to do under these circumstances.

Mohegan (jack-mohegan) wrote :

The patches work with natty and cryptkeeper 0.9.5 (but apply manually). But I have a problem with the compilation. So, I modify the src/Makefile.in at line 123 :
--- LIBS = @LIBS@
+++ LIBS = @LIBS@ -lX11
Now, it is ok.
I had the modified source as attachment.

Moritz Molch (mmolch) wrote :

Mohegan: Your source only showed an empty menu for me after the indicator is created, I had to move the "sico_activated (NULL);" three lines down, after the menu is set. I'm too lazy to append a patch, but I thought I'd share if someone runs into the same problem.

Emmanouil Kapernaros (kapcom01) wrote :

The above happened to me too. I solved it in the exact same way as liberty.zero

Fabián Rodríguez (magicfab) wrote :

Marking high:
* Prevents the application or any dependencies from functioning correctly at all
* Renders essential features or functionality of the application or dependencies broken or ineffective

Changed in cryptkeeper (Ubuntu):
importance: Undecided → High
Changed in cryptkeeper (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Axel Pospischil (apos) wrote :

Thanks for the patches. As a heavy user of cryptkeeper for encrypting my data in the cloud I would really appreciate any effort in this. Thanks for the work so far.

ethanay (ethan-y-us) wrote :

is it a different bug when the indicator applet disappears from the applet menu bar altogether? cryptkeeper is still running, but can only be seen in the process of switching workplaces.

Norbert (asterix52) wrote :

You can use Gnome Encfs Manager as replacement for cryptkeeper.

https://bugs.launchpad.net/ubuntu/+bug/1080327

Norbert (asterix52) wrote :

unity (6.12.0daily13.02.07-0ubuntu1) raring; urgency=low

  [ Andrea Azzarone ]
  * make check fails on test-unit (LP: #1117487)
  * Notification area whitelist is obsolete (LP: #974480)

With this change is cryptkeeper not longer working with raring and Ubuntu should switch to Gnome Encfs Manager.

https://bugs.launchpad.net/ubuntu/+bug/1080327

Changed in cryptkeeper (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cryptkeeper - 0.9.5-5.1ubuntu2

---------------
cryptkeeper (0.9.5-5.1ubuntu2) saucy; urgency=low

  * debian/patches/add_support_for_appindicator.patch:
    - Fix FTBFS on i386.
 -- Alberto Milone <email address hidden> Mon, 13 May 2013 13:29:45 +0200

Changed in cryptkeeper (Ubuntu):
status: In Progress → Fix Released
Andrea (sammybuca) wrote :

Try this:
Super+ALT+rightclick go to add panel and notification area!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers