cross-toolchain-base ftbfs with linux-4.18

Bug #1792600 reported by Matthias Klose on 2018-09-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cross-toolchain-base (Ubuntu)
High
Unassigned
linux (Ubuntu)
High
Canonical Kernel

Bug Description

according to the build logs, the build process changed and calls the host compiler even for building the header files. This worked in 4.15, but not anymore in 4.18.

To limit the build to one cross arch:

CROSS_ARCHS=arm64 DEB_BUILD_OPTIONS=... dpkg-buildpackage -b

Matthias Klose (doko) on 2018-09-14
tags: added: ftbfs
Changed in cross-toolchain-base (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) wrote :

that's how the "cross" build fails:

  WRAP arch/arm64/include/generated/asm/xor.h
  UPD include/generated/uapi/linux/version.h
  UPD include/generated/utsrelease.h
  HOSTCC scripts/basic/fixdep
  CC kernel/bounds.s
gcc: error: unrecognized command line option '-mlittle-endian'; did you mean '-fconvert=little-endian'?
make[5]: *** [Kbuild:21: kernel/bounds.s] Error 1
make[4]: *** [Makefile:1112: prepare0] Error 2
make[3]: *** [debian/rules:4: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
make[2]: *** [scripts/package/Makefile:72: deb-pkg] Error 2
make[1]: *** [Makefile:1370: deb-pkg] Error 2

Matthias Klose (doko) wrote :

the "native" build fails like:

  CC scripts/mod/empty.o
  HOSTCC scripts/mod/mk_elfconfig
  MKELF scripts/mod/elfconfig.h
  HOSTCC scripts/mod/modpost.o
  CC scripts/mod/devicetable-offsets.s
  UPD scripts/mod/devicetable-offsets.h
  HOSTCC scripts/mod/file2alias.o
  HOSTCC scripts/mod/sumversion.o
  HOSTLD scripts/mod/modpost
  HOSTCC scripts/selinux/genheaders/genheaders
  HOSTCC scripts/selinux/mdp/mdp
  HOSTCC scripts/kallsyms
  HOSTCC scripts/pnmtologo
  HOSTCC scripts/conmakehash
  HOSTCC scripts/sortextable
  HOSTCC scripts/asn1_compiler
  HOSTCC scripts/extract-cert
scripts/extract-cert.c:21:10: fatal error: openssl/bio.h: No such file or directory
 #include <openssl/bio.h>
          ^~~~~~~~~~~~~~~
compilation terminated.
make[5]: *** [scripts/Makefile.host:90: scripts/extract-cert] Error 1
make[4]: *** [Makefile:1076: scripts] Error 2
make[3]: *** [debian/rules:4: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
make[2]: *** [scripts/package/Makefile:72: deb-pkg] Error 2
make[1]: *** [Makefile:1370: deb-pkg] Error 2

I assume we can make that one an additional b-d, but these things shouldn't build

Changed in cross-toolchain-base (Ubuntu):
importance: Undecided → High
Matthias Klose (doko) wrote :

The better solution for this would be a build profile in the linux source that just builds the linux-libc-dev package. That way the cross-toolchain-base packaging would be independent from the linux build system.

Changed in linux (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-18.09
assignee: nobody → Canonical Kernel (canonical-kernel)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1792600

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Seth Forshee (sforshee) wrote :

It looks like building the binary-arch-headers target should limit the build to the linux-libc-dev package.

Matthias Klose (doko) wrote :

right, now using that and checking in an autopkg test, so migration of kernels with a changed build system will block.

Changed in cross-toolchain-base (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers