cron init script support for 'status'

Bug #201504 reported by Dustin Kirkland  on 2008-03-12
6
Affects Status Importance Assigned to Milestone
cron (Ubuntu)
Wishlist
Dustin Kirkland 

Bug Description

Binary package hint: cron

Ubuntu Hardy, cron-3.0pl1-100ubuntu1

The Linux Standard Base requires all service init scripts to support the 'status' action. This package's init script lacks this ability.

Reference:
http://refspecs.freestandards.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic/iniscrptact.html

Dustin Kirkland  (kirkland) wrote :

Bug fixed by attached debdiff

Dustin Kirkland  (kirkland) wrote :

Patch ready for sponsorship

Changed in cron:
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Colin: can you please take a look at it?

Colin Watson (cjwatson) wrote :

Consensus seems to be not to attempt this for Hardy, so removing this from the sponsorship list. (Feel free to forward it to Debian in the meantime.)

Changed in cron:
milestone: none → later
Dustin Kirkland  (kirkland) wrote :

Related to changes from Bug #203169.

Patch attached.

:-Dustin

Changed in cron:
assignee: nobody → kirkland
importance: Undecided → Wishlist
milestone: later → ubuntu-8.10-beta
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cron - 3.0pl1-104+ubuntu3

---------------
cron (3.0pl1-104+ubuntu3) intrepid; urgency=low

  * debian/control: Depend on lsb >= 3.2.12ubuntu2, which has
    the status_of_proc() function.
  * debian/cron.init: Add the 'status' action (LP: #201504),
    thanks to Dustin Kirkland.

 -- Chuck Short <email address hidden> Thu, 10 Jul 2008 14:47:09 +0000

Changed in cron:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers