crmsh fixes before groovy release

Bug #1895728 reported by Rafael David Tinoco on 2020-09-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
crmsh (Ubuntu)
High
Unassigned

Bug Description

crmsh is in 4.2 version for sometime now and this is an attempt of cherry-picking fixes before groovy release.

This is the delta since 4.2 version.

Yes means I should bring the fix.
+++ means I should consider...

--- d4e0b8e5 Fix: bootstrap: revert ssh_merge function for compatibility(bsc#11
--- 7fe47ef2 Dev: behave: adjust functional test for sbd config process changes
--- bd7456f6 Dev: unittest: adjust unit test cases for sbd config process chang
+++ 1a81de9d Fix: bootstrap: adjust sbd config process to fix bug on sbd stage(
--- 5350f49f Dev: unittest: test the case which command "crm corosync status qu
--- 49480f8a Dev: behave: use "crm corosync status quorum" to check the quorum
+++ 8698c6ed Low: corosync: handle the return code of corosync-quorumtool corre
--- 314ca14d Dev: unittest: append unit test for corosync status related codes
--- 1c400304 Low: ui_corosync: copy ssh key to qnetd while detect need password
+++ 78ce77e4 Low: hb_report: Fix collecting of binary data (bsc#1166962)
--- 7a1d008b Dev: unittest: unit test for ssh key configuration improvement
--- fa33f29d Dev: bahave: adjust based on ssh key configuration improvement
--- 086a8a9e High: bootstrap: ssh key configuration improvement(bsc#1169581)
--- be7cc3b1 Dev: behave: functional test for bootstrap network improvement
--- e6b95dcd Dev: unittest: unit test for bootstrap network improvement
--- 3b5c123b High: bootstrap: bootstrap network improvement
--- 0acb26eb Low: cibconfig: Avoid adding the ID attribute to select_* nodes
--- 10ccd092 Dev: unittest: unit test for class SBDManager
--- 3d8da3cf Dev: behave: functional test for sbd functionalities
--- e859c010 High: bootstrap: using class SBDManager for sbd configuration and
--- 8ee29ab9 Low: bootstrap: change ha-cluster-bootstrap log path
--- bfb33c69 Low: ui_corosync: print cluster nodes while getting quorum and qne
--- 6d7b7df0 Low: bootstrap: exit with proper error messages when ssh return fa
--- cab72dd8 Dev: unittest: test interface_choice function
--- 82588983 Low: ui_cluster: use argparse choices to validate -i and -t option
--- d696fa20 Low: corosync: Use with statement to open file
--- b3a8c7a5 Dev: unittest: change test_add_node_ucast to make whole test reent
+++ ca1f0a7f Fix: ui_resource: refresh <Tab> should complete resource first(bsc
--- 0a064bda Dev: behave: change for deprecated alias
--- c66a1971 Dev: testcases: change for deprecated alias
--- 86282af8 Low: ui_context: give warning if using alias command
--- 25123c13 Dev: behave: add functional test for geo cluster setup
--- 4f6b9e82 Low: bootstrap: Simplify bootstrap context
--- 8431800d Dev: behave: Functional test for user case master survive
--- 960e4aa8 Dev: unittest: unittest for qdevice improvement
--- 1b97ccb4 Dev: behave: functional test for qdevice imporvement
--- 355489c9 Low: corosync: Improve qdevice configure process
--- bc144758 Fix: doc: Update man page about completion example of crm resource
+++ 669f13b5 Fix: bootstrap: Change condition to add stonith-sbd resource(bsc#1
--- 2c10d3df Dev: unittest: unit test for changed function csync2_update
+++ d79e416b Dev: behave: functional test for scenarios of bsc#1166684
+++ e098387e Fix: bootstrap: use csync2 '-f' option correctly(bsc#1166684)
--- b256772e Low: setup.py: update crmsh's version
--- e43eb844 Fix: crmsh.spec.in: enable completion of crm command(bsc#1166329)
--- e9910318 Low: crmsh.spec.in: sync contents from NHF's crmsh.spec file
--- e10e5eb6 Dev: testcases: update test output due to pacemaker update
--- e2a36e87 Dev: behave: functional test for setup cluster with crossed networ
--- 2816fc66 Dev: unittest: test for get_peer_hostname/is_online/find_configure
--- e11cce02 Dev: corosync: check whether local ip has already configured
--- 6ccc21d5 Dev: bootstrap: check whether init node is online while joining
--- 5a821f69 Dev: bootstrap: for udpu, don't check join node's ip was in the sa
--- a8fc7664 Low: unittest: add unit test to detect_cloud
--- e8ee51cf Low: utils: update detect_cloud pattern for aws
yes c6b15764 scripts: python3.8 unittest compatibility
--- c9aac1c7 Dev: bootstrap: binding interface when calling "crm cluster init"
--- 8843e08f Low: doc: update configure.set documentation
--- dbe03cf4 Low: behave: functional test for configure.set subcommand
--- 6461acca Feature: configure: make configure.set to update operation
--- ec9c17d8 Low: testcases: adjust testcases based on related upstream version
--- c9e2991f Low: unittest: replace nose with pytest
--- a403aa15 Low: replace configparser.SafeConfigParser as configparser.ConfigP
yes 71dc4b5d Dev: behave: Not allowed space value for option
yes 79bf0733 Fix: ui_cluster: Not allowed space value for option (bsc#1141976)
--- 403461a7 Dev: unittest: add unit test for dump_D_process function
--- 58c7b8a7 Dev: behave: varify help output for commands which replace as argp
--- b8b13fe3 Dev: replace optparse with argparse
yes cce28254 Fix: crmsh.spec: using mktemp to create tmp file(bsc#1154163)
+++ 62bfb9d1 Dev: unittest: remove "placement-strategy=balanced" in ut codes
+++ f53ef7ed Dev: behave: test placement-strategy value is "default"
yes dd97cc14 Fix: bootstrap: set placement-strategy value as "default"(bsc#1129
yes 9dcc6468 dev: unittest: fix test_report.py failing in 2020
yes 72193d06 Dev: bootstrap: Maximum number of SBD device is 3
--- eb2a25fb Dev: bootstrap: improve multi disk sbd usability support both '-s
yes 997f62d6 Fix: hb_report: disable dump all tasks stack into dmesg(bsc#115806

Related branches

These were the selected fixes:

    * Fixes before release: (LP: #1895728)
      - [997f62d6] Fix: hb_report: disable dump all tasks stack into dmesg
      - [cce28254] Fix: crmsh.spec: using mktemp to create tmp file
      - [e098387e] Fix: bootstrap: use csync2 '-f' option correctly
      - [669f13b5] Fix: bootstrap: Change condition to add stonith-sbd resource
      - [ca1f0a7f] Fix: ui_resource: refresh <Tab> should complete resource first
      - [78ce77e4] Low: hb_report: Fix collecting of binary data

Changed in crmsh (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package crmsh - 4.2.0-3ubuntu1

---------------
crmsh (4.2.0-3ubuntu1) groovy; urgency=medium

  * Fixes before release: (LP: #1895728)
    - [997f62d6] Fix: hb_report: disable dump all tasks stack into dmesg
    - [cce28254] Fix: crmsh.spec: using mktemp to create tmp file
    - [e098387e] Fix: bootstrap: use csync2 '-f' option correctly
    - [669f13b5] Fix: bootstrap: Change condition to add stonith-sbd resource
    - [ca1f0a7f] Fix: ui_resource: refresh <Tab> should complete resource first
    - [78ce77e4] Low: hb_report: Fix collecting of binary data

 -- Rafael David Tinoco <email address hidden> Wed, 16 Sep 2020 03:41:38 +0000

Changed in crmsh (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers