createrepo uses deprecated md5 and sha python modules

Bug #530015 reported by Michael Stringer on 2010-03-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
createrepo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: createrepo

Older versions of createrepo use the md5 and sha Python modules which are deprecated in Python 2.5. This causes deprecation warnings to be spewed while creating repositories using createrepo.

The deprecation warnings were fixed in January 2009 (http://createrepo.baseurl.org/gitweb?p=createrepo.git;a=commit;h=5af6824631dfda17d0817343f42583129c0d0d8b) and should be in versions 0.9.7 and later.

Please upgrade the version of createrepo to get rid of these warnings.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package createrepo - 0.9.9-1

---------------
createrepo (0.9.9-1) unstable; urgency=low

  * New upstream release. (Closes: #463571)
    - createrepo --help now mentions --split option. (Closes: #682151)
    - No longer use deprecated md5 and sha modules. (LP: #530015)
  * New maintainer. (Closes: #673958) Thanks to Adam for his work.
  * debian/patches/01_fix-man-page-options.patch: Escape dashes in
    command-line options in man pages.
  * Cherry-pick fixes from upstream git:
    - debian/patches/02_drop-unused-imports.patch: Fix incorrect call of
      function imported from createrepo.utils.
    - debian/patches/03_fix-getting-YumAvailablePackage-local-path.patch: Fix
      getting path from repository packages.
    - debian/patches/04_fix-writing-additional-metadata.patch: Fix writing
      metadata when merging repositories.
    - debian/patches/05_fix-handling-remote-packages.patch: Fix handling
      remote packages when writing repository metadata.
  * debian/source/format: Update source format to 3.0 (quilt).
  * Bump debhelper compatibility level to 9.
  * Update packaging to current Python Policy recommendations:
    - debian/rules: Switch to using dh --with python2.
    - Add Build-Depends on python-all (>= 2.6.6-3~) for switch to building
      with dh_python2.
    - Drop Build-Depends on python-all-dev, package is not building Python
      extensions.
    - Drop Build-Depends on deprecated python-support, now using dh_python2.
    - Add X-Python-Version control field.
    - Drop obsolete debian/pyversions.
  * Install bash completion support:
    - Add Build-Depends on bash-completion.
    - Install createrepo.bash using dh_bash-completion.
  * debian/rules: Install the createrepo python module for all supported
    python versions.
  * debian/control:
    - Add Depends on ${misc:Depends}, deltarpm, python-deltarpm, and
      yum (>= 3.2.29).
    - Update package description.
    - Update Homepage control field to correct upstream URL. (Closes: #682149)
    - Set Priority to extra because Depends includes other extra packages.
    - Add Vcs-Git and Vcs-Browser fields.
    - Bump Standards-Version to 3.9.4. No further changes needed.
  * debian/copyright: Convert to machine-readable format 1.0.
  * debian/watch: Update to correct upstream URL.

 -- Mike Miller <email address hidden> Mon, 19 Aug 2013 01:39:04 -0400

Changed in createrepo (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers