Ubuntu

"Name: " header is missing in several swatch files

Reported by Alex Valavanis on 2011-05-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
create-project
Medium
The Create Project Developers
create-resources (Debian)
Fix Released
Unknown
create-resources (Ubuntu)
Low
Alessio Treglia

Bug Description

Binary package hint: create-resources

Several of the GIMP Palette files in the swatches folder do not contain a "Name: " header. This causes problems for Inkscape (see bug #780659), because it uses the contents of the "Name: " header to label its palette menu items.

The headers should be added to all the following swatch files:
Bears
Bgold
Blues
Borders
Browns_And_Yellows
Caramel
Cascade
China
Coldfire
Cool_Colors
Cranes
Dark_pastels
Default
Ega
Firecode
Gold
Grayblue
Grays
GrayViolet
Greens
Hilite
Kahki
Lights
Muted
Named_Colors
News3
Op2
Paintjet
Pastels
Plasma
Reds
Reds_And_Purples
Royal
Topographic
Visibone
Visibone2
Volcano
Warm_Colors

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: create-resources 0.1.3-3
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
Architecture: amd64
Date: Wed May 11 20:37:44 2011
Dependencies:

PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: create-resources
UpgradeStatus: Upgraded to natty on 2011-05-03 (8 days ago)

Changed in create-resources (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Alex Valavanis (valavanisalex) wrote :

Adding debdiff that fixes the problem for me

description: updated
description: updated
Alex Valavanis (valavanisalex) wrote :

Successful local pbuilder build. Please consider sponsoring this upload

tags: added: patch-forwarded-upstream
tags: added: patch-forwarded-debian
tags: removed: amd64
Dave Walker (davewalker) wrote :

Thanks for the patch.

Patch looks good... as this would introduce a new delta on the package which is currently unchanged from Debian, holding off sponsoring to Ubuntu to give the Debian Maintainer a chance to review the change first in Debian.

Thanks again.

On Mon, May 16, 2011 at 2:23 PM, Dave Walker <email address hidden> wrote:
> Thanks for the patch.
>
> Patch looks good... as this would introduce a new delta on the package
> which is currently unchanged from Debian, holding off sponsoring to
> Ubuntu to give the Debian Maintainer a chance to review the change first
> in Debian.

Thank you Dave, I'll upload a new revision to Debian sid as soon as possibile.

--
Alessio Treglia          | www.alessiotreglia.com
Debian Developer         | <email address hidden>
Ubuntu Core Developer    | <email address hidden>
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Daniel Holbach (dholbach) wrote :

Alessio: how are things are going with the update? For now, I'll unsubscribe sponsors from this bug as it seems to be established that there's nothing to be uploaded to Ubuntu until it's not updated in Debian.

Alex Valavanis (valavanisalex) wrote :

@Daniel - the Debian package has been updated. This will be fixed in Ubuntu with the next sync.

Alessio Treglia (quadrispro) wrote :

Hi Daniel,

On Thu, Jun 9, 2011 at 10:32 AM, Daniel Holbach
<email address hidden> wrote:
> Alessio: how are things are going with the update? For now, I'll
> unsubscribe sponsors from this bug as it seems to be established that
> there's nothing to be uploaded to Ubuntu until it's not updated in
> Debian.

right this morning I uploaded a patch to Debian sid.
The autosync should fix this within few hours.

Regards,

--
Alessio Treglia          | www.alessiotreglia.com
Debian Developer         | <email address hidden>
Ubuntu Core Developer    | <email address hidden>
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Changed in create-resources (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
status: Triaged → Fix Committed
tags: added: patch-accepted-debian
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package create-resources - 0.1.3-4

---------------
create-resources (0.1.3-4) unstable; urgency=low

  * debian/patches/0001-add_name_header_to_GIMP_palettes.patch
    - Several of the swatches in the create-resources package do not contain
      a "Name: " header. This causes problems for Inkscape (see LP #780659),
      because it uses the contents of the "Name: " header to label its
      palette menu (Closes: #626419, LP: #781350).
  * Improve long description (LP: #389136):
    - It actually only includes resources for use with graphics programs.
      Plus, Open Clip Art gallery is not an application.
  * Remove unuseful substvar ${shlibs:Depends}.
  * debian/rules:
    - Purge extra COPYING,INSTALL files.
    - Don't purge SConscript~ files, to avoid introducing changes into the
      sources tree.
  * debian/copyright: Update to DEP-5 to rev.174.
  * Bump Standards.
 -- Ubuntu Archive Auto-Sync <email address hidden> Sat, 11 Jun 2011 09:00:11 +0000

Changed in create-resources (Ubuntu):
status: Fix Committed → Fix Released
rejon (rejon) on 2011-07-24
Changed in create-project:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → The Create Project Developers (create-project-developers)
milestone: none → 1.4
tags: removed: patch-forwarded-debian
Changed in create-resources (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.