crash version is outdated. Needs to import Debian version of the package

Bug #1064475 reported by Louis Bouchard on 2012-10-09
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
crash (Ubuntu)
Medium
Stefan Bader
Precise
Medium
Stefan Bader
Quantal
Medium
Stefan Bader
Raring
Undecided
Stefan Bader

Bug Description

Sid's version of crash is at 6.0.6 and upstream is at 6.1.0. Ubuntu version should at least follow Sid's version

SRU Justification (for Quantal and Precise):

Impact: With the current crash utility in Quantal (and Precise) it is impossible to look at dumps from recent kernels (3.5+). So Quantal cannot be used to examine dumps created in Quantal and with the rolling backport kernels we will have the same problem in Precise (12.04.2). Beside that it should be possible to use the latest LTS to work on newer dumps (IMO). Another feature of this latest release is the ability to work on dumps of PV guests produced by Xen.

Fix: Instead of trying to pick individual patches it is much simpler to push the the 6.1.0 release back into older releases. It was compiled and tested in Precise at least while working on bug reports that involved dumps and required a recent version of crash.

Testcase:
- Load and examine a dump produced from a 3.5+ kernel
- Load and examine a dump of a PV Xen guest.

Louis Bouchard (louis) on 2012-10-12
Changed in crash (Ubuntu):
assignee: nobody → Louis Bouchard (louis-bouchard)
status: New → Confirmed
Stefan Bader (smb) wrote :

Attaching the the diff to get a Debianized 6.1.0 package which I am now using for a bit (however since this sort of fakes a Debian version it is nothing that we could upload).

Stefan Bader (smb) wrote :

Louis, if it is of help to you for usage, I got that uploaded as a Precise version to a PPA [1]. So it is easy to install it on a new machine.

[1] https://launchpad.net/~stefan-bader-canonical/+archive/precise

tags: added: patch
Chris J Arges (arges) on 2012-11-06
Changed in crash (Ubuntu):
assignee: Louis Bouchard (louis-bouchard) → Chris J Arges (christopherarges)
importance: Undecided → Medium
status: Confirmed → In Progress
Louis Bouchard (louis) wrote :

Upstream debian is now in sync with crash upstream. we should get our act together, now that we know what to do with the Ubuntu specifics (either drop the module or submit upstream).

Stefan Bader (smb) wrote :

Chris, not sure how much you already did, but I also was on it and nearly head a working version. The only thing I was trying to fix up was to get the extensions build and the path lookup sorted out.

Stefan Bader (smb) wrote :

Think it is working now (at least x86 part, need to find a powerpc porter and test the spu thing). Meanwhile I uploaded the current state into my Raring PPA (https://launchpad.net/~stefan-bader-canonical/+archive/raring/+packages).

Chris J Arges (arges) on 2012-11-07
Changed in crash (Ubuntu):
assignee: Chris J Arges (christopherarges) → Louis Bouchard (louis-bouchard)
Stefan Bader (smb) on 2012-11-07
Changed in crash (Ubuntu):
assignee: Louis Bouchard (louis-bouchard) → Stefan Bader (stefan-bader-canonical)
Stefan Bader (smb) wrote :

Ok, so right now we have 2 bits where we would deviate from Debian:
1. The spu extension (which as far as we know had been used for PS3 but we do not know is still usable)
2. I changed the rules to compile and package up the extensions directory.

For 1. we need to find out its usefulness. 2. I think would be useful (at least the dminfo I can use), so I should talk to Troy whether he would think that is good for Debian, too.

Stefan Bader (smb) wrote :

Tested the compile in a Quantal chroot on a PPC porter and it (the spu extension) at least compiles and gets packaged.

Stefan Bader (smb) wrote :

Package sucessfully built in https://launchpad.net/~stefan-bader-canonical/+archive/raring/+packages. Test built manually done on PPC. Now need a sponsor to review and upload into Raring.

description: updated
Stefan Bader (smb) on 2012-11-12
Changed in crash (Ubuntu Precise):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: New → Triaged
Changed in crash (Ubuntu Quantal):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (75.6 KiB)

This bug was fixed in the package crash - 6.1.0-1ubuntu1

---------------
crash (6.1.0-1ubuntu1) raring; urgency=low

  * Merge from Debian unstable (LP: #1064475). Remaining changes:
    - debian/patches/01_spu_commands.patch
      + Provides SPU extension support
      + Enable SPU extension only on PPC (using .mk logic)
    - debian/rules:
      + Always build extensions and package them.
      + Cleanup for extensions

crash (6.1.0-1) unstable; urgency=low

  * Fix for 32-bit SADUMP dumpfiles to correctly check whether a requested
    physical address is within the 0-640K backup region. Without the patch,
    requested physical addresses that are larger than 32-bits are truncated to
    32-bit values, leading to unexpected results.

  * Added support for the ELF dumpfile type that is generated by the new
    "virsh dump --memory-only" option. The "--memory-only" option uses a new
    "dump-guest-memory" QEMU monitor command that creates an ELF kdump vmcore
    clone. The "virsh dump" command continues to borrow the "migrate" QEMU
    monitor command to create a file that is designed for guest migration, and
    not well-suited for a vmcore because it is not designed for random-access
    of physical memory. A new "help -r" option has been added to dump the
    registers that are stored in per-cpu "QEMU" ELF notes; those notes are
    used to distinguish this dumpfile type from regular kdump ELF vmcores.
    The patch also combines common functionality between the new format and
    the SADUMP format.

  * Fix for the "runq" command for kernels that have the CFS scheduler.
    Without the patch, a cpu's RT runqueue may incorrectly display "[no tasks
    queued]" when in fact there are tasks on its queue.

  * In the highly-unlikely event that a pre-Linux 3.5 kernel's log buffer
    cannot be read during initialization, display a message indicating
    "WARNING: cannot read log_buf contents", and just continue. Without the
    patch, a "readmem" error would be displayed and the crash session would be
    killed.

  * Updated the "net -a" option to support Linux 2.6.9 to 3.6.0. Without the
    patch, the option displayed "net: -a option not supported or applicable on
    this architecture or kernel".

  * Enhanced the "net -a" option to show the struct neighbour address
    associated with each line of output.

  * Fix for the "runq" command for kernels that are configured with
    CONFIG_RT_GROUP_SCHED. Without the patch, tasks contained within an RT
    group scheduling entity are not displayed.

  * Fix for "crash --version" or "crash -v" to prevent the sourcing of a
    .gdbinit file that is located in the current directory.

  * Preemptive fix to handle this patch to the x86 devmem_is_allowed()
    function that was posted on the Linux Kernel Mailing List here:
    https://lkml.org/lkml/2012/8/28/357 If the proposed kernel patch put into
    place, a failed attempt to use /dev/mem when the kernel is configured with
    CONFIG_STRICT_DEVMEM will not result in an automatic attempt to use
    /proc/kcore. With this crash utility patch, the automatic switch to
    /proc/kcore will be attempted regardless whether the kernel patch is
...

Changed in crash (Ubuntu):
status: In Progress → Fix Released
Stefan Bader (smb) wrote :
Changed in crash (Ubuntu Precise):
status: Triaged → In Progress
Changed in crash (Ubuntu Quantal):
status: Triaged → In Progress
Dmitry Shachnev (mitya57) wrote :

The attached debdiffs are unsuitable for SRUs because there are some non-bugfix changes, just to name a few:

* Add support for reading compressed kdump dumpfiles that were compressed by the snappy compressor.
* Introduction of a new "tree" command that can be used to dump the the addresses of all data structure entries in a red-black tree or a radix tree.
* Created a new "rd -r <outputfile>" option that copies raw data from memory to an output file.

Please consider using -backports instead. If you really want to do a SRU, you'll have to manually pick needed fixes and verify each one individually. It would be also good if you merged your fixes and one in bug 251288.

Stefan Bader (smb) wrote :

Dmitry, I am aware that pulling back a newer package will never satisfy the normal SRU requirements. The question is whether there is a way to argue for an exemption in any way. One problem with the crash package is that (AFAIK) it is maintained upstream in tarball releases only. So picking specific fixes is hard at least and may cause even more problems. This newer release has been used by a few people quite a bit and while probably not looking much at the new features, those would be sort of opt-in to use. Of course there is always the risk of regressing old functionality. Which hopefully is kept at minimum by the intense usage that has been done.
The proposed pocked may be a resort. The problem I see with that is that it is rather complicated to enable only for a specific package. And the situation for Quantal at least which is broken (the version in release and updates cannot be used to work on kernels that are installed be default). The Precise situation is soon similar as 12.04.2 will install a 3.5 kernel by default.
That is why I would rather try to get a special exemption here.

Timo Aaltonen (tjaalton) wrote :

Stefan: I think you need to ask technical-board about it?

Adam Conrad (adconrad) wrote :

The TB doesn't need to get involved if the current package is literally unusable *and* if the SRU team is willing to let it in. You only need the TB if we put our foot down and point at the rules. Stefan and I talked about this a few months and it seemed vaguely sane back then, but we should probably have that conversation again to refresh both our memories before anything gets uploaded.

(Hint, hint, talk to me on IRC, Stefan)

Stefan Bader (smb) wrote :

Hint taken. :) I remove the sponsors for now and get back to you.

Stefan Bader (smb) wrote :

Latest crash would now be 6.1.6 and probably just should go into r, q, and p.

Adam Conrad (adconrad) on 2013-08-05
Changed in crash (Ubuntu Raring):
assignee: nobody → Stefan Bader (stefan-bader-canonical)

Hello Louis, or anyone else affected,

Accepted crash into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/crash/6.1.6-1ubuntu0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in crash (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in crash (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Louis, or anyone else affected,

Accepted crash into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/crash/6.1.6-1ubuntu0.12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in crash (Ubuntu Raring):
status: New → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Louis, or anyone else affected,

Accepted crash into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/crash/6.1.6-1ubuntu0.13.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Louis Bouchard (louis) on 2013-08-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (102.4 KiB)

This bug was fixed in the package crash - 6.1.6-1ubuntu0.12.04.1

---------------
crash (6.1.6-1ubuntu0.12.04.1) precise-proposed; urgency=low

  * Merge from Debian unstable (LP: #1064475). Remaining changes:
    - debian/rules: Always build extensions and package them.
    - debian/rules: Cleanup for extensions.
  * Dropped ubuntu changes:
    - SPU extension support.
  * debian/control: Add armhf to build architectures.

crash (6.1.6-1) unstable; urgency=low

  * New upstream version 6.1.6

  * Fix for a crash-6.1.5 regression that causes the "mount" command to fail
    on kernel versions prior to Linux 3.3. Without the patch, the command
    fails with the message "mount: invalid structure member offset:
    mount_mnt_devname".

crash (6.1.5-1) UNRELEASED; urgency=low

  * New upstream version 6.1.6

  * Fix for the ARM "irq" command. Without the patch, on 2.6.34 and later
    kernels configured with CONFIG_SPARSE_IRQ, the command fails with the
    error message "irq: cannot determine number of IRQs".

  * Fix for a segmentation violation generated during invocation while parsing
    a makedumpfile-created "flat-format" vmcore-incomplete file. Without the
    patch, the crash session would display the error message "crash: unable to
    seek dump file vmcore-incomplete", followed by a segmentation violation.

  * Fix for a segmentation violation generated by the "kmem -s" option when
    encountering a corrupted array_cache structure that contains a bogus
    "avail" count that is greater than the maximum legitimate limit value.
    Without the patch, the "kmem -s" command would print a warning message
    regarding the invalid array_cache, complete the command normally, and then
    generate a segmentation violation when freeing buffers used by the
    command.

  * Update to the "kmem -s" function to include the errors found in slab
    structures to the display of total errors found when the command
    completes. Without the patch, invalid list_head pointers, bad inuse
    counters, and bad s_mem pointers were not added to the total number of
    errors found.

  * Fix for "crash --osrelease <dumpfile>" and "crash --log <dumpfile>" when
    run on an ARM compressed kdump with a crash binary that was built with
    "make target=ARM" on an x86 or x86_64 host. Without the patch, if the
    compressed kdump header version is 4 or 5, "crash --osrelease" fails with
    the error message "crash: compressed kdump: cannot lseek dump vmcoreinfo"
    followed by "unknown", and "crash --log" fails with the error message
    "crash: <dumpfile>: no VMCOREINFO section".

  * Enhancement to the "swap" command to display the swap_info_struct address
    of each configured swap device. The output has been changed to display
    the address in the first column, and the variable-length device name has
    been moved to the last column.

  * Fix for the "kmem -[sS]" options on kernels that configured with both
    CONFIG_SLUB and CONFIG_NODES_SHIFT, and that are running on hardware that
    generates NUMA nodes that contain no memory. Without the patch, both
    command options fail immediately with the message "kmem: invalid kernel
    virtual ad...

Changed in crash (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (102.4 KiB)

This bug was fixed in the package crash - 6.1.6-1ubuntu0.12.10.1

---------------
crash (6.1.6-1ubuntu0.12.10.1) quantal-proposed; urgency=low

  * Merge from Debian unstable (LP: #1064475). Remaining changes:
    - debian/rules: Always build extensions and package them.
    - debian/rules: Cleanup for extensions.
  * Dropped ubuntu changes:
    - SPU extension support.
  * debian/control: Add armhf to build architectures.

crash (6.1.6-1) unstable; urgency=low

  * New upstream version 6.1.6

  * Fix for a crash-6.1.5 regression that causes the "mount" command to fail
    on kernel versions prior to Linux 3.3. Without the patch, the command
    fails with the message "mount: invalid structure member offset:
    mount_mnt_devname".

crash (6.1.5-1) UNRELEASED; urgency=low

  * New upstream version 6.1.6

  * Fix for the ARM "irq" command. Without the patch, on 2.6.34 and later
    kernels configured with CONFIG_SPARSE_IRQ, the command fails with the
    error message "irq: cannot determine number of IRQs".

  * Fix for a segmentation violation generated during invocation while parsing
    a makedumpfile-created "flat-format" vmcore-incomplete file. Without the
    patch, the crash session would display the error message "crash: unable to
    seek dump file vmcore-incomplete", followed by a segmentation violation.

  * Fix for a segmentation violation generated by the "kmem -s" option when
    encountering a corrupted array_cache structure that contains a bogus
    "avail" count that is greater than the maximum legitimate limit value.
    Without the patch, the "kmem -s" command would print a warning message
    regarding the invalid array_cache, complete the command normally, and then
    generate a segmentation violation when freeing buffers used by the
    command.

  * Update to the "kmem -s" function to include the errors found in slab
    structures to the display of total errors found when the command
    completes. Without the patch, invalid list_head pointers, bad inuse
    counters, and bad s_mem pointers were not added to the total number of
    errors found.

  * Fix for "crash --osrelease <dumpfile>" and "crash --log <dumpfile>" when
    run on an ARM compressed kdump with a crash binary that was built with
    "make target=ARM" on an x86 or x86_64 host. Without the patch, if the
    compressed kdump header version is 4 or 5, "crash --osrelease" fails with
    the error message "crash: compressed kdump: cannot lseek dump vmcoreinfo"
    followed by "unknown", and "crash --log" fails with the error message
    "crash: <dumpfile>: no VMCOREINFO section".

  * Enhancement to the "swap" command to display the swap_info_struct address
    of each configured swap device. The output has been changed to display
    the address in the first column, and the variable-length device name has
    been moved to the last column.

  * Fix for the "kmem -[sS]" options on kernels that configured with both
    CONFIG_SLUB and CONFIG_NODES_SHIFT, and that are running on hardware that
    generates NUMA nodes that contain no memory. Without the patch, both
    command options fail immediately with the message "kmem: invalid kernel
    virtual ad...

Changed in crash (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (26.7 KiB)

This bug was fixed in the package crash - 6.1.6-1ubuntu0.13.04.1

---------------
crash (6.1.6-1ubuntu0.13.04.1) raring-proposed; urgency=low

  * Merge from Debian unstable (LP: #1064475). Remaining changes:
    - debian/rules: Always build extensions and package them.
    - debian/rules: Cleanup for extensions.
  * Dropped ubuntu changes:
    - SPU extension support.
  * debian/control: Add armhf to build architectures.

crash (6.1.6-1) unstable; urgency=low

  * New upstream version 6.1.6

  * Fix for a crash-6.1.5 regression that causes the "mount" command to fail
    on kernel versions prior to Linux 3.3. Without the patch, the command
    fails with the message "mount: invalid structure member offset:
    mount_mnt_devname".

crash (6.1.5-1) UNRELEASED; urgency=low

  * New upstream version 6.1.6

  * Fix for the ARM "irq" command. Without the patch, on 2.6.34 and later
    kernels configured with CONFIG_SPARSE_IRQ, the command fails with the
    error message "irq: cannot determine number of IRQs".

  * Fix for a segmentation violation generated during invocation while parsing
    a makedumpfile-created "flat-format" vmcore-incomplete file. Without the
    patch, the crash session would display the error message "crash: unable to
    seek dump file vmcore-incomplete", followed by a segmentation violation.

  * Fix for a segmentation violation generated by the "kmem -s" option when
    encountering a corrupted array_cache structure that contains a bogus
    "avail" count that is greater than the maximum legitimate limit value.
    Without the patch, the "kmem -s" command would print a warning message
    regarding the invalid array_cache, complete the command normally, and then
    generate a segmentation violation when freeing buffers used by the
    command.

  * Update to the "kmem -s" function to include the errors found in slab
    structures to the display of total errors found when the command
    completes. Without the patch, invalid list_head pointers, bad inuse
    counters, and bad s_mem pointers were not added to the total number of
    errors found.

  * Fix for "crash --osrelease <dumpfile>" and "crash --log <dumpfile>" when
    run on an ARM compressed kdump with a crash binary that was built with
    "make target=ARM" on an x86 or x86_64 host. Without the patch, if the
    compressed kdump header version is 4 or 5, "crash --osrelease" fails with
    the error message "crash: compressed kdump: cannot lseek dump vmcoreinfo"
    followed by "unknown", and "crash --log" fails with the error message
    "crash: <dumpfile>: no VMCOREINFO section".

  * Enhancement to the "swap" command to display the swap_info_struct address
    of each configured swap device. The output has been changed to display
    the address in the first column, and the variable-length device name has
    been moved to the last column.

  * Fix for the "kmem -[sS]" options on kernels that configured with both
    CONFIG_SLUB and CONFIG_NODES_SHIFT, and that are running on hardware that
    generates NUMA nodes that contain no memory. Without the patch, both
    command options fail immediately with the message "kmem: invalid kernel
    virtual add...

Changed in crash (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers