No window decorations

Bug #197820 reported by Kristoffer Lundén on 2008-03-03
306
This bug affects 24 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned
crack-attack (Ubuntu)
Low
Unassigned

Bug Description

There are a number of cases when window decorations are not present/are invisible:
- Running glut programs, e.g. crack-attack
- Using 16 bit color mode
- On all applications after login

The decorations may be invisible but working or not present at all

Can not reproduce issue in Gutsy (crack-attack 1.1.14-6ubuntu1)

Changed in crack-attack:
importance: Undecided → Low

Correct, it worked fine under Gutsy for me as well, but I don't have a Gutsy install handy at the moment...

Could someone please try it under Hardy?

I see this issue too - crack attack's game window gets no window decorations with Compiz enabled on Intel GMA X3100, though the initial game settings windows does. Same goes for mplayer's video window if using the -vo gl or -vo gl2 output drivers.

Note, the widgets in the window border are there, and responsive - they're just invisible.

Seems to be something to do with OpenGL interacting with Compiz, but not all OpenGL apps are affected; glxgears gets proper decoration.

Also, if you drag a window containing OpenGL graphics around the screen while it's running, it leaves "trails" behind - screenshot attached. This goes for glxgears as well as the apps whose window decorations don't render properly.

Screenshot attached, showing the Experience Ubuntu video in mplayer's -vo gl mode, having been dragged around the screen then paused. And crack attack's game window. Both with no visible decoration. The shell window is, as you can see, decorated correctly.

Sorry, should have mentioned, I'm running Hardy, with everything up to date as of last night.

Changed in crack-attack:
status: New → Confirmed
Basilio Kublik (sourcercito) wrote :

Hi Kristoffer
you report this issue some time ago and hasn't been any activity in a while, i was wondering if this is still an issue for you with the latest upgrades in Hardy Heron.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete

Yes.

Yeah, it still happens here, too - though it affects several GL applications, not just Crack Attack.

Changed in compiz:
assignee: sourcercito → nobody
status: Incomplete → Confirmed
alex_b (barth-alexander) wrote :

Same problem here (Hardy with all updates and intel 915GM graphics card).
The problem does also appears with very simple freeglut programs such as the GLUT example lorenz:

http://freeglut.cvs.sourceforge.net/*checkout*/freeglut/freeglut/freeglut/progs/demos/Lorenz/lorenz.c?revision=1.8

To compile with:
gcc -o lorenz lorenz.c -lglut -lGL -lGLU

Alex

alex_b (barth-alexander) wrote :

I found this thread with the same issue:
http://forum.compiz-fusion.org/showthread.php?p=54517

Knut Karevoll (gnonthgol) wrote :

This is not a problem with crack-attack itself, but with the combination of glut and compiz.

Changed in crack-attack:
status: Confirmed → Invalid

Problem persists in Jaunty, updated as of 2008-03-20.

summary: - No window decorations under compiz
+ No window decorations
Robert Ancell (robert-ancell) wrote :

Summary of duplicates:
- Can occur for all applications after login
- Specifically reported for Thunderbird, Kalarm, Krusader2, Konsole, KTimetracker
- Can occur when 16 bit graphics enabled, fixed by increasing to 24/32 bits.

Changed in compiz (Ubuntu):
importance: Low → Medium
Robert Ancell (robert-ancell) wrote :

From duplicate bug 373479:

I have no windows decorations on start up with desktop effects enabled. When run from the command line the command "compiz" gives no major errors and appears to be working. The output is at the end of this description. However, when I attempt to run either emerald or gtk-window-decorator, I do not get any window decorations. The programs appear to start, give no command line errors, and show up in running processes, but don't actually create decorations.

There are some other odd behaviors. I can't do standard wm behaviors like desktop switching. Trying to minimize a window using the right click window menu (accessed from the window list) has no affect. Windows cannot be resized or moved.

However, at least some compositing seems to be going on, because gnome-do (docky theme) works, transparency, resizing, and all.

Most interestingly, there is a work around for this problem. Running "compiz.real --indirect-rendering" and then "emerald --replace." However the startup information for the command "compiz" suggests compiz is using indirect rendering anyways. Also, if emerald is already running, and I run compiz.real --indirect-rendering, I will get window decorations.

description: updated
Etienne Lepercq (e-guepe) wrote :

I reported bug #348432 and tried to install fusion-icon.
When fusion-icon is loaded at session startup, compiz is ok, BUT i have issues with GTK/Compiz configuration conflicts.

When using compiz, I lost the window decoration configured from GTK (I have a blue title with the wrong font). Changing pointer icon does not change until I log out/log in. I also lost some effects which I con't find where they are - like window shadow, menu clicking animations...
When switching to metacity window decorator, I regain the right window title, right font, right pointer icon :-(

So installing fusion-icon get me something lost from compiz configuration, but compiz successfully loads at login...

This is a pretty annoying bug !

Etienne Lepercq (e-guepe) wrote :

I would like to update my last comment.
When installing fusion-icon, I lost _all_ configurations inside compiz, no plugins was enabled.
I re-enabled quiet a fiew, but it took me some time to find everything.

But there is worse: I lost a lot of framerate: everything was very smooth, but now with fusion-icon the cube is not very smooth, Expose has a _very_ low framerate (about 10fps) on a 8600GTS video card. And again, everything was smooth.

I don't know what to do, I have all packages related to compiz (excepted those related to kde).

Etienne Lepercq (e-guepe) wrote :

I invastigated a little bit more. Using fusion-icon at session login "works" _but_ : framerate is DAMN slow !

I removed fusion-icon at startup : again, no window decoration at startup. If I enable compiz settings, compiz launches but because after fusion-icon configuration I lost all standard settings from "normal" interface (appearance > Visual effects) I gain compiz... without anything checked.
Launching ccsm, enabling some effects (window decoration, move window etc...) I get again a normally fluid compiz... with the previous bug explained still there, window title has wrong font/color !
So it seems that there are several configuration conflicts between metacity, compiz, fusion-icon... which installation made more damages than gains.

Changed in compiz (Ubuntu):
status: Confirmed → Triaged

In my case, to make everything work, I had to add something to "applications startup" (I am not sure about the translation since I use a French system) OR in a terminal screen type "gnome-session-properties"

You can test this option with the command line interface to see if it works before addind it to the gnome-session-properties:

"compiz --replace"

This is, of course, a workaround, not the solution.

Martin Albisetti (beuno) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10

Changed in hundredpapercuts:
status: New → Invalid
Travis Watkins (amaranth) wrote :

There are way too many different issues here, I think.

The bug with GLUT apps appears to be fixed as I cannot reproduce anymore in karmic with Intel X3100.
The problem with using 16-bit color is Won't Fix.
In karmic we have new code to make sure compiz is setup correctly to show decorations no matter what may happen to its configuration so that should help some people.

Anyone running up-to-date karmic still having this issue should file a new bug or make their bug not a dupe of this one anymore.

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Martin Wimmer (martin-wimmer) wrote :

I upgraded three machines to karmic (64bit) and on 2 of them I get the problem.

On one of them (Notebook with ATI open source driver) this only appears on bootup. If have to launch Appearance Properties and reenable desktop effects. Then borders are shown normally

On the other machine (Intel onboard graphics i believe) borders never appear when desktop effects are enabled.

So this is not fixed in Karmic, actually it happens more often, at least for me! (Never had the bug in previous versions)

Andrew Saturn (saturn) on 2010-05-18
Changed in compiz (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Andrej Mosi (mosibiz) wrote :

Compiz crashed badly after normal update run.

After meddling with nvidia drivers, realized that the provided xorg-nouveau drivers will not work on my nvidia geforce 7600.

Have Ubuntu 11.10, tried proprietary drivers and all possible variations.

The "bug" in my case was: /etc/X11/xorg.conf
 default color depth 16 instead of 24

Lost 3 days of searching for the cause. Found solution by visiting " Duplicate of bug #197820 "

Would it be inconvenient to display a BIG FAT Warning to users running 16bit depth: "Please set your screen resolution to 24bit, otherwise compiz will crash" ???

What package would be a good candidate for this, i.e. whom should I bug?

Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments