cqrlog cann't remove from yakkety

Bug #1635267 reported by FanJun Kong - ( BH1SCW ) on 2016-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cqrlog (Ubuntu)
Undecided
Ubuntu ham developers
mysql-5.7 (Ubuntu)
Medium
Lars Tangvald

Bug Description

me@BH1SCW master* > sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  mysql-server mysql-server-5.7 mysql-server-core-5.7
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  mysql-server-5.7
Suggested packages:
  mailx tinyca
The following packages will be REMOVED:
  cqrlog
The following NEW packages will be installed:
  mysql-server-5.7
0 upgraded, 1 newly installed, 1 to remove and 5 not upgraded.
3 not fully installed or removed.
Need to get 0 B/2,748 kB of archives.
After this operation, 22.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 486641 files and directories currently installed.)
Removing cqrlog (2.0.1-1) ...
dpkg: error processing package cqrlog (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 cqrlog
E: Sub-process /usr/bin/dpkg returned an error code (1)

not sure why it broken dependcy.It seems that something wrong with mysql

Changed in cqrlog (Ubuntu):
assignee: nobody → Ubuntu ham developers (ubuntu-hams-devel)

seems like this is a bug about mysql not cqrlog

something wrong with /etc/apparmor.d/local/usr.sbin.mysqld

@{HOME}/.config/cqrlog/database/ r,
@{HOME}/.config/cqrlog/database/** rwk,

Lars Tangvald (lars-tangvald) wrote :

This does sound like the same issue as in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804920, in which case this is because we need to add a conflict on cqrlog in the MySQL packaging.

Changed in mysql-5.7 (Ubuntu):
assignee: nobody → Lars Tangvald (lars-tangvald)
Robie Basak (racb) on 2017-01-06
Changed in mysql-5.7 (Ubuntu):
importance: Undecided → Medium

is this bug confirmed in mysql?

Lars Tangvald (lars-tangvald) wrote :

My previous comment was about something else, as it's not the same issue.

I gave this a test by just installing and removing cqrlog, and it worked without error, so not sure what's happening here.

There isn't enough information here, I think.

Changed in cqrlog (Ubuntu):
status: New → Invalid
Robie Basak (racb) wrote :

The error and failure seems to come from cqrlog in the first instance. If we don't know what the problem is, I think it's reasonable to consider it a bug in cqrlog until we know otherwise.

Changed in mysql-5.7 (Ubuntu):
status: New → Invalid
Changed in cqrlog (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.