CPUSet is no more working on 3.2.0.26+

Bug #1028933 reported by Poil on 2012-07-25
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
cpuset (Ubuntu)
Undecided
Unassigned

Bug Description

cpuset is searching for (here on a 12.04 3.2.0.24)
ll /cpusets/
total 4
drwxr-xr-x 2 root root 0 Jul 24 11:14 ./
drwxr-xr-x 24 root root 4096 Jul 24 11:14 ../
-rw-r--r-- 1 root root 0 Jul 24 11:14 cgroup.clone_children
--w--w--w- 1 root root 0 Jul 24 11:14 cgroup.event_control
-rw-r--r-- 1 root root 0 Jul 24 11:14 cgroup.procs
-rw-r--r-- 1 root root 0 Jul 24 11:14 cpu_exclusive
-rw-r--r-- 1 root root 0 Jul 24 11:14 cpus
-rw-r--r-- 1 root root 0 Jul 24 11:14 mem_exclusive
-rw-r--r-- 1 root root 0 Jul 24 11:14 mem_hardwall
-rw-r--r-- 1 root root 0 Jul 24 11:14 memory_migrate
-r--r--r-- 1 root root 0 Jul 24 11:14 memory_pressure
-rw-r--r-- 1 root root 0 Jul 24 11:14 memory_pressure_enabled
-rw-r--r-- 1 root root 0 Jul 24 11:14 memory_spread_page
-rw-r--r-- 1 root root 0 Jul 24 11:14 memory_spread_slab
-rw-r--r-- 1 root root 0 Jul 24 11:14 mems
-rw-r--r-- 1 root root 0 Jul 24 11:14 notify_on_release
-rw-r--r-- 1 root root 0 Jul 24 11:14 release_agent
-rw-r--r-- 1 root root 0 Jul 24 11:14 sched_load_balance
-rw-r--r-- 1 root root 0 Jul 24 11:14 sched_relax_domain_level
-rw-r--r-- 1 root root 0 Jul 24 11:14 tasks

But in 3.2.0.26+ we have
ll /cpusets/
total 4
drwxr-xr-x 3 root root 0 Jul 24 17:19 ./
drwxr-xr-x 24 root root 4096 Jul 25 16:14 ../
-rw-r--r-- 1 root root 0 Jul 24 17:19 cgroup.clone_children
--w--w--w- 1 root root 0 Jul 24 17:19 cgroup.event_control
-rw-r--r-- 1 root root 0 Jul 24 17:19 cgroup.procs
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.cpu_exclusive
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.cpus
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.mem_exclusive
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.mem_hardwall
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.memory_migrate
-r--r--r-- 1 root root 0 Jul 24 17:19 cpuset.memory_pressure
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.memory_pressure_enabled
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.memory_spread_page
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.memory_spread_slab
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.mems
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.sched_load_balance
-rw-r--r-- 1 root root 0 Jul 24 17:19 cpuset.sched_relax_domain_level
drwxr-xr-x 4 root root 0 Jul 24 17:20 libvirt/
-rw-r--r-- 1 root root 0 Jul 24 17:19 notify_on_release
-rw-r--r-- 1 root root 0 Jul 24 17:19 release_agent
-rw-r--r-- 1 root root 0 Jul 24 17:19 tasks

So we need to change all path in the cset binary or we have this error
# cset set
cset: /cpusets/libvirt/lxc is not a cpuset directory
cset: **> /cpusets/libvirt/lxc is not a cpuset directory

Related branches

Poil (poil) on 2012-07-25
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cpuset (Ubuntu):
status: New → Confirmed
Poil (poil) wrote :

On 3.2.0.24
mount -t cgroup none /cpusets/ -o cpuset,noprefix
ll /cpusets/
total 4
drwxr-xr-x 2 root root 0 Jul 25 17:14 ./
drwxr-xr-x 24 root root 4096 Jul 24 11:14 ../
-rw-r--r-- 1 root root 0 Jul 25 17:14 cgroup.clone_children
--w--w--w- 1 root root 0 Jul 25 17:14 cgroup.event_control
-rw-r--r-- 1 root root 0 Jul 25 17:14 cgroup.procs
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpu_exclusive
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpus
-rw-r--r-- 1 root root 0 Jul 25 17:14 mem_exclusive
-rw-r--r-- 1 root root 0 Jul 25 17:14 mem_hardwall
-rw-r--r-- 1 root root 0 Jul 25 17:14 memory_migrate
-r--r--r-- 1 root root 0 Jul 25 17:14 memory_pressure
-rw-r--r-- 1 root root 0 Jul 25 17:14 memory_pressure_enabled
-rw-r--r-- 1 root root 0 Jul 25 17:14 memory_spread_page
-rw-r--r-- 1 root root 0 Jul 25 17:14 memory_spread_slab
-rw-r--r-- 1 root root 0 Jul 25 17:14 mems
-rw-r--r-- 1 root root 0 Jul 25 17:14 notify_on_release
-rw-r--r-- 1 root root 0 Jul 25 17:14 release_agent
-rw-r--r-- 1 root root 0 Jul 25 17:14 sched_load_balance
-rw-r--r-- 1 root root 0 Jul 25 17:14 sched_relax_domain_level
-rw-r--r-- 1 root root 0 Jul 25 17:14 tasks

mount -t cgroup none /cpusets/ -o cpuset
ll /cpusets/
total 4
drwxr-xr-x 2 root root 0 Jul 25 17:14 ./
drwxr-xr-x 24 root root 4096 Jul 24 11:14 ../
-rw-r--r-- 1 root root 0 Jul 25 17:14 cgroup.clone_children
--w--w--w- 1 root root 0 Jul 25 17:14 cgroup.event_control
-rw-r--r-- 1 root root 0 Jul 25 17:14 cgroup.procs
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.cpu_exclusive
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.cpus
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.mem_exclusive
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.mem_hardwall
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.memory_migrate
-r--r--r-- 1 root root 0 Jul 25 17:14 cpuset.memory_pressure
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.memory_pressure_enabled
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.memory_spread_page
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.memory_spread_slab
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.mems
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.sched_load_balance
-rw-r--r-- 1 root root 0 Jul 25 17:14 cpuset.sched_relax_domain_level
-rw-r--r-- 1 root root 0 Jul 25 17:14 notify_on_release
-rw-r--r-- 1 root root 0 Jul 25 17:14 release_agent
-rw-r--r-- 1 root root 0 Jul 25 17:14 tasks

But on 3.2.0.26+ noprefix option seems to be ignored (or broken)

Poil (poil) wrote :

Ok, I've reproduce it on 2 others servers
1- install cpuset
cset set
> working

2- Install libvirt
aptitude install -y qemu-kvm libvirt-bin virtinst kvm-pxe

3- try again
cset set
> working (/cpuset is always mounted with noprefix)

4- Reboot
reboot

5- Try cset again
cset set
> error, /cpuset is prefixed
ll /cpuset/

Alex Moldovan (alexmoldovan) wrote :

libvirt-bin depends on cgroup-lite and so cset is not working properly once cgroup-lite is installed and the computer rebooted.

Mark Petersen (mpetersen-peak6) wrote :

Is there a workaround? Is cgroup-lite really necessary for libvirt-bin?

Poil (poil) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cpuset - 1.5.6-3

---------------
cpuset (1.5.6-3) unstable; urgency=low

  * Include updated watch file.
  * Update Standards-Version to 3.9.4 (no changes)
  * Add Homepage field to debian/control
  * Patch cset.py to account for filesystem prefixes (LP: #1028933, #1075997)

 -- Roberto C. Sanchez <email address hidden> Sat, 03 Aug 2013 11:28:50 -0400

Changed in cpuset (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.