[FFe] kvm-ok Support for ARM Architecture is Missing

Bug #1194632 reported by Michael Reed on 2013-06-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
CPU-Checker
Undecided
Unassigned
cpu-checker (Ubuntu)
Undecided
Unassigned

Bug Description

Currently there is no support for Arm support using kvm-ok. Currently when I run kvm-ok I get the following output:

INFO: Your CPU does not support KVM extensions
KVM acceleration can NOT be used

[FFe]

We have ARM KVM support in the kernel, and now expect real A-15 server hardware to ship during the 13.10 cycle. So I think this bug has changed from hypothetical to real now. The patch is relatively small.

Testing: see MP for Brendan's results.

I suggest that we thoroughly test for regressions on the Intel side of things before uploading. We aren't changing Intel behaviour at all here - just trivially adding new code paths for ARM. I don't see how we can cause a regression for ARM here, ARM KVM support is new so it didn't work previously anyway.

Related branches

Michael Reed (mreed8855) on 2013-06-25
description: updated
Robie Basak (racb) wrote :

I've just uploaded a distro patch to ppa:racb/experimental for testing. In particular, I'm concerned to make sure that this doesn't accidentally break Intel. For Saucy I think we'll need an FFe whether it gets merged upstream or not, so I guess we need to test anyway.

Kees or Dustin: if it's not worth or we don't get this merged upstream and a new release soon, any objections to a distro patch in the meantime? Now that we finally have A-15s around and our kernel supports ARM KVM, it'd be great to get this in before release so all our tooling works.

Robie Basak (racb) on 2013-09-13
description: updated
summary: - kvm-ok Support for ARM Architecture is Missing
+ [FFe] kvm-ok Support for ARM Architecture is Missing
Robie Basak (racb) on 2013-09-18
description: updated
Colin Watson (cjwatson) wrote :

Fine by me - FFe ack.

However, since you're making it "Architecture: any", you probably ought to make sure that it does something vaguely sensible on powerpc (even if that's just to bail out with a suitable error), or else "Architecture: amd64 armhf i386".

Changed in cpu-checker (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cpu-checker - 0.7-0ubuntu3

---------------
cpu-checker (0.7-0ubuntu3) saucy; urgency=low

  * d/p/arm: add support for ARM Cortex-A15 systems (LP: #1194632). Thanks to
    dann frazier.
  * d/control: add armhf architecture, but restrict msr-tools dependency to
    x86.
 -- Robie Basak <email address hidden> Wed, 18 Sep 2013 13:53:45 +0000

Changed in cpu-checker (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers