Ubuntu

cpio FTBFS with glibc-2.16

Reported by Wookey on 2012-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cpio (Debian)
Fix Released
Unknown
cpio (Ubuntu)
Undecided
Unassigned

Bug Description

cpio does not build against eglibc-2.16 due to gets having been removed
but embedded gnulib in package still referring to it.

Upstream bug links are in the patch.

This patch makes it work by #ifdefing the offending line but the proper
fix is a new upstream release using a newer gnulib. Preferably by syncing from debian.

Wookey (wookey) wrote :
Changed in cpio (Debian):
status: Unknown → Confirmed

The attachment "cpio-2.11-8ubuntu3-glibc-2.16-fix.patch" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Colin Watson (cjwatson) wrote :

Yep, thanks - I've applied similar stopgap patches elsewhere, so this is fine (modulo version and target distribution, which I'll fix).

+++ Colin Watson [2012-11-16 17:00 -0000]:
> Yep, thanks - I've applied similar stopgap patches elsewhere, so this is
> fine (modulo version and target distribution, which I'll fix).

I've found 4 of these so far: cpio, gettext, tar and diffutils.
apparently m4 is also affected and no doubt others.

Wookey
--
Principal hats: Linaro, Emdebian, Wookware, Balloonboard, ARM
http://wookware.org/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cpio - 2.11-8ubuntu4

---------------
cpio (2.11-8ubuntu4) raring; urgency=low

  * Fix FTBFS with glibc-2.16 (due to outdated gnulib/gets removal;
    LP: #1079748).
 -- Wookey <email address hidden> Fri, 16 Nov 2012 16:59:53 +0000

Changed in cpio (Ubuntu):
status: New → Fix Released
Changed in cpio (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.