Ubuntu

package courier-base 0.61.2-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Reported by Mark A. Hershberger on 2009-08-13
110
This bug affects 19 people
Affects Status Importance Assigned to Milestone
courier (Debian)
Fix Released
Unknown
courier (Ubuntu)
High
Nicolas Valcarcel
Karmic
High
Unassigned
Lucid
High
Nicolas Valcarcel

Bug Description

As per subject... from a synaptic upgrade on karmic today.

ProblemType: Package
Architecture: amd64
Date: Thu Aug 13 15:24:45 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 2
Package: courier-base 0.61.2-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SourcePackage: courier
Title: package courier-base 0.61.2-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
Uname: Linux 2.6.31-5-generic x86_64

Mark A. Hershberger (hexmode) wrote :
Mark A. Hershberger (hexmode) wrote :

key bit:

update-alternatives: error: alternative link /usr/share/man/man5/maildir.5.gz is already managed by maildir.5.gz.

dpkg: error processing courier-base (--configure):

 subprocess installed post-installation script returned error exit status 2

So... the manpage link should be fixed or a conflict added or ... ?

Mark A. Hershberger (hexmode) wrote :

Specifically, maildrop define maildir.5.gz as the alternative and courier-base wants maildir.5. Confusion reigns!

Patch attached.

tags: added: patch
Changed in courier (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Changed in courier (Ubuntu Karmic):
status: New → Triaged
importance: Undecided → High
milestone: none → karmic-updates
Nicolas Valcarcel (nvalcarcel) wrote :

Can't reproduce it, i just did:
- Create a jaunty chroot
- install courier-base
- sed -e 's/jaunty/karmic/g' /etc/apt/sources.list
- apt-get update; apt-get install courier

The upgrade runned fine. No complains from apt.

Scott Kitterman (kitterman) wrote :

You need to install maildrop first.

Darik Horn (dajhorn) wrote :

Note that there are two maildrop providers in Karmic:

  * http://packages.ubuntu.com/karmic/maildrop
  * http://packages.ubuntu.com/karmic/courier-maildrop

This glitch happens only with the non-courier maildrop package. Any easy fix for me was:

  $ apt-get remove maildrop
  $ apt-get install courier-maildrop

Downgrading to the Jaunty package also works.

John Dong (jdong) wrote :

ACK from motu-sru for the diff attached.

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in courier (Ubuntu Karmic):
status: Triaged → Fix Committed
tags: added: verification-needed
Febri (theblues-zero) on 2009-11-20
Changed in courier (Ubuntu Karmic):
status: Fix Committed → Incomplete
status: Incomplete → New
Febri (theblues-zero) on 2009-11-20
Changed in courier (Ubuntu Karmic):
assignee: nobody → Febri (theblues-zero)
Changed in courier (Ubuntu Karmic):
status: New → Fix Committed
Changed in courier (Ubuntu Lucid):
status: Triaged → In Progress
assignee: nobody → Nicolas Valcárcel (nvalcarcel)
Changed in courier (Ubuntu Lucid):
status: In Progress → Fix Released
Changed in courier (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in courier (Ubuntu Karmic):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) on 2009-12-13
Changed in courier (Ubuntu Karmic):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
assignee: Febri (theblues-zero) → nobody
Martin Pitt (pitti) wrote :

Any testers?

Mitch Towner (kermiac) wrote :

I can confirm the install error
$ uname -a
Linux ubuntu 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

$ sudo apt-cache policy maildrop
maildrop:
  Installed: 2.0.4-3
  Candidate: 2.0.4-3
  Version table:
 *** 2.0.4-3 0
        500 http://mirror.optus.net karmic/universe Packages
        100 /var/lib/dpkg/status

Installing "courier-base 0.61.2-1ubuntu2" returned "dpkg: error processing courier-base (--configure):
 subprocess installed post-installation script returned error exit status 2"

______________________________________

Enabled "proposed" to verify fix for SRU
$ uname -a
Linux ubuntu 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

$ sudo apt-cache policy maildrop
maildrop:
  Installed: 2.0.4-3
  Candidate: 2.0.4-3
  Version table:
 *** 2.0.4-3 0
        500 http://mirror.optus.net karmic/universe Packages
        100 /var/lib/dpkg/status

$ sudo apt-cache policy courier-base
courier-base:
  Installed: 0.61.2-1ubuntu3
  Candidate: 0.61.2-1ubuntu3
  Version table:
 *** 0.61.2-1ubuntu3 0
        500 http://mirror.optus.net karmic-proposed/universe Packages
        100 /var/lib/dpkg/status
     0.61.2-1ubuntu2 0
        500 http://mirror.optus.net karmic/universe Packages

All packages installed without error.

I think someone else may need to double check as I'm not sure I configured everything correctly as I have not setup a mail server before. The best tutorial I could find was slightly modifying the instructions at http://www.howtoforge.org/perfect-server-ubuntu-9.10-ispconfig-3-p4 to test this package.

Martin Pitt (pitti) wrote :

Thank you for testing! Since the change only affect the packaging, not the actual upstream code, this looks sufficient.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package courier - 0.61.2-1ubuntu3

---------------
courier (0.61.2-1ubuntu3) karmic-proposed; urgency=low

  * Fix alternatived conflict with maildrop. (LP: #413252)
    Thanks to Mark A. Hershberger for the patch
 -- Nicolas Valcarcel Scerpella (Canonical) <email address hidden> Tue, 10 Nov 2009 10:21:40 -0500

Changed in courier (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in courier (Ubuntu Karmic):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Changed in courier (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.