package courier-authdaemon 0.62.2-1 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1

Bug #496261 reported by DantePasquale on 2009-12-13
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
courier-authlib (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: courier-authlib

Description: Ubuntu 9.10
Release: 9.10
courier-authdaemon:
  Installed: 0.62.2-1
  Candidate: 0.62.2-1
  Version table:
 *** 0.62.2-1 0
        500 http://us.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

conflict -- needed to remove ALL courier packages and maildrop, then could run install to fix.

ProblemType: Package
Architecture: amd64
Date: Sun Dec 13 12:34:06 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed pre-removal script returned error exit status 1
Package: courier-authdaemon 0.62.2-1
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: courier-authlib
Title: package courier-authdaemon 0.62.2-1 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1
Uname: Linux 2.6.31-17-generic x86_64

DantePasquale (dantepasquale) wrote :
Clint Byrum (clint-fewbar) wrote :

Since there are 5 affected by this, marking as Confirmed, importance Medium.

Has anyone experienced this on 10.04 or later? 9.10 is hitting EOL at the end of April, so its unlikely this will be SRU'd to it.

tags: added: karmic
Changed in courier-authlib (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
kOoLiNuS (koolinus-gmail) wrote :

I don't know if it's the right place to fill in my "bug report" ... I had this error on Ubuntu 12.04.1 doing an upgrade via apt-get:

nicola@popeye:~$ sudo apt-get remove courier-authlib-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libmysqlclient16
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  courier-authlib-mysql
0 upgraded, 0 newly installed, 1 to remove and 5 not upgraded.
After this operation, 123 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 271905 files and directories currently installed.)
Removing courier-authlib-mysql ...
/var/run/courier/authdaemon/pid.lock: No such file or directory
dpkg: error processing courier-authlib-mysql (--remove):
 subprocess installed pre-removal script returned error exit status 1
Errors were encountered while processing:
 courier-authlib-mysql

After some other tries I had a:

dpkg - trying script from the new package instead ... /var/run/courier/authdaemon/pid.lock: No such file or directory

which lead me to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=540374 - a Debian's known bug since 2009 (!!!). Following the tip of starting courier-authdaemon, running the upgrade and then stopping it all went ok.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.