Repeated Ubuntu One address book errors

Bug #825280 reported by Jono Bacon on 2011-08-12
130
This bug affects 26 people
Affects Status Importance Assigned to Milestone
couchdb (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

With a recent update Thunderbird has become almost unusable with errors that say the follow appearing whenever I interact with my email:

There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Unauthorized

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 6.0~b3+build1+nobinonly-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
Date: Fri Aug 12 08:21:21 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunderbird
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (29 days ago)

Jono Bacon (jonobacon) wrote :
Changed in thunderbird (Ubuntu):
status: New → Confirmed
Jamie Pocas (pocas-jamie) wrote :

I see this message as well, except I only see it a few times (maybe three?) after Thunderbird startup and then I don't see them ever again in that process. If I restart Thunderbird then I see the error messages again a few times. Maybe I am not using as many features as the original poster and so I am not seeing them as often.

Pranesh Prakash (the-solipsist) wrote :

I see it every time Thunderbird starts up. Sometimes it continues after TB starts up as well.

It was a problem with TB 6.0 and continues to be a problem with TB 7.0.

Mark Rabideau (lorax-treemagic) wrote :

I also see the same problem in 11.10 with T'bird 7. It happens with every start of T'bird.

Ngassam Nkwenga (cyrildz) wrote :

every time, as I start Thunderbird , i get this message : There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Cannot process, book backend is opening

Chris Coulson (chrisccoulson) wrote :

From IRC:

<chrisccoulson> dobey, is there a bug for tracking the desktopcouch bustage?
<chrisccoulson> we should be tracking that for oneiric really, if people are expecting U1 contact sync to work in tbird
 bug 825280 is caused by it
<dobey> chrisccoulson: yes, mark any bugs like that as dup of 817656
<chrisccoulson> thanks

Marking as a duplicate of bug 817656, as that should fix the current desktopcouch breakage which causes this error

affects: thunderbird (Ubuntu) → couchdb (Ubuntu)
Changed in couchdb (Ubuntu):
status: Confirmed → Invalid
Kate Stewart (kate.stewart) wrote :

Since bug 817656 has been delayed to P, having this as a duplicate doesn't seem appropriate.

Have reset it back to confirmed. In 817656, there are indications that the bug is still present after the last update with some cherry picked fixes.

Changed in couchdb (Ubuntu Oneiric):
status: Invalid → Confirmed
importance: Undecided → High
tags: added: rls-mgr-o-tracking
Kate Stewart (kate.stewart) wrote :

Can one of the original reporters please confirm that they are still seeing this bug?

dobey (dobey) wrote :

Kate, there were two issues. One issue was that couchdb was causing a lot of authentication errors when trying to use desktopcouch. That issue was fixed. The second issue is that at some point a new version of evolution-data-server had some threading related changes, which would cause the "book backend is opening" error. It seems this later issue can possibly happen with any of the address book backends in evolution-data-server. This should be fixed already in current couchdb-glib for the couchdb backend, but the issue is likely in evolution-data-server if the "book backend is opening" issue still recurs.

Kate Stewart (kate.stewart) wrote :

Rodney, worth a release note then? Is there a workaround?

dobey (dobey) wrote :

Don't think there are any workarounds. Not enough data to know if it's still a solid issue that should have a release note either. Rodrigo might know better.

Rodrigo Moya (rodrigo-moya) wrote :

For evolution-couchdb it should be fixed indeed, haven't seen reports of that problem with other backends, so I don't think we need a release note at all.

Also, about this bug, does it still happen with the latest Oneiric packages? As I said, this should already be fixed, so please make sure you have the latest packages installed.

dobey (dobey) wrote :

Rodrigo, this comment at least suggest it happens for the gmail backend: https://bugs.launchpad.net/ubuntu/+source/couchdb/+bug/817656/comments/18

primefalcon (primefalcon) wrote :

yes it does happen with the gmail backend at least, I just started thunderbird from terminal and it gave this error if it helps (I also have attached a screenshot of the notification alert)

(thunderbird-bin:4468): libebook-WARNING **: e_book_client_new: Cannot get book from factory: Invalid source

primefalcon (primefalcon) wrote :

I assume this has been worked on a fair bit, it used to say missing, now it says opening so.....

MNLipp (mnl) wrote :

I can confirm that this bug still exists in the officially published 11.10 from yesterday. Very annoying...

Philippe (philippe-rast) wrote :

Same here - I never had this problem under 11.04. After upgrading to 11.10 I get "There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Cannot process, book backend is opening" right after starting Thunderbird 7.0.1.

Same for me:

There was a problem opening the address book "xxxxxxxxx" - the message returned was: Cannot open book: Cannot process, book backend is opening

This is annoying, but the message is repeated just 2-3 times after cklicking OK.

More annoying is the error of the calendar app:

Enter password for calendar....

Message show up several 10+ times, but the app is fine.

Is there a workaround in the meantime?

Thunderbird 7.0.1 on Ubuntu 11.10

David (droe) wrote :

Same problem here. I've updated my system to 11.10 two days ago. Whenever I open an email or any folder in Thunderbird (v 7.0.1) the following message appears:

<<There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Bad Request>>

I can work around this problem by deleting the address book "Ubuntu One" for one Thunderbird session. When I do this, I get the following message:

<<Sorry - this version of EDS Contacts Integration does not support deleting Evolution address books. Due to the way that Thunderbird tries to delete address books, all of your EDS address books will appear to be removed from the address book manager. Simply restart Thunderbird in order to have them return.>>

And indeed, as soon as I restart Thunderbird, the address book comes back and with it the problem described above.

David (droe) wrote :

I could fix the problem by removing Evolution mail client.

Bill Loucks (biloucks) wrote :

Removing Evolution mail client is a totally unacceptable solution for me. It amazes me that such a serious bug hasn't even been ASSIGNED to anyone yet. I was so upset that I rolled back my whole distribution upgrade and have no intention of upgrading to 11.10 until this bug is fixed. There have got to be thousands of Ubuntu fans who use Thunderbird instead of Evolution as their email client. It's about time the Ubuntu developers start taking Thunderbird bugs seriously, and it's far past time to get this bug assigned to someone.

Howard Cheng (howard-cheng) wrote :

Removing evolution does not work for me. I still have exactly the same problem as david-roerich has reported.

Howard Cheng (howard-cheng) wrote :

Correction: removing evolution does work after I have also killed the remaining couchdb processes.

Si Dedman (si-dedman) wrote :

I have the same problem with address book "Contacts". I used to use evolution on this install (11.10) so will try removing it.

Si Dedman (si-dedman) wrote :

nope, no change.

Gladys Luque (gladysmluque) wrote :

This bug affects me too. Also everything (navigating internet, writing emails, my son playing club Penguin, etc.) became slower and sometimes the computer freezes and I have to reset it. Although it hasn't reached such levels of awfulness, it is begining to remind me of Windows XP ;-)

Help me!

opt (opt) wrote :

Same for me: freeze after a "while" (few mnutes to few hours, randomly)
And can't use thunderbird: it start, retrieve all new mail from POPs, then
"""
(thunderbird-bin:3079): libebook-WARNING **: e_book_client_new: Cannot get book from factory: Invalid source
"""

opt (opt) wrote :

Sorry, forgot sytem "details":
it's on "Version 12.04 (precise) 64 bits" with "Noyau Linux 3.2.0-24-generic" on an "Intel® Core™ i7-3770 CPU @ 3.40GHz" with 16GB Ram

opt (opt) wrote :

Fixed for me by:
- Uninstall Evolution
- Uninstall UbuntuOne
- Force "thunderbird 11.0.1+build1-0ubuntu2"
- Reinstall Evolution
- Update to "thunderbird 12..."

After that thunderbird works fine... didn't understand why !?!?

opt (opt) wrote :

Sorry not fixed :-(
After 30mn thunderbird quit with same error... and won't restart ;(

Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in couchdb (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers