libjs-jquery 1.4.2 => 1.5 breaks Couchdb-Futon (TypeError, no method httpData)

Bug #716237 reported by Jason Gerard DeRose on 2011-02-10
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
CouchDB
Fix Committed
Undecided
Unassigned
couchdb (Ubuntu)
Undecided
Chad Miller
jquery (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: couchdb

The recent libjs-jquery 1.4.2 => 1.5 update appears to break Futon... I'm getting a "$.httpData is not a function" JavaScript error when i visit /_utils/

Screenshot attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: couchdb-bin 1.0.1-0ubuntu10
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
Uname: Linux 2.6.38-2-generic x86_64
Architecture: amd64
CheckboxSubmission: fdbdfcded0c0bb479a6b52e9ec5af131
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Wed Feb 9 20:44:00 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: couchdb

Related branches

lp:~jderose/ubuntu/natty/couchdb/fix-716237
Martin Pitt: Approve on 2011-03-04
Jason Gerard DeRose (jderose) wrote :
Chad Miller (cmiller) wrote :

Confirmed on change of only libjs-jquery from 1.4.2-2ubuntu1 to 1.5-2ubuntu1.

"""Server information could not be retrieved: TypeError: Object function ( selector, context ) {
  // The jQuery object is actually just the init constructor 'enhanced'
  return new jQuery.fn.init( selector, context, rootjQuery );
 } has no method 'httpData'"""

summary: - Recent libjs-jquery 1.4.2 => 1.5 update breaks Futon
+ libjs-jquery 1.4.2 => 1.5 breaks Couchdb-Futon (TypeError, no method
+ httpData)
Changed in jquery (Ubuntu):
status: New → Confirmed
Jason Gerard DeRose (jderose) wrote :

Was just talking to jan____ in #couchdb... in newest upstream work, Futon still doesn't work with jquery 1.5... so if 1.5 is the version in Natty, I think CouchDB is going to have to use it's own internal 1.4.2 version.

Stuart Langridge (sil) wrote :

The problem is in jquery.couch.js and jquery.form.js. Latest couchdb trunk fixes these problems.

<rnewson> aquarius: this was fixed 2011-02-05 with r1067420
<rnewson> "Make compatible with jQuery 1.5.x"
<rnewson> 064a1d9483cfa33bd0fcc97cb1d97e8e342fdeaf by Jason Davies.

http://friendpaste.com/6dZ6seCUQSphLsb9PL6udP contains the bulk of the patch (but not the calls *to* httpData). We should backport the patch.

Chad Miller (cmiller) on 2011-02-16
Changed in jquery (Ubuntu):
status: Confirmed → New
Changed in couchdb:
status: New → Confirmed
Changed in couchdb (Ubuntu):
status: New → Confirmed
assignee: nobody → Chad Miller (cmiller)
Changed in couchdb:
status: Confirmed → Fix Committed
Changed in jquery (Ubuntu):
status: New → Invalid
Jason Gerard DeRose (jderose) wrote :

I have a proposed a fix here:

https://code.launchpad.net/~jderose/ubuntu/natty/couchdb/fix-716237/+merge/51592

I also have test packages (build pending) in Novacut Daily PPA:

https://launchpad.net/~novacut/+archive/daily

PeterPall (peterpall) wrote :

The solution from this ppa works fine on my box (intel atom, 32 Bit).

Jason Gerard DeRose (jderose) wrote :

Okay, new merge proposal, I guess... I didn't quite understand what "Resubmit proposal" would do, not sure if that was the correct Launchpad way or not.

Anyway, thanks to Martin Pitt's review, I reworked the change as a patch in debian/patches:

https://code.launchpad.net/~jderose/ubuntu/natty/couchdb/fix-716237/+merge/52160

PetterPall - thanks for giving the PPA build a spin, confirming it works for you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package couchdb - 1.0.1-0ubuntu12

---------------
couchdb (1.0.1-0ubuntu12) natty; urgency=low

  * debian/patches/jquery15-fix.patch: Make Futon work with jQuery 1.5 via
    git commit 064a1d9483cfa33bd0fcc97cb1d97e8e342fdeaf (LP: #716237)
 -- Jason Gerard DeRose <email address hidden> Fri, 04 Mar 2011 11:08:10 +0100

Changed in couchdb (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers