Please merge couchdb 0.11.0-1 (main) from Debian unstable (main)

Bug #591444 reported by Clint Byrum on 2010-06-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
couchdb (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: couchdb

Merge to latest version marked as requirement for this blueprint:

https://blueprints.launchpad.net/ubuntu/+spec/server-maverick-cloud-datastores

Changed in couchdb (Ubuntu):
status: New → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
Clint Byrum (clint-fewbar) wrote :

debian unstable version (0.11.0-1) patch to 0.11.0-1ubuntu1

Clint Byrum (clint-fewbar) wrote :

couchdb lucid (0.10.0-1ubuntu2) to maverick (0.11.0-1ubuntu1) patch

Clint Byrum (clint-fewbar) wrote :

these changes were tested to build correctly in a pbuilder environment on my maverick machine.

Changed in couchdb (Ubuntu):
assignee: Clint Byrum (clint-fewbar) → nobody
status: In Progress → Confirmed
Mathias Gug (mathiaz) wrote :

@Elliot: do you have a comment for the version of couchdb to be used in maverick?

Mathias Gug (mathiaz) wrote :

@clint: reviewing the attached patch the changelog entry is missing a lot of the changes (eg the coudb-bin package). It seems that only the ubuntu2 entries were added. ubuntu1 entries should also be added. I'd suggest to prepare the merge and then review the patch with the version from Debian unstable to make sure everything is still relevant and documented in the changelog entry.

Changed in couchdb (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Elliot Murphy (statik) wrote :

Hi, version 0.11 will be ok for maverick but we will need to do updates to desktopcouch at the same time. I am happy to help review this when it's ready.

Mathias Gug (mathiaz) wrote :

A few comments on the attached patch:

 * the changelog entry needs to document all the *current* changes between Debian and Ubuntu as well as the patches that have been dropped since the merge. Using the last merge log entry (0.10.0-1ubuntu1) as a template is usually a good way to start.
 * debian/control: I would use a new line for all of the Ubuntu dependencies in order to make the diff easier to review. If Debian adds some dependencies to the line it would inter-mix with the Ubuntu addition making the review harder (ie put erlang-crypto, erlang-inets, erlang-xmerl, on its own line).
 * Breaks/Replaces for 0.10.0~svn818859-0ubuntu1 are no longer necessary since upgrade from lucid are the only one supported. It should also make the delta with Debian smaller - so easier to review.
 * refer this bug number in the changelog entry:

     * Merge from debian unstable. Remaining changes: (LP: #591444)

I would also suggest to use bzr branches instead of patches attached to this bug. Using merge proposal will make it easier for the review process as well.

Mathias Gug (mathiaz) wrote :

@Elliot does desktopcouch need to be *uploaded* at the same time as couchdb 0.11? Or filling a bug against desktopcouch once couchdb 0.11 has been uploaded is enough?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package couchdb - 0.11.0-1ubuntu1

---------------
couchdb (0.11.0-1ubuntu1) maverick; urgency=low

  * Merge from debian unstable. Remaining changes: (LP: #591444)
    - debian/patches/fix-help2man.patch, debian/control: build with help2man
      >= 1.37; add --no-discard-stderr
    - debian/patches/init.patch: updated to account for upstream conflicting
      changes
    - debian/rules, debian/control: split couchdb and couchdb-bin
    - debian/control: add missing erlang-{inets,crypto,xmerl}
      (build-)dependencies
    - debian/patches/mozjs_ldlibpath.patch, debian/control: change version
      of xulrunner to xulrunner-1.9.2
    - debian/control: transition from libmozjs-dev to xulrunner-dev in
      ubuntu
    - debian/rules, debian/control: grab the current xulrunner version with
      "xulrunner --gre-version" to use as a dependency
    - debian/postinst: renamed to couchdb-bin.postinst, change the default
      permissions on /etc/couchdb to 0775 and files to 0664
    - debian/couchdb-bin.postrm: don't try to delete couchdb system
      user/group
  * erlang-depends, pass explicit -pcouchdb-bin

couchdb (0.11.0-1) unstable; urgency=medium (security fixes)

  * New upstream release, including security fix for CVE-2010-00009.
    (closes: #576304, #577417)
  * Removed debian/patches/icu-patch.patch, as it's no longer needed.

couchdb (0.10.1-2) unstable; urgency=low

  [ Elliot Murphy ]
  * Updated debian/control, added Elliot to Uploaders
  * Dropped $ENABLE_SERVER portion of debian/patches/init.patch

  [ Sam Bisbee ]
  * Updated debian/patches/init.patch, adding a grace period to the init
    script's stop task to allow couchdb's child processes (ie., heart) a chance
    to exit before deciding whether the task was successful or not. This adds a
    dependency on procps (`ps` command).
  * Removed debian/preinst, undoing killall preinst patch from 0.10.0-1 that is
    no longer needed due to the grace period init patch in this release. This
    also removes the dependency on psmisc. (closes: #562901)
  * Updated debian/control, bumping Debian standards version to 3.8.4.
  * Updated debian/control, adding mawk as a dependency. The majority of
    systems will have it installed with the base system, but it's required and
    not essential. (closes: #569965)

couchdb (0.10.1-1) unstable; urgency=low

  * New upstream release (closes: #550782).
  * Cleaning up nmu related lintian warnings.
 -- Clint Byrum <email address hidden> Tue, 08 Jun 2010 23:16:21 -0700

Changed in couchdb (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers