couchdb fails to start with xulrunner-1.9, needs xulrunner-1.9.1

Bug #419082 reported by Joshua Timberman on 2009-08-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
couchdb (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: couchdb

For CouchDB, you need to install xulrunner-1.9.1. When installing just CouchDB via apt:

Setting up couchdb (0.10.0~svn806985-0ubuntu1) ...
 * Starting database server couchdb
/usr/bin/couchdb: 38: xulrunner-1.9.1: not found [fail]
invoke-rc.d: initscript couchdb, action "start" failed.

Install xulrunner-19.1:

Selecting previously deselected package xulrunner-1.9.1.
Unpacking xulrunner-1.9.1 (from .../xulrunner-1.9.1_1.9.1.2+nobinonly-0ubuntu3_i386.deb) ...
Setting up couchdb (0.10.0~svn806985-0ubuntu1) ...
 * Starting database server couchdb [ OK ]

The couchdb package needs to depend on xulrunner-1.9.1 instead of 1.9

Joshua Timberman (jtimberman) wrote :

Affects installation of Chef Server, which depends on CouchDB. Once the xulrunner-1.9.1 package is installed, it finishes configuring everything fine, though.

James Henstridge (jamesh) wrote :

Attached is the change Elliot made to the couchdb snapshot package we had in the private UbuntuOne PPA. It should solve the problem.

It looks like it is missing a patch to the debian/control file to update the xulrunner-1.9 dependency to xulrunner-1.9.1 though.

James Henstridge (jamesh) wrote :

Actually, looks like the above patch is already in the karmic package. Sorry for noise.

Joshua Timberman (jtimberman) wrote :

No worries, I talked to SteveA on #couchdb and he said this was known and pending an update. Thanks James!

Markus Korn (thekorn) on 2009-08-26
Changed in couchdb (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers