CouchDB has excessive dependencies

Bug #385104 reported by James Henstridge
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
couchdb (Debian)
Fix Released
Unknown
couchdb (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: couchdb

In Karmic, the erlang-nox package was split into multiple smaller packages leaving erlang-nox as a dummy dependency package.

The couchdb package still depends on erlang-nox though, so brings in a large number of libraries it doesn't actually require to run. I put together a package in my PPA that reduces the dependencies to those that are actually needed. The build record and debdiff are available here:

https://launchpad.net/~jamesh/+archive/ppa/+sourcepub/642347/+listing-archive-extra

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package couchdb - 0.9.0-2ubuntu2

---------------
couchdb (0.9.0-2ubuntu2) karmic; urgency=low

  * Change erlang-nox dependency to erlang-inets. (LP: #385104)

 -- James Henstridge <email address hidden> Tue, 02 Jun 2009 17:17:40 +0800

Changed in couchdb (Ubuntu):
status: New → Fix Released
Revision history for this message
James Henstridge (jamesh) wrote :

When testing things after asac's 0.9.0-2ubuntu1 release, I found that I missed some dependencies, so the previous package from my PPA was broken. The problem only presented itself at runtime though, which is why I didn't catch it immediately.

Here is the fixed package, which adds dependencies on erlang-crypto and erlang-xmerl:

https://launchpad.net/~jamesh/+archive/ppa/+sourcepub/648119/+listing-archive-extra

With this change, all but one of the tests in the couchdb test suite pass, and the remaining one is apparently a known issue. It also fixes up the LD_LIBRARY_PATH changes to put the xulrunner directory first, which is necessary if the user also happens to have libmozjs-dev installed.

Changed in couchdb (Ubuntu):
status: Fix Released → Confirmed
Changed in couchdb (Debian):
status: Unknown → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package couchdb - 0.9.0-2ubuntu3

---------------
couchdb (0.9.0-2ubuntu3) karmic; urgency=low

  * Add missing erlang-{crypto,xmerl} dependencies, thanks James Henstridge!
    (LP: #385104)

 -- Martin Pitt <email address hidden> Fri, 12 Jun 2009 18:06:25 +0200

Changed in couchdb (Ubuntu):
status: Confirmed → Fix Released
Changed in couchdb (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.