dd segmentation fault

Bug #75477 reported by Konrad Materka on 2006-12-12
4
Affects Status Importance Assigned to Milestone
coreutils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: coreutils

I'v tried to install win4lin, but bug is not releated to win4lin, because I can reproduse it by:
dd if=/dev/zero of="$IMGFILE" bs=1k count=$IMGSIZE >/dev/null 2>&1
eg:

konrad@server:~$ dd if=/dev/zero of=st.img bs=1k count=600
600+0 records in
600+0 records out
Naruszenie ochrony pamięci == Segmentation fault in Polish
konrad@server:~$

I tired:
konrad@server:~$ LANG=C dd if=/dev/zero of=st.img bs=1k count=600
600+0 records in
600+0 records out
614400 bytes (614 kB) copied, 0.006742 seconds, 91.1 MB/s
konrad@server:~$

and everything is OK.

dd doesn't work with:
LANG=pl_PL.UTF-8 (set by default)

dd works when LANG is set to:
pl_PL
ca_ES.UTF-8
C
and everything else

The problem is releated to other users:
"The funny thing is that I tried the "dd" command, and kept getting a segment violation in Catalan, which is the lenguage I use. I logged off, selected English and... the thing works. Images are created,(...) " - http://www.win4lin.com/phpBB2/viewtopic.php?p=12298

so it is quite importand bug...

More info:

http://www.win4lin.com/phpBB2/viewtopic.php?p=12298
http://www.win4lin.com/phpBB2/viewtopic.php?p=12810

Vassilis Pandis (pandisv) wrote :

Thanks for reporting this. This is indeed an important which has been mostly fixed now acording to Martin Pitt. This is also known as bug 42264.

Konrad Materka (kmaterka) wrote :

22 duplicates - sorry I missed that, but this bug is very old and still not fixed, so i thought that no-one reported it. My fault I haven't spend more time searching :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers