dd reporting Segmentation Fault

Bug #63514 reported by anonym on 2006-10-02
2
Affects Status Importance Assigned to Milestone
coreutils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: coreutils

It seems like this is happening on a number of boxes, dd is always reporting a segfault, like so:

shoobs@fabiana:~$ dd if=/dev/cdrom count=1 of=/mnt/storage/bab.iso
1+0 records in
1+0 records out
Segmentation fault

Here are a few links on ubuntuforums to others having the same problem:
http://ubuntuforums.org/showthread.php?t=247624&highlight=dd+segmentation+fault
http://ubuntuforums.org/showthread.php?t=232708&highlight=dd+segmentation+fault
http://ubuntuforums.org/showthread.php?t=266544&highlight=dd+segmentation+fault
http://ubuntuforums.org/showthread.php?t=267932&highlight=dd+segmentation+fault
http://ubuntuforums.org/showthread.php?t=236614&highlight=dd+segmentation+fault
http://ubuntuforums.org/showthread.php?t=265424&highlight=dd+segmentation+fault
http://ubuntuforums.org/showthread.php?t=240360&highlight=dd+segmentation+fault

And perhaps some diagnostics from another user with the same problem:
http://<email address hidden>/msg07807.html

Apparently a fix is to add LANG=en to the beginning of the command line, but I haven't had a chance to try it yet.

Thanks for the bug report. This particular bug has already been
reported into our bug tracking system, but please feel free to report
any further bugs which you find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers