dd segfaults on amd64

Bug #30088 reported by Tobi Vollebregt on 2006-01-30
2
Affects Status Importance Assigned to Milestone
coreutils (Ubuntu)
Medium
Unassigned

Bug Description

dd segfaults on amd64 when just before it should show the message "XX bytes transferred in YY seconds (ZZ bytes/sec)".

It happens no matter what I set the blocksize to.

This bug can be reproduced by doing, on an amd64 architecture PC:

tobi@ubuntu:~$ echo "hello world" > file1
tobi@ubuntu:~$ dd if=file1 of=file2
0+1 records in
0+1 records out
Segmentatie fout

On the same amd64 computer, but in a 32 bit chroot:

tobi@ubuntu:~$ dd if=file1 of=file2
0+1 records in
0+1 records out
12 bytes transferred in 0.000207 seconds (57968 bytes/sec)

If a backtrace is needed because you can't reproduce the bug just ask and I'll provide one.

I can't reproduce this on Dapper AMD64.

I think the backtrace would be welcome, and more informations about your system too.

Changed in coreutils:
status: Unconfirmed → Needs Info

hm, I just tried it again, and it doesn't crash anymore. Maybe it has been fixed. It did crash earlier this week with my Flight-4 Live CD while backupping/restoring the MBR. So I'll assume it has been fixed by some update of dd sometime between Flight 4 and Flight 5. If I manage to reproduce it again, I'll reopen the bug.

Changed in coreutils:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers