coreutils FTBFS during zesty/artful test rebuild

Bug #1679865 reported by Patricia Gaughen on 2017-04-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
coreutils (Ubuntu)
Undecided
Unassigned

Bug Description

coreutils version 8.26-3ubuntu3 in zesty failed to build on all arches during a test rebuild of the archive. The build log can be found here:

https://launchpadlibrarian.net/312365438/buildlog_ubuntu-zesty-amd64.coreutils_8.26-3ubuntu3_BUILDING.txt.gz

The failure seems to be:

FAIL: tests/misc/date-debug
===========================

--- exp3 2017-03-25 05:27:00.477874098 +0000
+++ out3 2017-03-25 05:27:00.481874118 +0000
@@ -4,4 +4,4 @@
 date: final: 1.000000000 (epoch-seconds)
 date: final: (Y-M-D) 1970-01-01 00:00:01 (UTC0)
 date: final: (Y-M-D) 1969-12-31 19:00:01 (output timezone TZ=-05:00)
-Wed Dec 31 19:00:01 PET 1969
+Wed Dec 31 19:00:01 -05 1969
FAIL tests/misc/date-debug.sh (exit status: 1)

tags: added: ftbfs zesty
Changed in coreutils (Ubuntu):
assignee: nobody → Matthias Klose (doko)
Tiago Stürmer Daitx (tdaitx) wrote :

This is caused by a change in the new TZ as reported at [1]. A fix is provided in [2] but required a small change for the first chunk to apply cleanly - see attached debdiff.

Other option is to sync the newest version, 8.28-1 [3,4], which includes the fix upstream and builds cleanly.

[1] http://lists.gnu.org/archive/html/coreutils/2017-03/msg00026.html
[2] http://lists.gnu.org/archive/html/coreutils/2017-03/msg00031.html
[3] http://snapshot.debian.org/package/coreutils/8.28-1/
[4] https://tracker.debian.org/pkg/coreutils

Changed in coreutils (Ubuntu):
assignee: Matthias Klose (doko) → nobody
status: New → Confirmed
tags: added: patch
tags: added: artful
summary: - coreutils FTBFS during zesty test rebuild
+ coreutils FTBFS during zesty/artful test rebuild
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package coreutils - 8.26-3ubuntu4

---------------
coreutils (8.26-3ubuntu4) artful; urgency=medium

  * debian/patches/test-misc-date-tzdb-2017a.patch: fixes date test
    caused by tzdb-2017a update. LP: #1679865.

 -- Tiago Stürmer Daitx <email address hidden> Wed, 04 Oct 2017 19:56:41 +0000

Changed in coreutils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers