lucid to precise: invalid $LS_COLORS after upgrade and before reboot

Bug #1038914 reported by Jean-Baptiste Lallement on 2012-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
coreutils (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Right after an upgrade from Lucid to Precise and before restarting the system 'ls' displays the following error:
$ LANG=C ls
ls: unrecognized prefix: hl
ls: unparsable value for LS_COLORS environment variable
Bureau Images Musique T??l??chargements examples.desktop
Documents Mod??les Public Vid??os

Here is the value of $LS_COLORS
$ echo $LS_COLORS
rs=0:di=01;34:ln=01;36:hl=44;37:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:

A reboot fixes it.

WORKAROUND:
After upgrade if you want to continue using the system before restarting it:
1. open a terminal and run the following command:
 $ eval "$(dircolors -b)"

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: coreutils 8.13-3ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-42.95-generic 2.6.32.59+drm33.24
Uname: Linux 2.6.32-42-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Mon Aug 20 10:19:17 2012
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110720.1)
ProcEnviron:
 TERM=xterm
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: coreutils
UpgradeStatus: Upgraded to precise on 2012-08-20 (0 days ago)

Jean-Baptiste Lallement (jibel) wrote :
tags: added: lucid2precise qa-manual-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1038914

tags: added: iso-testing
Changed in coreutils (Ubuntu Precise):
importance: Undecided → Medium
description: updated
Changed in coreutils (Ubuntu Precise):
importance: Medium → Low
Changed in coreutils (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers