No conversion occurs. It just says converting... but nothing happens!

Bug #474341 reported by Riltormor on 2009-11-04
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
convertall (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: convertall

No conversion occurs. It just says converting... but nothing happens! I never had any problems with convertall in previous Ubuntu versions. BTW I use Ubuntu 9.10

ProblemType: Bug
Architecture: i386
Date: Wed Nov 4 16:07:30 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: convertall 0.4.2-1
PackageArchitecture: all
ProcEnviron:
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: convertall
Uname: Linux 2.6.31-14-generic i686

Riltormor (riltormor) wrote :
Arup (arup-chowdhury) wrote :

Facing the same issue here with x64 Karmic. No conversion occurs.

Dave Stevenson (davstev) wrote :

Same here. Fresh install of Karmic x64. Installed Convertall with Synaptic. Says "converting...", but doesn't convert.

Riltormor (riltormor) wrote :

A temporary fix would be to use Converber 1.3.0 through wine

Colin Mills (cm006a5077) wrote :

I can confirm that there is a bug in this version of Convertall. The developer (http://convertall.bellz.org/index.html) has released a new version with a number of bug fixes.
If you are comfortable running the terminal, there is an alternative. Uninstall the current version of Convertall. Download and unpack the latest tar file from the website. Since the new package has the same dependencies as the current version, open a terminal and enter:-

sudo apt-get build-dep -y convertall
cd Convertall
sudo python install.py

This will install a working version of Convertall. In my case, Convertall was not shown on the menu, so I used the Alacarte menu to add it. The launch command is "convertall' and the icon is in "/usr/local/share/icons/convertall".

Hopefully, the new version of Convertall will be ported to the Karmic repos at some point.

Mathieu Comandon (strycore) wrote :

Convertall throws the following error message :

Traceback (most recent call last):
  File "/usr/share/convertall/numedit.py", line 90, in setNum
    if numText.isNull():
AttributeError: 'str' object has no attribute 'isNull'

Changed in convertall (Ubuntu):
status: New → Confirmed
assignee: nobody → Mathieu Comandon (strycore)
Mathieu Comandon (strycore) wrote :

Patch sent to maintainer

Changed in convertall (Ubuntu):
status: Confirmed → In Progress
Changed in convertall (Ubuntu):
assignee: Mathieu Comandon (strycore) → nobody
assignee: nobody → William Grant (wgrant)
William Grant (wgrant) on 2009-12-05
Changed in convertall (Ubuntu):
assignee: William Grant (wgrant) → nobody
status: In Progress → Triaged
primefalcon (primefalcon) wrote :

I have the same issue as the OP

I ran convert all from the terminal so I could get debug info and collected this......

-------------------------------------------------------------------------------
516 units loaded
Traceback (most recent call last):
  File "/usr/share/convertall/numedit.py", line 90, in setNum
    if numText.isNull():
AttributeError: 'str' object has no attribute 'isNull'
Traceback (most recent call last):
  File "/usr/share/convertall/numedit.py", line 90, in setNum
    if numText.isNull():
AttributeError: 'str' object has no attribute 'isNull'
-------------------------------------------------------------------------------

Mathieu Comandon (strycore) wrote :

I've submitted the patch days ago, I don't know what's going on now and why it's not being released. I may not be very familiar with the whole bug fixing procedure on Launchpad but I wish more experienced users told me what I did wrong.

primefalcon (primefalcon) wrote :

from the error report I see the problem is in the file

/usr/share/convertall/numedit.py around line 90, I'm not too familiar with python unfortunately but it's probably just a typo, missed semicolon or something can you post instructions for the fix here?

Mathieu Comandon (strycore) wrote :

yeah , I posted the fix just above.
Open the file /usr/share/convertall/numedit.py and go to line 92, replace
if numText.isNull():
with
if not numText:

save, and then it should work

It's kind of a typo , isNull() doesn't exist in Python but does in many other languages. Even if it's the simplest fix ever, it's not something I made up, it's the real thing from ConvertAll 0.4.3

primefalcon (primefalcon) wrote :

Yup that's fixed, thx, in my system though it was on line 90 not 92 :-)

grn (gaurangarora) wrote :

Sorted.

Downloaded v0.4.3 from http://convertall.bellz.org/download.html and installed it by

..$sudo python install.py

It worked.

First uninstall earlier version.
Make sure you have the latest python libraries installed.
After installation.
Start ConvertAll by typing convertall in terminal or Run(Alt+F2)... or create a menu item with command: convertall

Riltormor (riltormor) wrote :

Thank you grn. ConvertAll now works perfectly.

grn (gaurangarora) wrote :
Changed in convertall (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

convertall 0.4.3 is not in Ubuntu, so this is not fixed.

Changed in convertall (Ubuntu):
status: Fix Released → Triaged

I confirm this same bug in Ubuntu 9.10 Desktop 64bit.

Can we expect this to be fixed in Ubuntu 10.04 ? Will it be in an update in 9.10?

nomnex (nomnex) wrote :

Mathieu Comandon (#11)

> Open the file /usr/share/convertall/numedit.py and go to line 92, replace
> if numText.isNull():
> with
> if not numText:

Thanks for this one. It would be nice if the package in the repo was updated at once.

Sidenote: as noted by primefalcon, go to line 90.

sudo gedit /usr/share/convertall/numedit.py
Click "Search" > Go to Line > 92
>replace
> if numText.isNull():
> with
> if not numText:
then save.

Yeah, that made it work for me too.

I'd like to learn more about the process of getting Ubuntu to include fixes in automatic updates.

For example, in this case, the developer has clearly fixed the problem, but how does a developer's fix get into automatic updates?

I just want to learn more about this process. Perhaps I can find a link in Google.

wideyes (tarunperkins) wrote :

Replacing this one line of code is quick and effective!

jlaroche (jlaroche) wrote :

I have the same problem (just says converting). I am running Ubuntu 9.10 64bit and my version of ConvertAll is 0.4.2. It used to work fine in Ubuntu 9.04 64bit and then I upgraded to 9.10 and it stopped working. I ultimately 'fixed' the problem though - I simply uninstalled 0.4.2 and then installed 0.4.3 from the ConvertAll website. The new version works in 9.10 64bit.... Gotta love Linux for all these idiosyncrasies.

bossbruin (bossbruin) wrote :

when i try to replace code line #90 ubuntu tells me it is read only and will not let me overwrite the /usr/share/convertall/numedit.py ? help please

bossbruin (bossbruin) wrote :

i'm sorry did thru sudo and worked fine for the edit and fix. convertall working now. ty Mathieu Comandon (#11) and nomnex(#19)

John Dong (jdong) wrote :

Accepted Karmic nomination.

Please format this as a sponsorship request for both Lucid and a karmic-proposed SRU, and try to get it into Lucid (soon) before the release.

I've unsubscribed the SRU team for now, as there is no debdiff/bzr branch to review.

grn (gaurangarora) wrote :

Fixed in Ubuntu 10.04 PPA

Changed in convertall (Ubuntu):
status: Triaged → Fix Released
nomnex (nomnex) wrote :

What's Ubuntu 10.04 PPA?

Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Changed in convertall (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers