Cannot install fonts using method described in help

Bug #82724 reported by mathew on 2007-02-01
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
gnome-control-center
Expired
Medium
control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Using Edgy.

Gnome desktop help says:

"If you prefer to download individual fonts by hand, you can install them simply and easily by opening a file manager, and typing fonts:/// into the location bar (see the file manager manual for how to use the location bar). Then you can simply drag the font you downloaded into the group of existing fonts."

I successfully found the location bar and typed in fonts:///, opened a second window with the .ttf font file in, and dragged the font file into the fonts:/// folder.

Result: nothing happens. Although the cursor changes to a + symbol when over the destination folder, nothing is copied when I let go of the font file. In addition, no error is reported, and the font is not installed.

While I'm at it, why doesn't the GNOME Font Viewer have a simple button for "Go ahead and install the font I'm showing you"?

mathew (meta23) wrote :

Correction:

I Googled for how to actually install fonts. I followed the instructions I found and opened up ~/.fonts/ and discovered that the font had, in fact, been installed. However:

1. It hadn't been installed to the place I had put it (the fonts:/// window),
2. the fonts:/// window hadn't indicated that the font had been installed by including it in the list of fonts,
3. no message had been displayed to indicate that the font had been diverted elsewhere, and
4. no message had been displayed when I tried repeating the drag-drop, which presumably silently overwrote the copy in ~/.fonts/ each time.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=319512

Changed in gnome-desktop:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Confirmed
Changed in control-center:
status: Unknown → Unconfirmed
Niels Giesen (niels-giesen) wrote :

As of Hardy, fonts get installed simply by putting them in ~/.fonts, nautilus or no nautilus.

The fonts:/// pseudo-directory does not work any longer and does not need to.

Michael Rooney (mrooney) wrote :

Is this Invalid then, since Edgy is no longer supported and this scheme no longer exists? Or is still valid for Dapper/Feisty/Gutsy?

Sebastien Bacher (seb128) wrote :

the bug is obsolete in hardy and intrepid

Changed in control-center:
status: Confirmed → Invalid
Przemek K. (azrael) wrote :

The bug is present in Hardy. There is no link to fonts directory in System / Preferences / Appearance -> Fonts tab

Sebastien Bacher (seb128) wrote :

there is no fonts special location in hardy

Arthur (moz-liebesgedichte) wrote :

There's still the issue that if you use the help system you get directed to fonts:/// (if the help browser doesn't just crash that is).

Przemek K. (azrael) wrote :

I guess this should be filed as bug of the help system/content.

Mat Tomaszewski (mat.t.) wrote :

This will be fixed in Karmic. "Install Font" option will be provided in the preview window as well as in the right-click menu.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Alejandro Vidal (mancvso) wrote :

The font issue and other could be fixed with nautilus actions

i mean:

Set as Wallpapaer, Install Font, Open as Administrator, Send shortcut, etc.

Changed in hundredpapercuts:
milestone: none → round-5
Przemek K. (azrael) wrote :

This bug will be fixed in Gnome 2.28.
See http://blogs.gnome.org/thos/2009/07/26/re-adding-fonts-in-gnome/

Related/duplicate bugs: Bug #254056 Bug #389657

Vish (vish) on 2009-08-12
Changed in hundredpapercuts:
milestone: round-5 → round-10
komputes (komputes) wrote :

I never understood why the abstraction of fonts:/// was removed. I enjoyed the concept and though it was easier than showing and navigating through hidden folders. Since this bug is from 2007 I'm not sure if the reporter is requesting to bring back the fonts:/// abstraction or if he is reporting to edit the documentation.

Mat has proposed that in karmic you can right click a .ttf file and it will propose to install the font. How does this scale on multiple .ttf files or folders/sub-folders full of fonts?

Andrew (and471) on 2009-09-06
Changed in gnome-control-center:
status: New → Fix Committed
Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in gnome-control-center:
status: Fix Committed → New
Vish (vish) on 2009-10-03
Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
Changed in gnome-control-center:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.