Ubuntu

variables from the session are not defined

Reported by Jim Braux-Zin on 2006-09-24
46
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
control-center (Ubuntu)
High
Ubuntu Desktop Bugs
dbus (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: evolution

Hello, I am using edgy since yesterday and I found a very annoying bug for me:

Evolution now uses gnome-keyring to store the passwords which isn't a bad thing for me as it works very well... if I launch evolution either by the launcher in the menu or by the command 'evolution' on the command line, or even by the Alt-F2 dialog.

However, if I launch evolution by using the keybinding set in gnome, it keeps asking me the passwords for my two mail accounts and can't remember it.

I hope you can solve this problem.

Jim.

Related branches

David Planella (dpm) wrote :

I can confirm this on my system with evolution 2.8.0-0ubuntu3 installed.

When launching Evo from Applications>Internet>Evolution, it contacts the gnome-keyring as expected, and the account passwords are read from the keyring (i.e. Evolution prompts once for the password to unlock the keyring).

However, when launching Evo from a keyboard shortcut set up under System>Preferences>Keyboard Shortcuts>Desktop>E-mail, it does not seem to communicate with the gnome-keyring daemon, since it asks for the password of each and every account upon startup.

The following binaries/links are on my system:

/usr/bin/evolution (symlink to /usr/bin/evolution-2.8)
/usr/bin/evolution (symlink to /usr/bin/evolution-2.8)
/usr/bin/evolution-2.8 (Evolution 2.8.0 binary)

* The launcher under Applications>Internet>Evolution Mail executes:
evolution --component=mail
This launcher works as expected.

* The launcher under Applications>Office>Evolution Mail executes:
evolution-2.8
This launcher works as expected.

* A keyboard shortcut set up under System>Preferences>Keyboard Shortcuts>Desktop>E-mail seems to execute what's defined under System>Preferences>Preferred Applications>Mail Reader. In my case, that is the default Evolution command:
evolution %s
This is the launcher that doesn't work. As said before, when the keyboard shortcut is pressed, Evolution starts but does not seem to communicate with the keyring.

Changing the command to Custom and trying:
evolution --component=mail
or
evolution-2.8
does not help, either.

Changed in evolution:
status: Unconfirmed → Confirmed
Jim Braux-Zin (j-brauxzin) wrote :

I have the problem when evolution is launched by Firefox when I click on a mailto: link too. It opens the message window fine but it asks me again for my pop and imap passwords.

The worst is that it then continue to periodically pop the password entry, even with evolution closed. I have to launch it again through the menu tu get rid of that.

Very annoying problem actually.

Sebastien Bacher (seb128) wrote :

That's a control-center issue, similar to http://bugzilla.gnome.org/show_bug.cgi?id=360475 upstream

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → High
Changed in control-center:
status: Unknown → In Progress
Changed in control-center:
status: In Progress → Needs Info
Changed in control-center:
status: Needs Info → Confirmed
Changed in control-center:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The upstream bug is fixed, gnome-session needs to start dbus though

Michael Hofmann (mh21) wrote :

I just commented the line
    #use-session-dbus
in /etc/X11/Xsession.options, and now my keybinding for logout works again. The dbus session daemon is started by /usr/bin/system-tools-backends and is running happily. Maybe this can still be fixed for Feisty?

Martin Pitt (pitti) wrote :

That looks a bit weird. Why should system-tools-backends (a root system process) start a session dbus? Also, we have always started the session dbus with the session. If this is a problem central to control-center, it should be fixed there, not change the global system (with unknown impact to other parts). Or what am I missing here?

Sebastien Bacher (seb128) wrote :

looks like a typo, gnome-session would start dbus if it's not done yet

upstream comment explaining it:

"This bug is fixed partially, but it requires action from the user/distribution
side: dbus must be started from within gnome-session. Most distributions start
dbus from an xinit script to make sure it is running. Gnome-session only starts
a dbus session bus when none is running yet. When dbus is launched before
gnome-session, variables like SESSION_MANAGER, GNOME_KEYRING_SOCKET and other
environment options set from gnome-session are not available to programs
launched from dbus."

Michael Hofmann (mh21) wrote :

Hmm, I actually have 3 processes looking like /usr/bin/dbus-daemon --session (two as user, one as root). And while it is working fine for Gnome, I don't know whether KDE or XFCE start the dbus session daemon themselves.

Michael Hofmann (mh21) wrote :

Xfce4 is starting dbus in by using dbus-launch in /etc/xdg/xfce4/xinitrc if there is no session bus yet, KDE does not seem to start a session bus.

Xfce4 also seems to start the dbus daemon before the session manager, which may cause similar pain as for the Gnome case if a session-manager-aware program is started through dbus.

Another way is to temporarily special-case the desktop environments in /etc/X11/Xsession.d/75dbus_dbus-launch. This should limit the effect of changes to Gnome.

Michael Hofmann (mh21) wrote :

Temporary patch. Maybe the real solution would be to get all DEs to start the session bus from inside their session manager. Then the Xsession script could be completely removed.

Daniel Holbach (dholbach) wrote :

Patch available, not sure if we'll get it in for Feisty, though.

Changed in control-center:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

not really "fix commited" yet, especially that the change is not for control-center

Changed in control-center:
status: Fix Committed → Confirmed
Michael Hofmann (mh21) wrote :

Hmm, for some reason the patch stopped working for me. I will investigate this further.

Changed in control-center:
status: Confirmed → Unconfirmed
Martin Pitt (pitti) wrote :

dbus will split out the Xsession script to a separate package.

Changed in xorg:
assignee: nobody → pitti
importance: Undecided → Medium
status: Unconfirmed → In Progress
Martin Pitt (pitti) wrote :

 dbus (1.0.2-5ubuntu1) gutsy; urgency=low
 .
   * Merge with Debian unstable; remaining Ubuntu changes:
     - debian/patches/80-dbus-change-at-console-policy.patch: Make at_console
       policy work with libpam-foreground.
     - debian/patches/81-session.conf-timeout.patch: Raise the service startup
       timeout from 25 to 60 seconds. It may be too short on the live CD with
       slow machines.
     - debian/rules: Start dbus at runlevel priority 12, so that it comes
       before gdm. This eliminates the race condition of starting the X session
       before hal is running. Also use 'multiuser' mode of update-rc.d.
     - debian/dbus.postinst: Migrate rc?.d symlinks from 20 to 12 on upgrades
       to this version. This needs to be kept until the next Ubuntu LTS.
     - debian/dbus.{postinst,prerm}: Reverted Debian's change to always restart
       dbus on upgrades.
   * debian/control: Drop dbus dependency to dbus-x11, since we crave to get
     rid of that Xsession.d script. (LP: #62163)
   * debian/dbus.preinst: Improve rm_conffile() to get the unmodified md5sum
     from dpkg instead of hardcoding it, and remove unchanged
     /etc/X11/Xsession.d/75dbus_dbus-launch on upgrade.

Now, systems which need the dbus and do not restart it by themselves need a dependency to dbus-x11.

Changed in dbus:
status: In Progress → Fix Released
Eitan Isaacson (eeejay) wrote :

Just another thought,

Since dbus is not started via gnome-session, any process that dbus launches is not accessible.
This is because gnome-session looks in gconf to see if accessibility is enabled and sets GTK_MODULES
accordingly before it launches dbus. As you guys mentioned, gnome-session will not launch dbus if it has already been started.

A good example is notification-daemon, any notification bubble that it pops up is completely inaccessible, so a screen reader user in Edgy will never find out that her battery is about to run out, before it is too late.

I am not very familiar with Ubuntu conduct in these cases, but is there a chance a fix could be pushed to Edgy users?

Cheers!

Sebastien Bacher (seb128) wrote :

that's not likely going to be changed on a stable version no

Daniel Holbach (dholbach) wrote :

Unsubscribing ubuntu-main-sponsors for now. There's no patch for review available.

Laurent Bigonville (bigon) wrote :

dbus (1.1.1-3ubuntu1) gutsy; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/patches/80-dbus-change-at-console-policy.patch: Make at_console
      policy work with libpam-foreground.
    - debian/patches/81-session.conf-timeout.patch: Raise the service startup
      timeout from 25 to 60 seconds. It may be too short on the live CD with
      slow machines.
    - debian/rules: Start dbus at runlevel priority 12, so that it comes
      before gdm. This eliminates the race condition of starting the X session
      before hal is running. Also use 'multiuser' mode of update-rc.d.
    - debian/dbus.postinst: Migrate rc?.d symlinks from 20 to 12 on upgrades
      to this version. This needs to be kept until the next Ubuntu LTS.
    - debian/dbus.{postinst,prerm}: Reverted Debian's change to always restart
      dbus on upgrades.
  * debian/control: Drop dbus dependency to dbus-x11, since we crave to get
    rid of that Xsession.d script. (LP: #62163)
  * debian/dbus.preinst: Improve rm_conffile() to get the unmodified md5sum
    from dpkg instead of hardcoding it, and remove unchanged
    /etc/X11/Xsession.d/75dbus_dbus-launch on upgrade.
  * Fix debian/patches/80-dbus-change-at-console-policy.patch

dbus (1.1.1-3) unstable; urgency=low

  * List arches where the build-dep on libselinux1-dev doesn't apply; thanks
    Michael Banck; closes: #430821.
  * Wrap build-deps and deps.
  * Misc cleanups, including quoting in maintainer scripts.
  * Add myself as uploader.
  * Add ${misc:Depends}.

dbus (1.1.1-2) unstable; urgency=low

  * debian/control
    - Fix small typo in the dbus-x11 package description. (Closes: #430736)

dbus (1.1.1-1) unstable; urgency=low

  [ Michael Biebl ]
  * debian/patches/02_dbus_monitor_no_sigint_handler.patch
    + Remove the sigint_handler in dbus-monitor so the application properly
      terminates on STRG+C. (Closes: #414139)

  [ Sjoerd Simons ]
  * New upstream release
  * debian/libdbus-1-3.shlibs: Bumped shlibs

dbus (1.1.0-1) unstable; urgency=low

  [ Sjoerd Simons ]
  * New upstream release

  [ Tim Dijkstra ]
  * Disable userdb cache. If you need a cache, use nscd. (closes: #370569)

  [ Michael Biebl ]
  * debian/control
    + Fix small typo in the dbus-x11 package description. (Closes: #425132)
    + Replace Source-Version with binary:Version for libdbus-1-dev.
  * debian/dbus.init
    + Suppress error messages about nonexistent or unreadable files.
      (Closes: #426296)
    + Do not abort on grep errors. (Closes: #423380)
    + Do not abort if starting a dependent service fails.
  * debian/control
    + Add build dependency on autotools-dev for up-to-date config.{guess,sub}
      files.

 -- Laurent Bigonville <email address hidden> Tue, 24 Jul 2007 12:29:08 +0200

Sebastien Bacher (seb128) wrote :

That should be fixed in gutsy, feel free to reopen if you still get the issue though

Changed in control-center:
status: New → Fix Released
Changed in gnome-control-center:
status: Fix Released → Confirmed
Changed in gnome-control-center:
status: Confirmed → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.