Ubuntu

Unable to load any usable fontset

Reported by X-Bert on 2005-09-04
62
Affects Status Importance Assigned to Milestone
control-center (Ubuntu)
Medium
Ubuntu Desktop Bugs
libxfont (Ubuntu)
Undecided
Unassigned

Bug Description

$ dpkg -l xfig*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii xfig 3.2.5-alpha5-3 Facility for Interactive Generation of figur
ii xfig-doc 3.2.5-alpha5-3 XFig on-line documentation and examples
ii xfig-libs 3.2.5-alpha5-3 XFig image libraries and examples

$ xfig
Warning: Color name "black" is not defined
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,*--16-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Color name "black" is not defined
Not enough colormap entries available for basic colors
using monochrome mode.

Changed in xfig:
assignee: nobody → motu
Ross Golder (ross-golder) wrote :

Just a 'me too'. I'm getting at least the following same errors trying to run xfontsel or any other Xlib app. I'm seeing this in Ubuntu Breezy *and* another Debian stable-derived distro on another box. I see lots of other reports by Googling for various related keyword patterns, but no (working) solution so far.

rossg@localhost:~$ xfontsel
Warning: app-defaults file not properly installed.
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

The xfontsel man page says that the program has to be able to find the app-defaults file in order for the program to work correctly. The app-defaults file is located in /etc/X11/app-defaults on my system (breezy Colony 4).

LaserJock (laserjock) wrote :

when I run xfontsel, I get:

Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

and when I run xfig, I get:

Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,*--16-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

no mention of app-defaults but I am having other problems with Xfig [http://launchpad.net/distros/ubuntu/+sources/xfig/+bug/3112 Bugg 3112] sooo, I'm not sure what is going on.

LaserJock (laserjock) wrote :

I was able to get rid of these font warnings by doing any of the following:

   - "sudo dpkg-reconfigure locales" set default to ISO-8859-1 instead of UTF-8
   - put "xset fp rehash" in gnome-session. It must be run after each login.
   - run xfig with "LANG=C xfig"

None of these are a real fix but it might give some hint as to the problem to someone smarter than I.
Note: This problems occurs for many of the old X packages. xfontsel, xload, etc.

LaserJock (laserjock) wrote :

This bug now seems to be fixed on Breezy. I will mark this fixed. If it isn't fixed for you on Breezy please feel free to reopen it.

Changed in xfig:
status: New → Fixed

I still get the warnings in Breezy and fonts look different in xfig and in ghostview.

I also get the warning for xfontsel (bug 35330). Should I reopen this bug?

manu@~ $ dpkg -l xfig* | grep '^ii'
ii xfig 3.2.5-alpha5-4
ii xfig-libs 3.2.5-alpha5-4

Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,*--16-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-medium-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-times-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-bold-r-normal--16-*-*-*-*-*-*-*,-*-*-*-r-*--16-*-*-*-*-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

Patrick Goetz (pgoetz) wrote :

I'm still having all the problems described above with Edgy (6.10).

X-Bert (x-bert-0sg) wrote :

It seems that the bug still isn't fixed. Is it possible to reopen it with the same number?

Adriaan Peeters (apeeters) wrote :

reopened

Changed in xfig:
status: Fix Released → Confirmed
Torsten Spindler (tspindler) wrote :

The command
xset fp rehash
seems to fix this problem.

Simon Law (sfllaw) wrote :

This is not xfig's problem, but rather a problem with the xorg package.

Changed in xfig:
assignee: motu → nobody
Simon Law (sfllaw) wrote :

Nope, I lied. Here are reproduction steps for Ubuntu Edgy:

1. Install tetex-bin.
2. Log out.
3. At the login screen, go to Options > Select Session... Then, select the "Failsafe Terminal" session and login.
4. Run `xdvi` and click "Cancel"
5. Note down xdvi's output
6. Run `dbus-launch` and export the environment variables it spews out.
7. Run `gnome-settings-daemon &`
8. Run `xdvi` and click "Cancel"
9. Note down xdvi's output.

Expected result:
xdvi runs quietly both times.

Actual result:
The second time xdvi is run, in step 9, it reports the following error:

Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

Workaround:
After gnome-settings-daemon starts up, run `xset fp rehash` to
recompute the font paths.

lemming (amy-cgi) wrote :

I experienced similar problems when running sawfish as my window manager. It seems that changing my locale to "C" fixes the problem. Thus, adding:

LANG="C"

to my .xinitrc allowed sawfish to run just fine. I also changed this in my .bashrc so that other apps such as xdvi, etc. don't run into problems.

So... maybe it's a locale problem?

I can confirm this behaviour. I modified /etc/environment to LANG="C", LANGUAGE="C", and things came back to life. I then set it to LANG="en_GB" and LANGUAGE="en_GB" and it still worked. Now with the default of LANG="en_GB.UTF-8" and LANGUAGE="en_GB:en" then I get the font problems.

Definitely looks like a locale problem.

Torsten Spindler (tspindler) wrote :

Try the following: When a file ~/.gnome2/share/fonts/fonts.dir exists, move it out of the way (e.g. mv ~/.gnome2/share/fonts/fonts.dir ~/.gnome2-share-fonts-fonts.dir-gone) and see if xdvi works.

Worked for me. I checked the contents of the ~/.gnome2/share/fonts/fonts.dir file and it has a single line consisting of a single 0 in it.

On Mon, 2007-02-12 at 15:31 +0000, Torsten Spindler wrote:
> Try the following: When a file ~/.gnome2/share/fonts/fonts.dir exists,
> move it out of the way (e.g. mv ~/.gnome2/share/fonts/fonts.dir
> ~/.gnome2-share-fonts-fonts.dir-gone) and see if xdvi works.
>
I get:

mas@bright:~$
mv /home/mas/.gnome2/share/fonts/fonts.dir /home/mas/.gnome2/share/fonts/fonts.dir.old
mas@bright:~$ xdvi
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

so no resolution I am afraid.

--
Matthew Swabey
Rm7002, Bldg21 Faraday Tower
Department of ECS
University of Southampton
University Road
Southampton, SO17 1BJ
England

Tel: 02380 597381
Mob: 07966 440946

Ooops. Just checked again. I was using an X-Win session on a remote box, not at the console. I have just checked on the console and it failed. Something to do with XOrg?

Torsten Spindler (tspindler) wrote :

Forgot to add the following: Please end your session and start a new one. If this does not work, does 'xset fp rehash' work?

OK. My results.

1.- When I logout/login then ~/.gnome2/share/fonts/fonts.dir is regenerated and contains "0" as before. Behaviour is as before.

2.- xset fp rehash cures the xdvi problem.

Sebastien Bacher (seb128) wrote :
Download full text (3.8 KiB)

That upload fixes the problem:

 control-center (1:2.17.91-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     common:
     - Compilation fixes
     - Fixed localedir defines
     - Use standard installation paths
     - Use capplet name for G_LOG_DOMAIN
     - Require GTK+ <= 2.10
     about me:
     - Fix build with gcc 2
     - Fix memory leaks
     - Fix possible crash
     at-properties:
     - Fix reference leaks and dont segfault if glade file is not available
     default applications:
     - Use specific string as app ID in gnome_program_init
     - Plug memory leaks
     - Fix DATADIR define
     keybindings:
     - Issue a sensible error message when trying to use unmodified keybindings
       (Ubuntu: #82065)
     - Removed leftover call to gnome_theme_init
     - Support localised key names
     - Clean up sorting to not use an imaginary column
     - Avoid warnings when clearing at exit
     - Added missing GConf key
     mouse:
     - Dont crash if the glade file is not available
     network:
     - Plug memory leaks
     sound:
     - Polypaudio->PulseAudio renaming
     - Added a11y label relations for the devices tab
     theme switcher:
     - Fix compiler warnings
     - Fixes on the suffix checks
     - Pass correct order of arguments to gnome_vfs_xfer
     - Listen for changes in the gtk-color-scheme property of GtkSettings
     typing break:
     - Use specific string as app ID in gnome_program_init
     - Use compositing to display the typing break window when available
     ui properties:
     - Plug memory leaks
     - Change "Editable menu accelerators" to "Editable menu shortcut keys"
       as per the style guide
     windows:
     - Plug memory leaks
     fontilus:
     - Use GOption argument parsing
     - Fixed some leaks
     themus:
     - Port to GOption
     settings daemon:
     - Prevent crashes/assertion failures trying to set ridiculously high/low
       volumes
     - Fixed property names
     - Dont install the same window filter twice
     - Make sure we have a key event before treating it as such
     - Fixed leaks
     - Round volume instead of truncating on umute so a simple mute/unmute
       doesn't lower the volume (Ubuntu: #81203)
     - Make the new volume overlay window follow the icon and color themes
     - Eat media player keys if someone is listening on the bus interface
       already
     - Revert to the old font path if the new one could not be set
       (Ubuntu: #2066, #52163, #79566)
     shell:
     - Prevent capplets from being launched twice
     - Use correct GConf prefix
     - Added default common tasks
     - Respect the exit_on_close flag
     - Added a flag controlling display of GenericName's
     - Fix typo in usage string
     - Respect the --disable-schemas-install configure flag
     - Dump remnants of gstreamer-0.8
     - Use custom gnomecc.menu instead of settings.menu
     - Dont show Help menu if help is not available
     - Disable package management/main-menu items in the context menu
       (Ubuntu: #81335)
     - Use correct text color when highlighting
     - Use ...

Read more...

Changed in control-center:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The libxfont problem is fixed with that upload:

 libxfont (1:1.2.2-1ubuntu1) feisty; urgency=low
 .
   * debian/patches/from_git_accept_empty_font_path.patch:
     - patch from git,"fontfile: accept empty (but valid) font paths (bug #3091)
       If a path has a valid fonts.dir or fonts.alias, but does not contain any
       fonts (either fonts.dir specifies zero fonts, or fonts could not be
       loaded), load it as a valid font path anyway."
       (Ubuntu: #2066, #52163, #79566)

Changed in libxfont:
status: Unconfirmed → Fix Released
Changed in control-center:
assignee: nobody → desktop-bugs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers