Support for alternative keyboard layouts broken in Feisty

Bug #103111 reported by Fabián Rodríguez on 2007-04-04
2
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Unknown
control-center (Debian)
Fix Released
Unknown
control-center (Ubuntu)
Low
Brian Murray

Bug Description

After applying today' s updates, Feisty now complains everytime I try to add an alternate keyboard layout.

Steps to reproduce:
- Add Keyboard Indicator applet to a panel
- Right click on applet, choose Keyboard preferences.
- Go to "Layouts" tab, click the " + ADD" button and try adding a keyboard layout
- The following message appears:

Unable to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with Bonobo, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

After that everytime you try to access the Keyboard preferences from the applet reproduces the message.

I found a similar upstream bug (CONFIRMED, IMPORTANT):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=377318

description: updated
Changed in control-center:
status: Unknown → Confirmed
status: Unknown → Confirmed

Thank you for your bug. Does it happen if you run gnome-keyboard-properties on a command line? Do you have any error to ~/.xsession-errors?

Changed in control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Fabián Rodríguez (magicfab) wrote :

Yes, inviking from command line throws the same error.
The console shows:
magicfab@suzy:~$ gnome-keyboard-properties
dpy: 0x8074c58
evt/error/major/minor: 111/174/1/0

No errors in ~/.xsession-errors

Fabián Rodríguez (magicfab) wrote :

Yes, invoking from command line throws the same error.
The console shows:
magicfab@suzy:~$ gnome-keyboard-properties
dpy: 0x8074c58
evt/error/major/minor: 111/174/1/0

No errors in ~/.xsession-errors

Fabián Rodríguez (magicfab) wrote :

Well, I don' t know if I feel embarrassed or relieved but I found out I had a corrupt file at /etc/X11/xkb/symbols/pc .

I had been playing with other keymap / layouts and somehow overwrote that one. I found out by comparing the files with a fresh Feisty install.

So, feel free to mark this as rejected - sorry for the inconvenience.

Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being with a config change. Thanks again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in control-center:
assignee: desktop-bugs → brian-murray
status: Needs Info → Rejected
Changed in control-center (Debian):
status: Confirmed → Fix Released
Changed in gnome-control-center:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.