containerd depends on unreleased docker19 package in focal

Bug #1937286 reported by Peter Tripp
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
containerd (Ubuntu)
Invalid
Undecided
Unassigned
Bionic
Invalid
Undecided
Marc Deslauriers
Focal
Invalid
Undecided
Marc Deslauriers
Hirsute
Invalid
Undecided
Unassigned
Impish
Invalid
Undecided
Unassigned
docker.io (Ubuntu)
Invalid
Undecided
Unassigned
Bionic
Fix Released
Undecided
Marc Deslauriers
Focal
Fix Released
Undecided
Marc Deslauriers
Hirsute
Invalid
Undecided
Unassigned
Impish
Invalid
Undecided
Unassigned

Bug Description

containerd release 1.5.2-0ubuntu1~20.10.2 addressing USN-5102-1 in focal includes a "Breaks" reference to a docker.io package version (19.03.8-0ubuntu1.20.04.2) that was never released. Currently only .1 is available not .2.

$ dpkg -I /var/cache/apt/archives/containerd_1.5.2-0ubuntu1~20.04.2_amd64.deb |grep -P '(Package|Version|Breaks)'
 Package: containerd
 Version: 1.5.2-0ubuntu1~20.04.2
 Breaks: docker.io (<< 19.03.8-0ubuntu1.20.04.2)

So it breaks if you're using the newest docker19 in focal (19.03.8-0ubuntu1.20.04.1) https://packages.ubuntu.com/focal/docker.io

Publishing history of the .2 release:
https://launchpad.net/ubuntu/+source/docker.io/19.03.8-0ubuntu1.20.04.2/+publishinghistory
Not sure why it was deleted and uploaded.

I assume this slipped thru because docker20 is focal-updates and so that's what most folks would run. Docker20 satisfies the "Breaks" >= stanza in the package, but all available versions of docker19 degs are broken with the new containerd.

Steps to reproduce on a clean focal machine:
apt-get update -qq
apt-get install install docker.io=19.03.8-0ubuntu1.20.04.1

For example under docker on my mac:
% docker pull ubuntu:focal
% docker run -it ubuntu:focal bash -c "apt-get update -qq && apt-get install docker.io=19.03.8-0ubuntu1.20.04.1"
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 docker.io : Depends: containerd (>= 1.2.6-0ubuntu1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Revision history for this message
Miriam España Acebal (mirespace) wrote :

Thank you for taking the time to file a bug report.

It seems that your point is to use the latest containerd version with and old docker.io version. We kindly suggest, if it's possible for you, update to the latest docker.io version from updates repositories. We can't figure out more about your necessity of installing 19.03.8-0ubuntu1.20.04.1 version without more context from your side... it seems you're receiving only security updates, not updates, but we can't confirm that without more information.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explain why you believe this is a bug in Ubuntu
rather than a problem specific to your system, and then change the bug
status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in containerd (Ubuntu):
status: New → Incomplete
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue.

This is happening because containerd relies on a version of docker.io in -updates, which in turn requires a version of runc in -updates.

This issue affects environments where the updates pocket is disabled and only the security pocket is used.

We will rebuild docker.io and runc in the -security pocket and will publish them early next week.

no longer affects: containerd (Ubuntu Groovy)
Changed in containerd (Ubuntu Bionic):
status: New → In Progress
Changed in containerd (Ubuntu Focal):
status: New → In Progress
Changed in containerd (Ubuntu Hirsute):
status: New → In Progress
status: In Progress → Invalid
Changed in containerd (Ubuntu Impish):
status: Incomplete → Invalid
Changed in containerd (Ubuntu Bionic):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in containerd (Ubuntu Focal):
assignee: nobody → Marc Deslauriers (mdeslaur)
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Looks like this only affects bionic and focal.

Changed in docker.io (Ubuntu Hirsute):
status: New → Invalid
Changed in docker.io (Ubuntu Impish):
status: New → Invalid
Changed in docker.io (Ubuntu Bionic):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → In Progress
Changed in docker.io (Ubuntu Focal):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 20.10.2-0ubuntu1~20.04.3

---------------
docker.io (20.10.2-0ubuntu1~20.04.3) focal-security; urgency=medium

  * No change rebuild in -security pocket. (LP: #1937286)

 -- Marc Deslauriers <email address hidden> Fri, 23 Jul 2021 15:35:35 -0400

Changed in docker.io (Ubuntu Focal):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 20.10.2-0ubuntu1~18.04.3

---------------
docker.io (20.10.2-0ubuntu1~18.04.3) bionic-security; urgency=medium

  * No change rebuild in -security pocket. (LP: #1937286)

 -- Marc Deslauriers <email address hidden> Fri, 23 Jul 2021 15:36:13 -0400

Changed in docker.io (Ubuntu Bionic):
status: In Progress → Fix Released
Changed in containerd (Ubuntu Bionic):
status: In Progress → Invalid
Changed in containerd (Ubuntu Focal):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers