kdm requires type you details in twice

Bug #495100 reported by Dave Morley on 2009-12-10
136
This bug affects 24 people
Affects Status Importance Assigned to Milestone
ConsoleKit
Fix Released
Medium
consolekit (Debian)
Fix Released
Unknown
consolekit (Ubuntu)
High
Unassigned
Nominated for Lucid by 3vi1

Bug Description

Binary package hint: kdebase-workspace

When logging in for the first time on kde the screen flashes and you are back to kdm upon typing in you password again it successfully logs into the system as expected

ProblemType: Bug
Architecture: amd64
Date: Thu Dec 10 15:52:11 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091210)
Package: kdm 4:4.3.80-0ubuntu1
ProcEnviron:
 LANGUAGE=
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
SourcePackage: kdebase-workspace
Tags: lucid
Uname: Linux 2.6.32-7-generic x86_64

Related branches

Dave Morley (davmor2) wrote :
koso (koso) wrote :

The same problem here, i have to login twce before desktop is started ...

From log files:
- :0[1305]: Cannot open ConsoleKit session: Unable to open session: Method "OpenSessionWithParameters" with signature "a(sv)" on interface "org.freedesktop.ConsoleKit.Manager" doesn't exist
- :0[1305]: Client start failed
- :0[1305]: Cannot close ConsoleKit session: Unable to close session: no session open

Can confirm as well

Cary

Scott Kitterman (kitterman) wrote :

Confirmed based on multiple IRC reports.

Changed in kdebase-workspace (Ubuntu):
importance: Undecided → High
status: New → Confirmed

Downstream report is here:

https://bugzilla.redhat.com/show_bug.cgi?id=545267

Relevant quote:

okay after about 20 reboots I got this to happen on my system with the latest
dbus and consolekit.

It looks like we're hitting *another* bug by being the first user to use
ConsoleKit.

There's one thing that looks suspicious in the ConsoleKit code. We take a name
on the bus before we register a handler for the call GDM is making.

So the race could be something like:

1) GDM calls OpenSessionWithParameters
2) d-bus notices consolekit isn't running and starts it
3) consolekit starts up and takes a name on the bus
4) consolekit registers handlers for the methods it supports
5) consolekit enters its event loop to process events

When the d-bus daemon notices ConsoleKit has taken a name (step 3) it delivers
the pending gdm call. If that happens before step 4 then it could explain this
behavior.

starslights (starslights) wrote :

hello,

same for me on x86 64

Xavier Tardivel (the-frog45) wrote :

This also affects i386 build.

By the way I can't get out of hibernation since a few days ago, and I think this is related : instead of waking up to my restored X session, X crashes and all I got is the default KDE login screens once X has restarted.

Alan Young (alanfyoung) wrote :

Is this not related to the autologin problems reported under # 495057 ?

Jonathan Thomas (echidnaman) wrote :

ConsoleKit issue, according to the Debian bug.

affects: kdebase-workspace (Ubuntu) → consolekit (Ubuntu)
Changed in consolekit (Debian):
status: Unknown → Confirmed
Luis F. Lopez (luis.lopez) wrote :

As per debian bug report: Apparently, upstream has a fix for this:

http://cgit.freedesktop.org/ConsoleKit/commit/?id=2418840248f07025ad0edc96ed17e03ce5e47f3e

Changed in consolekit:
status: Unknown → Confirmed
BlCa (blca) wrote :

In case someone else is sick of this pesky bug, here's a fixed package using the aforementioned patch :

https://edge.launchpad.net/~blca/+archive/temp/+packages

tags: added: iso-testing
Luis F. Lopez (luis.lopez) wrote :

I can confirm that the bug is still present in Alpha 2.

Also, packages from BlCa's ppa work as advertised ;) Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package consolekit - 0.4.1-2ubuntu2

---------------
consolekit (0.4.1-2ubuntu2) lucid; urgency=low

  * Add kubuntu-05-bus_name.patch patch, Closes LP: #495100
    "KDM requires type you details in twice"
 -- Yann Gilson <email address hidden> Tue, 12 Jan 2010 14:54:59 +0100

Changed in consolekit (Ubuntu):
status: Confirmed → Fix Released
Jonathan Riddell (jr) wrote :

Thanks for the package blca, I've uploaded it.

starslights (starslights) wrote :

hello,

I have installed kubuntu lucid alpha2 and i confirm that's this bug are fixed for me

Thanks

Best Regards

Stars

kpk187 (kpk187) wrote :

Hi, I just installed the latest software updates and I can confirm that this bug is also fixed for me.

fejes (anthony-fejes) wrote :

For what its worth, it is also fixed for me too. Thanks!

Changed in consolekit (Debian):
status: Confirmed → Fix Released

Seems like fixed in master.

Changed in consolekit:
status: Confirmed → Fix Released
Changed in consolekit:
importance: Unknown → Medium
Changed in consolekit:
importance: Medium → Unknown
Changed in consolekit:
importance: Unknown → Medium
Ruslan (b7-10110111) wrote :

The same symptoms still appear in Precise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.