D-BUS activation fails to start console-kit-daemon with error: "Success"

Bug #475503 reported by Andy Ruddock on 2009-11-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
consolekit (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Launching the System -> Administration -> Users and Groups results in a dialog "The configuration could not be loaded", An unknown error occurred.

Running from a terminal :

$ users-admin

(users-admin:6773): polkitgtk-WARNING **: Error sync-checking authorization for action id `org.freedesktop.systemtoolsbackends.set': Remote Exception invoking org.freedesktop.PolicyKit1.Authority.CheckAuthorization() on /org/freedesktop/PolicyKit1/Authority at name org.freedesktop.PolicyKit1: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

(users-admin:6773): Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

$ apt-cache policy gnome-system-tools
gnome-system-tools:
  Installed: 2.28.1-0ubuntu2
  Candidate: 2.28.1-0ubuntu2
  Version table:
 *** 2.28.1-0ubuntu2 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Milan Bouchet-Valat (nalimilan) wrote :

Thanks for your report. The error comes from PolicyKit, whose daemon can't be started for some reason. You may work around this problem by running 'sudo /usr/lib/policykit-1/polkitd' before starting users-admin. Could you confirm that this works? That information will help us to determine the cause of the bug.

affects: gnome-system-tools (Ubuntu) → policykit-1 (Ubuntu)
Changed in policykit-1 (Ubuntu):
status: New → Incomplete
summary: - users-admin fails to start
+ D-BUs activation fails to start polkitd with error: "Success"
summary: - D-BUs activation fails to start polkitd with error: "Success"
+ D-BUS activation fails to start polkitd with error: "Success"

$ sudo /usr/lib/policykit-1/polkitd

Registering null backend at priority -10

** (process:15531): WARNING **: Error getting seats: Remote Exception invoking org.freedesktop.ConsoleKit.Manager.GetSeats() on /org/freedesktop/ConsoleKit/Manager at name org.freedesktop.ConsoleKit: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success
Using authority class PolkitBackendLocalAuthority

(process:15531): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15531): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(process:15531): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(process:15531): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15531): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Error registering authority: Could not become primary name owner for org.freedesktop.PolicyKit1

$ sudo users-admin

(users-admin:16247): Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

Andy Ruddock (andy-ruddock) wrote :

Didn't mention that this error is on amd64, the i386 installs on other machines all work ok.

Milan Bouchet-Valat (nalimilan) wrote :

Thanks for the details. Somewhat funny, the problem comes from even further, it looks like ConsoleKit fails to start, which makes PolicyKit fail too. What does the following command say?
sudo /usr/sbin/console-kit-daemon

affects: policykit-1 (Ubuntu) → consolekit (Ubuntu)
summary: - D-BUS activation fails to start polkitd with error: "Success"
+ D-BUS activation fails to start console-kit-daemon with error: "Success"
Andy Ruddock (andy-ruddock) wrote :

One or two other strange things began to occur on this machine, which has survived upgrades for about two years (things like usb memory sticks suddenly not being recognised) so I decided to do a clean install.
(It's great that you can install from scratch, restore all your data and begin to be productive again in the time that it takes to do a base install of other operating systems)
The user admin tool now works admirably, so it would appear that the problem lay with my machine, not with your software - which is nice.
Unless you get any "this also affects me" reports I'd drop this bug. Thanks for the help.

Milan Bouchet-Valat (nalimilan) wrote :

It's somewhat sad you didn't try to fix this, because it must be a bug in any case. Upgrading often creates problems after a while, but we should work to avoid that. OTOH I completely understand that you prefer cleaning your system instead of suffering from bugs all the time - indeed, Ubuntu is quite easy to reinstall when you have your date on a separate partition.

Closing the report for now, as I don't think many people will experience the same problem.

Changed in consolekit (Ubuntu):
status: Incomplete → Invalid
Andy Ruddock (andy-ruddock) wrote :

This was not the only bug affecting the system and had it been any other machine I probably could have lived with them to find a solution.
As with any machine that gets used for development and experimentation there comes a time where a fresh start is probably the best solution - and this was that time.
Thanks again.

Virg (jpvirgin) wrote :

I seem to be having the same problem and I would like to try to fix without reinstalling. Intel i386 machine. Currently running Karmic but I know this was happening in Jaunty and possibly earlier. I'm new to the launchpad so please bear with me while I learn the ropes

Virg (jpvirgin) wrote :

Forgot to mention that I am also having problems mounting usb devices and I suspect the bugs are related.

Kjue (mlavi) wrote :

I think I am also experiencing this problem. I get some warnings when I run the polkit daemon and cannot get any information from the console-kit. I just did a fresh install and tried to bring my system to the same status as when I had on the Hardy installation. I copied the users from that installation along with their passwords and all. I was able to resume all my other services like apache, samba and myth, but when audio didn't start I started digging and got here.

If you are both experiencing this problem, we can resume debugging then. Could you post the output of
sudo /usr/sbin/console-kit-daemon
here?

Changed in consolekit (Ubuntu):
importance: Undecided → Medium
status: Invalid → Incomplete
Kjue (mlavi) wrote :

I get nothing from the console-kit-daemon with just sudo. When I run it as root (sudo su) I get:

console-kit-daemon[25719]: WARNING: Failed to acquire org.freedesktop.ConsoleKit
console-kit-daemon[25719]: WARNING: Could not acquire name; bailing out

Does it matter if I do it from the ssh-terminal or over a VNC connection?

I guess you'd need to kill the existing daemon if it exists:
sudo killall /usr/sbin/console-kit-daemon

But if it's already present, D-Bus wouldn't need to start it...

Kjue (mlavi) wrote :

When I did a reboot the console-kit-daemon started clean. After that I tried running the polkitd as root and then users-admin for the user over VNC. Here what comes for the users-admin:

Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

And then for polkitd:

# /usr/lib/policykit-1/polkitd
Registering null backend at priority -10
Using authority class PolkitBackendLocalAuthority

(process:3480): GLib-GObject-WARNING **: value "-1" of type `gint' is invalid or out of range for property `pid' of type `gint'
** (process:3480): DEBUG: system-bus-name::1.353 is inquiring whether unix-process:3503:47162 is authorized for org.freedesktop.systemtoolsbackends.set
** (process:3480): DEBUG: user of caller is unix-user:mlavi
** (process:3480): DEBUG: user of subject is unix-user:mlavi
** (process:3480): DEBUG: checking whether unix-process:3503:47162 is authorized for org.freedesktop.systemtoolsbackends.set
** (process:3480): WARNING **: skipping unknown tag <_description> at line 11
** (process:3480): WARNING **: skipping unknown tag <_message> at line 12
** (process:3480): WARNING **: skipping unknown tag <_description> at line 12
** (process:3480): WARNING **: skipping unknown tag <_message> at line 13
** (process:3480): WARNING **: skipping unknown tag <_description> at line 21
** (process:3480): WARNING **: skipping unknown tag <_message> at line 22
** (process:3480): WARNING **: skipping unknown tag <_description> at line 30
** (process:3480): WARNING **: skipping unknown tag <_message> at line 31
** (process:3480): WARNING **: skipping unknown tag <_description> at line 39
** (process:3480): WARNING **: skipping unknown tag <_message> at line 40
** (process:3480): DEBUG: (nil)
** (process:3480): DEBUG: not authorized
** (process:3480): DEBUG:

Mmm... Those warnings are really different from those of the original report. Why do you think you're experiencing the same problem? It's always good to avoid dealing with different issues on the same report.

And BTW, I've skipped your question form the previous comment: running via SSH or VNC actually matters here, because ConsoleKit might be wrong in detecting that your user is active. So please performs all checks from a local session, so that we know where the problem comes from.

Virg: are the symptoms you're seeing the same as the original reporter?

Kjue (mlavi) wrote :

I'll check this again when I get home. Thanks so far!

Gitykins (gitykins) wrote :

I'd really like to continue debugging this bitch... It causes a whole bunch of other problems that I just can't live with...

Anyways, I decided to just start using root for all of this, and got this error the first time I tried to run
/usr/sbin/console-kit-daemon
as root:
console-kit-daemon[25719]: WARNING: Failed to acquire org.freedesktop.ConsoleKit
console-kit-daemon[25719]: WARNING: Could not acquire name; bailing out

I then did
killall /usr/sbin/console-kit-daemon
and then once again ran
/usr/sbin/console-kit-daemon
and got no errors.

Then, I ran
/usr/lib/policykit-1/polkitd
and got this as an output:
Registering null backend at priority -10
Using authority class PolkitBackendLocalAuthority

(process:25450): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:25450): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(process:25450): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(process:25450): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:25450): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Error registering authority: Could not become primary name owner for org.freedesktop.PolicyKit1

Then, I once again tried to run
time-admin
and got the common error:
'
(time-admin:25451): Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

The polkitd part does not work because the daemon was already running. Could you try
sudo killall /usr/lib/policykit-1/polkitd
sudo /usr/lib/policykit-1/polkitd

David Wynn (wynn-david) wrote :

First, just want to clear the air. I'm using a Linux Mint system, not a straight Ubuntu system. But Mint is Ubuntu-based. I also followed the upgrade path, instead of installing fresh. Mine was a more indirect upgrade. I believe my path was something like Mint Xubuntu Gloria -> Ubuntu Karmic -> Mint Ubuntu Helena. (Wireless networking was not "Just Working" under straight Ubuntu -- no problems in Mint)

$ lsb_release -rd
Description: Linux Mint 8 Helena - Main Edition
Release: 8

$ apt-cache policy gnome-system-tools
gnome-system-tools:
  Installed: 2.28.1-0ubuntu2
  Candidate: 2.28.1-0ubuntu2
  Version table:
 *** 2.28.1-0ubuntu2 0
        500 http://ubuntu.osuosl.org karmic/main Packages
        100 /var/lib/dpkg/status

I was also getting this message from my computer:

$ gksu users-admin

(users-admin:11756): Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

I've tried the above:
$ sudo killall /usr/sbin/console-kit-daemon
$ sudo /usr/sbin/console-kit-daemon
$ sudo killall /usr/lib/policykit-1/polkitd
/usr/lib/policykit-1/polkitd: no process found
$ sudo /usr/lib/policykit-1/polkitd
Registering null backend at priority -10
Using authority class PolkitBackendLocalAuthority

At this point, the first terminal session did not give me a c/l back, so I went to a second terminal session:

$ gksu users-admin
(users-admin:12665): Liboobs-WARNING **: There was an unknown error communicating with the backends: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success

Back on the first terminal, I now see:

$ sudo /usr/lib/policykit-1/polkitd
Registering null backend at priority -10
Using authority class PolkitBackendLocalAuthority

(process:12651): GLib-GObject-WARNING **: value "-1" of type `gint' is invalid or out of range for property `pid' of type `gint'
** (process:12651): DEBUG: system-bus-name::1.1893 is inquiring whether unix-process:12665:322721 is authorized for org.freedesktop.systemtoolsbackends.set
** (process:12651): DEBUG: user of caller is unix-user:root
** (process:12651): DEBUG: user of subject is unix-user:root
** (process:12651): DEBUG: checking whether unix-process:12665:322721 is authorized for org.freedesktop.systemtoolsbackends.set

** (process:12651): WARNING **: skipping unknown tag <_description> at line 11

** (process:12651): WARNING **: skipping unknown tag <_message> at line 12

** (process:12651): WARNING **: skipping unknown tag <_description> at line 12

** (process:12651): WARNING **: skipping unknown tag <_message> at line 13

** (process:12651): WARNING **: skipping unknown tag <_description> at line 21

** (process:12651): WARNING **: skipping unknown tag <_message> at line 22

** (process:12651): WARNING **: skipping unknown tag <_description> at line 30

** (process:12651): WARNING **: skipping unknown tag <_message> at line 31

** (process:12651): WARNING **: skipping unknown tag <_description> at line 39

** (process:12651): WARNING **: skipping unknown tag <_message> at line 40
** (process:12651): DEBUG:

OK, I've found the problem. It's not related to ConsoleKit directly, I was actually misled by a warning shown for some reporters, but not all. It seems that the messagebus user and groups don't match after an upgrade, which cause D-Bus activation to fail. See https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/295405/comments/15.

To fix this on your computer, edit your /etc/group file. Find the group 'messagebus', on a line like:
messagebus:x:OLD_GID:
where OLD_GID is the GID of the group. Check that another group is using the same GID (which is the root cause of this bug). If that's the case, you should find a free GID, use it for the group messagebus, and then run:
sudo find / -gid OLD_GID -exec chgrp NEW_GID '{}' \;

Then, edit /etc/passwd and change the line
messagebus:x:108:OLD_GID::/var/run/dbus:/bin/false
replacing OLD_GID with the NEW_GID. You may need to reboot for the changes to take effect.

Please report if that works for you.

Biocyberman (biocyberman) wrote :

It's now 2014! I landed on this page because I saw exact error message from my Ubuntu 21.04 box. Milan comment (https://bugs.launchpad.net/ubuntu/+source/consolekit/+bug/475503/comments/20) was helpful for me. But WAIT! I did not take his advice literally and I am glad that I did that.

A while a go I was careless enough to run "sudo chown -R myuser:root /usr". I fixed that mistake by copying ownership and permissions from another machine, but apparently it did not fix everything. After reading Milan's comment, I did this:

On the problematic server:
ls -lah /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwxr-xr-- 1 root root 287K Jun 13 2013 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

On the intact server:
ls -lah /usr/lib/dbus-1.0/dbus-daemon-launch-helper
-rwsr-xr-- 1 root messagebus 287K Jun 13 2013 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

So a chmod command fixed it:
sudo chmod 4754 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

So running "sudo find / -gid OLD_GID -exec chgrp NEW_GID '{}' \;" would be potentially very dangerous and time consuming too. One more WARNING: /usr is not really for "users". It's still a system directory that Linux does not like at all if you mess up with ownerships and permissions there.

It's old thread but I want to write and save someone from troubles.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers