console-kit-daemon: glibgobject warning value location for gachararray passed as null

Bug #374397 reported by thomas richard on 2009-05-10
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ConsoleKit
Fix Released
Medium
consolekit (Fedora)
Fix Released
Medium
consolekit (Ubuntu)
Medium
Unassigned

Bug Description

I use ubuntu jaunty 64 finale release
When I shut down the system (the normal way) a pop-up window with a warning I don't have the time to read appears at the bottom of the desktop just before the system shuts down. I thought it was because I stop it before countdown is over but the same thing happens if I wait 'till the countdown is over.
So I opened the system reports to see what was written at the time of this pop-up warning and all I found was this :

 noun-desktop console-kit-daemon[2805]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
May 10 00:37:13 noun-desktop last message repeated 6 times
May 10 00:37:13 noun-desktop init: tty4 main process (2500) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty5 main process (2501) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty2 main process (2508) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty3 main process (2509) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty6 main process (2510) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty1 main process (3350) killed by TERM signal
May 10 00:37:13 noun-desktop console-kit-daemon[2805]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
May 10 00:37:13 noun-desktop last message repeated 5 times
May 10 00:37:16 noun-desktop bluetoothd[2967]: bridge pan0 removed
May 10 00:37:16 noun-desktop bluetoothd[2967]: Stopping SDP server
May 10 00:37:16 noun-desktop bluetoothd[2967]: Exit

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic x86_64

With current Rawhide, I get four copies of this syslog message every time I log in:

Apr 20 07:12:59 jik2 console-kit-daemon[2079]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
Apr 20 07:12:59 jik2 console-kit-daemon[2079]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
Apr 20 07:12:59 jik2 console-kit-daemon[2079]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
Apr 20 07:12:59 jik2 console-kit-daemon[2079]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL

This might fix it, I think

diff -up ConsoleKit-0.3.0/src/ck-manager.c.null-warning ConsoleKit-0.3.0/src/ck-manager.c
--- ConsoleKit-0.3.0/src/ck-manager.c.null-warning 2009-04-20 23:55:53.248884043 -0400
+++ ConsoleKit-0.3.0/src/ck-manager.c 2009-04-20 23:56:27.736126951 -0400
@@ -1213,7 +1213,7 @@ session_is_real_user (CkSession *session

         g_object_get (session,
                       "unix-user", &uid,
- "session-type", session_type,
+ "session-type", &session_type,
                       NULL);

         username = get_user_name (uid);

Built in ConsoleKit-0.3.0-8.fc11

I use ubuntu jaunty 64 finale release
When I shut down the system (the normal way) a pop-up window with a warning I don't have the time to read appears at the bottom of the desktop just before the system shuts down. I thought it was because I stop it before countdown is over but the same thing happens if I wait 'till the countdown is over.
So I opened the system reports to see what was written at the time of this pop-up warning and all I found was this :

 noun-desktop console-kit-daemon[2805]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
May 10 00:37:13 noun-desktop last message repeated 6 times
May 10 00:37:13 noun-desktop init: tty4 main process (2500) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty5 main process (2501) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty2 main process (2508) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty3 main process (2509) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty6 main process (2510) killed by TERM signal
May 10 00:37:13 noun-desktop init: tty1 main process (3350) killed by TERM signal
May 10 00:37:13 noun-desktop console-kit-daemon[2805]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
May 10 00:37:13 noun-desktop last message repeated 5 times
May 10 00:37:16 noun-desktop bluetoothd[2967]: bridge pan0 removed
May 10 00:37:16 noun-desktop bluetoothd[2967]: Stopping SDP server
May 10 00:37:16 noun-desktop bluetoothd[2967]: Exit

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic x86_64

Marcerino (mastervanleeuwen) wrote :

I see the same behaviour. There is also a series of rather annoying beeps when shutting down, which I suspect is related (note above: last message repeated 5 times; I think I get six beeps).

My system was updated from Hardy Heron to Jaunty Jackalope, maybe something was not properly reconfigured/updated?

summary: - glibgobject warning value location for gachararray passed as null
+ console-kit-daemon: glibgobject warning value location for gachararray
+ passed as null
affects: ubuntu → consolekit (Ubuntu)
Peter Nagy (antronin) wrote :

Would this be a solution for this?
https://bugzilla.redhat.com/show_bug.cgi?id=496636
For me it seems to be a similar bug in Fedora, and as I see they found a solution to it...
Somebody with more linux knowledge would be so kind to check if it applies to Ubuntu either?

EugeneI (eugenestm) wrote :

I don't have much knowledge in linux or programming but I think that Matthias Clasen on bugzilla is right: should be an & before session_type. No matter will it solve our problem or not.
See http://library.gnome.org/devel/gobject/unstable/gobject-The-Base-Object-Type.html#g-object-get

This error is in consolekit 0.3.0 sources. And it's not corrected in consolekit_0.3.0-2ubuntu4.diff (current version for Ubuntu 9.04).
But what's interesting is that the same error is in 0.2.10 sources and also not corrected in consolekit_0.2.10-1ubuntu10.diff (current version for 8.10).
May be it's intended after all?

I don't know may be it's better to wait and see what William Jon McCann (author of consolekit) will do with it? Or file another bug in launchpad? Something like "Possibly incorrectly passed argument to g_object_get() in ck-manager.c line 1216". Or contact directly maintainer or developer? I have no experience in dealing with errors/bugs.

Can somebody check syslog is there only this line at shutdown or some other warnings too: "GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL"?
On my system not every day I get additional warnings.

James Westby (james-w) on 2009-05-31
Changed in consolekit (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in consolekit:
status: Unknown → Confirmed
Changed in consolekit (Fedora):
status: Unknown → Fix Committed
Steven (stebalien) wrote :

I can confirm that the fedora fix works on ubuntu.

This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

EugeneI (eugenestm) wrote :

There is no beeps and no warning messages in syslog when rebooting PC after software/security update (via "blue arrows" icon appearing on top Gnome panel).

Changed in consolekit:
status: Confirmed → Fix Released
Marcerino (mastervanleeuwen) wrote :

Eugenel, which version do you have installed (you can look up this info with the Synaptic Package Manager)?

I have 0.3.0-2ubuntu4 and the problem persists.

EugeneI (eugenestm) wrote :

Sorry, didn't visited launchpad. If my answer is of any use after this time: I have the same version as you.

I guess this minor gnome update fixes this beeping. ftp.gnome.org/pub/GNOME/desktop/2.26/2.26.3/NEWS mentions: "- Make gnome-session exit properly on reboot/shutdown". And as Steven wrote - Fedora fix works.

But for me it's until Karmic is out as I won't risk to update Gnome or to recompile console-kit without firm understanding of how to do it.

James Westby (james-w) wrote :

Fixed when 0.3.1 was uploaded to karmic.

Thanks,

James

Changed in consolekit (Ubuntu):
status: Triaged → Fix Released
Changed in consolekit (Fedora):
status: Fix Committed → Fix Released
guiliker (gothishpoof) wrote :

Hi,

I found this on a google search and the description above very accurately describes what is happening to my newly upgraded to Jaunty box, what with the beeps and too quickly disappearing warning window. I'm just curious as to why this is still happening if a fix has been released through ubuntu repo's?

This is an extract of syslog:
Oct 27 02:53:36 ub-j console-kit-daemon[2663]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
Oct 27 02:53:36 ub-j last message repeated 8 times
Oct 27 02:53:36 ub-j init: tty4 main process (2145) killed by TERM signal
Oct 27 02:53:36 ub-j init: tty5 main process (2146) killed by TERM signal
Oct 27 02:53:36 ub-j init: tty2 main process (2153) killed by TERM signal
Oct 27 02:53:36 ub-j init: tty3 main process (2154) killed by TERM signal
Oct 27 02:53:36 ub-j init: tty6 main process (2155) killed by TERM signal
Oct 27 02:53:36 ub-j init: tty1 main process (3151) killed by TERM signal
Oct 27 02:53:38 ub-j kernel: [ 6853.917246] mtrr: no MTRR for 40000000,10000000 found
Oct 27 02:53:39 ub-j nm-system-settings: SCPlugin-Ifupdown: devices removed (udi: /org/freedesktop/Hal/devices/net_0a_00_27_00_00_00)
Oct 27 02:53:43 ub-j bluetoothd[2815]: bridge pan0 removed
Oct 27 02:53:43 ub-j bluetoothd[2815]: Stopping SDP server
Oct 27 02:53:43 ub-j bluetoothd[2815]: Exit
Oct 27 02:53:43 ub-j exiting on signal 15

guiliker a écrit :
> Hi,
>
> I found this on a google search and the description above very
> accurately describes what is happening to my newly upgraded to Jaunty
> box, what with the beeps and too quickly disappearing warning window.
> I'm just curious as to why this is still happening if a fix has been
> released through ubuntu repo's?
>
> This is an extract of syslog:
> Oct 27 02:53:36 ub-j console-kit-daemon[2663]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
> Oct 27 02:53:36 ub-j last message repeated 8 times
> Oct 27 02:53:36 ub-j init: tty4 main process (2145) killed by TERM signal
> Oct 27 02:53:36 ub-j init: tty5 main process (2146) killed by TERM signal
> Oct 27 02:53:36 ub-j init: tty2 main process (2153) killed by TERM signal
> Oct 27 02:53:36 ub-j init: tty3 main process (2154) killed by TERM signal
> Oct 27 02:53:36 ub-j init: tty6 main process (2155) killed by TERM signal
> Oct 27 02:53:36 ub-j init: tty1 main process (3151) killed by TERM signal
> Oct 27 02:53:38 ub-j kernel: [ 6853.917246] mtrr: no MTRR for 40000000,10000000 found
> Oct 27 02:53:39 ub-j nm-system-settings: SCPlugin-Ifupdown: devices removed (udi: /org/freedesktop/Hal/devices/net_0a_00_27_00_00_00)
> Oct 27 02:53:43 ub-j bluetoothd[2815]: bridge pan0 removed
> Oct 27 02:53:43 ub-j bluetoothd[2815]: Stopping SDP server
> Oct 27 02:53:43 ub-j bluetoothd[2815]: Exit
> Oct 27 02:53:43 ub-j exiting on signal 15
>
>
A very good question indeed !
I was wondering about it myself.
I can tell you that I don't have this bug anymore since my upgrade to
the beta version of karmic koala (though maybe it hasn't been solved for
all types of computers).
So all you have to do is wait for october the 29th and upgrade to Ubuntu
9.10 that day.

I know this is an old bug, but it has only just started affecting my system since I downloaded linux-headers 2.6.28-18 yesterday. The effect it has at shutdown isn't always the same, but the message is:
Feb 6 19:47:05 padraic-laptop console-kit-daemon[2688]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
Feb 6 19:47:05 padraic-laptop last message repeated 2 times
Feb 6 19:47:06 padraic-laptop init: tty4 main process (2297) killed by TERM signal
Feb 6 19:47:06 padraic-laptop init: tty5 main process (2298) killed by TERM signal
Feb 6 19:47:06 padraic-laptop init: tty2 main process (2304) killed by TERM signal
Feb 6 19:47:06 padraic-laptop init: tty3 main process (2306) killed by TERM signal
Feb 6 19:47:06 padraic-laptop init: tty6 main process (2307) killed by TERM signal
Feb 6 19:47:06 padraic-laptop init: tty1 main process (3232) killed by TERM signal
Feb 6 19:47:12 padraic-laptop bluetoothd[2856]: Stopping SDP server
Feb 6 19:47:12 padraic-laptop bluetoothd[2856]: Exit
Feb 6 19:47:13 padraic-laptop exiting on signal 15

I also get these weird lines in startup I never noticed before:
Feb 6 20:21:31 padraic-laptop kernel: [ 36.780028] eth1: no IPv6 routers present
Feb 6 20:21:42 padraic-laptop console-kit-daemon[2696]: WARNING: Couldn't read /proc/2695/environ: Failed to open file '/proc/2695/environ': No such file or directory
Feb 6 20:21:50 padraic-laptop x-session-manager[3366]: WARNING: Could not parse desktop file /etc/xdg/autostart/update-notifier-kde.desktop: Key file does not have key 'Type'
Feb 6 20:21:50 padraic-laptop x-session-manager[3366]: WARNING: could not read /etc/xdg/autostart/update-notifier-kde.desktop

Note: My system is 32-bit, i686, so a little different.

Padraic Calpin a écrit :
> I know this is an old bug, but it has only just started affecting my system since I downloaded linux-headers 2.6.28-18 yesterday. The effect it has at shutdown isn't always the same, but the message is:
> Feb 6 19:47:05 padraic-laptop console-kit-daemon[2688]: GLib-GObject-WARNING: IA__g_object_get_valist: value location for `gchararray' passed as NULL
> Feb 6 19:47:05 padraic-laptop last message repeated 2 times
> Feb 6 19:47:06 padraic-laptop init: tty4 main process (2297) killed by TERM signal
> Feb 6 19:47:06 padraic-laptop init: tty5 main process (2298) killed by TERM signal
> Feb 6 19:47:06 padraic-laptop init: tty2 main process (2304) killed by TERM signal
> Feb 6 19:47:06 padraic-laptop init: tty3 main process (2306) killed by TERM signal
> Feb 6 19:47:06 padraic-laptop init: tty6 main process (2307) killed by TERM signal
> Feb 6 19:47:06 padraic-laptop init: tty1 main process (3232) killed by TERM signal
> Feb 6 19:47:12 padraic-laptop bluetoothd[2856]: Stopping SDP server
> Feb 6 19:47:12 padraic-laptop bluetoothd[2856]: Exit
> Feb 6 19:47:13 padraic-laptop exiting on signal 15
>
>
> I also get these weird lines in startup I never noticed before:
> Feb 6 20:21:31 padraic-laptop kernel: [ 36.780028] eth1: no IPv6 routers present
> Feb 6 20:21:42 padraic-laptop console-kit-daemon[2696]: WARNING: Couldn't read /proc/2695/environ: Failed to open file '/proc/2695/environ': No such file or directory
> Feb 6 20:21:50 padraic-laptop x-session-manager[3366]: WARNING: Could not parse desktop file /etc/xdg/autostart/update-notifier-kde.desktop: Key file does not have key 'Type'
> Feb 6 20:21:50 padraic-laptop x-session-manager[3366]: WARNING: could not read /etc/xdg/autostart/update-notifier-kde.desktop
>
> Note: My system is 32-bit, i686, so a little different.
>
>
They say on launchpad that a bug fix has been released for Ubuntu.
But I still have the problem every time I shut down the computer with
Ubuntu 9.10 so maybe they did not spread the bug fix through an update.
With the beta version of karmic the problem did not appear anymore but
with the finale release... it was back !
I wonder wether it has something to do with Compiz. The pop-up at
shutdown says something like my screen is not composited or something.
I still hope the problem will disappear in the next version : Lucid Lynx.

Changed in consolekit:
importance: Unknown → Medium
Changed in consolekit:
importance: Medium → Unknown
Changed in consolekit:
importance: Unknown → Medium
Changed in consolekit (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.