old-style loadkeys invocations no longer work

Bug #83487 reported by Adrian Bridgett
4
Affects Status Importance Assigned to Milestone
console-tools (Ubuntu)
Fix Released
Low
Unassigned
Hardy
Fix Released
Low
Unassigned
kbd (Ubuntu)
Fix Released
Undecided
Unassigned
Hardy
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: console-setup

Using Feisty beta2 (x86-64) I used "loadkeys uk" to change my keyboard settings. This reports "cannot open file uk". Strace()ing it shows that it's looking in /usr/share/keymaps/ which is empty as console-data is not installed.

I selected the "failsafe graphics" boot option (which failed, but that might be a vga card issue) - so it might be prompting me to select a keyboard, I don't know.

Revision history for this message
Colin Watson (cjwatson) wrote :

Unfortunately it isn't quite as simple as that with console-setup yet. The easiest approaches right now are either to edit /etc/default/console-setup and run setupcon, or to run 'ckbcomp -model pc105 gb | eval loadkeys'. I do agree that a simpler wrapper should exist, though, possibly via loadkeys for compatibility. Not sure how to deal with keymap names now being expressed in terms of X though.

Changed in console-setup:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Revision history for this message
Martin Olsson (mnemo) wrote :

I also ran into this bug (even though I tried "loadkeys se" to get swedish keyboard). Trying to workaround broken wifi and broken X.org with all the keys in random places is really hard. :-/

Revision history for this message
Martin Olsson (mnemo) wrote :

Instead of editing "/etc/default/console-setup" one can also run "dpkg-reconfigure console-setup". This will give you a console based menu system where you answer a couple of basic question. For my swedish keyboard I went with pc105 (generic 105-key (intl) pc), sweden, sweden, right alt, no compose key, utf-8, latin1/latin5, vga font and fontsize 16 (which on my widescreen laptop looks like the good old MS-DOS font).

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-tools - 1:0.2.3dbs-65ubuntu6

---------------
console-tools (1:0.2.3dbs-65ubuntu6) hardy; urgency=low

  * 999_ubuntu_loadkeys_console-setup.patch: Use ckbcomp to get the keyboard
    layout if other data files are not available (LP: #83487).

 -- Colin Watson <email address hidden> Mon, 04 Feb 2008 14:04:06 +0000

Changed in console-tools:
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kbd - 1.12-19ubuntu2

---------------
kbd (1.12-19ubuntu2) hardy; urgency=low

  * loadkeys_console-setup.patch: Use ckbcomp to get the keyboard layout if
    other data files are not available (LP: #83487).

 -- Colin Watson <email address hidden> Mon, 04 Feb 2008 14:19:21 +0000

Changed in kbd:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers