keyboard_names.py and console-setup's layout/variant list don't match

Bug #953328 reported by Florian Reinhard on 2012-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Undecided
Stéphane Graber

Bug Description

* Booted 12.04 Beta 1, amd64 desktop from an USB-stick.
* After selecting the timezone the keyboard layout should be choosen
* I've been cycling through the keyboardlayouts and at "German - German (qwerty)" the installer crashed

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/plugin.py", line 44, in wrapper
    return target(self, *args, **kwargs)
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 300, in on_keyboard_variant_selected
    var = variantMap[misc.utf8(variant)]
KeyError: u'German - German (qwerty)'

Jonathan Riddell (jr) on 2012-03-14
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-12.04-beta-2
tags: added: kubuntu
Stéphane Graber (stgraber) wrote :

I'll take a look

Changed in ubiquity (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
Changed in ubiquity (Ubuntu):
status: New → Triaged
Stéphane Graber (stgraber) wrote :

I haven't found the exact source of the bug yet though I can confirm it's a KDE only bug.

There seems to be some missing layouts in the variantMap. I'll have another look later/tomorrow and see if I can maybe get the logic of the gtk version into the qt one.

Stéphane Graber (stgraber) wrote :

Actually, it also affects the gtk frontend, it just doesn't crash :)
This is most likely caused by console-setup not being in sync with what our X server supports, I'm doing a test rebuild to ensure this fixes it.

summary: - Kubuntu 12.04 Beta 1: ubiquity crash at keyboard selection
+ keyboard_names.py and console-setup's layout/variant list don't match
affects: ubiquity (Ubuntu) → console-setup (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.70ubuntu3

---------------
console-setup (1.70ubuntu3) precise; urgency=low

  * No change rebuild for new xkb-data. (LP: #953328)
 -- Stephane Graber <email address hidden> Thu, 15 Mar 2012 11:48:58 -0400

Changed in console-setup (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers