Ubuntu

French alternative keyboard should be default

Reported by Patrice Vetsel on 2007-03-05
6
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Wishlist
Colin Watson
xorg (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: ubiquity

When ubiquity ask for the keyboard configuration for french/france keyboard, it assume that the "France" is the default and this choice is pre-selectioned. So 99% of french users use the proposed choice.

French keyboard have evolved from latin1 to latin9 and now to fr-oss.

The fr file symbols included in xkeyboard-config0.9, after discussions on lists/blog/and with the actual maintainer , is ready to be set as the default choice for French users.

So i propose that ubiquity automatically pre-select "France - Alternative" when it prompt for the keyboard configuration for France.

Changed in ubiquity:
importance: Undecided → Wishlist
Sun Wukong (sunwukong) wrote :

That's an excellent idea ! So that I won't have to do it manually everytime (like some dozen of thousands of others, I guess).

Good point man ! :-)

Sebastien Bacher (seb128) wrote :

The request seems a reasonable one. Patrice mailed the ubuntu-fr-l10n list about it and people there seems to think that the change is a good idea.

Colin Watson (cjwatson) wrote :

xorg (1:7.2-0ubuntu3) feisty; urgency=low

  * Set default keyboard variant for French to oss (LP: #89835).

 -- Colin Watson <email address hidden> Tue, 6 Mar 2007 11:20:23 +0000

Changed in xorg:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Colin Watson (cjwatson) wrote :

console-setup (1.13ubuntu7) feisty; urgency=low

  * Add lt to list of non-Latin keymaps (LP: #38931).
  * Map Caps Lock to Shift Lock for Turkish layouts.
  * Build keymap tree from MyKeyboardNames.pl rather than KeyboardNames.pl.
  * Add fr:oss to keymap tree.
  * Set default variant for French to oss (LP: #89835).
  * Remove Keyboard/*.tree on clean.
  * Fix six files in debian/ that were supposed to be symlinks.
  * Move console-setup-udeb's post-base-installer script to be a
    base-installer script instead, so that console-setup will be configured
    properly along with the initramfs during debootstrap.
  * Set Maintainer to me.

 -- Colin Watson <email address hidden> Tue, 6 Mar 2007 12:09:57 +0000

Changed in console-setup:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :
Download full text (5.7 KiB)

xorg (1:7.2-3ubuntu1) gutsy; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/control, debian/scripts/vars.sparc, debian/rules:
      + Makes xorg Architecture: any and use an extra variable
        to not Depends on type-handling.
    - debian/control:
      + Keep meta-packages for xbase-clients, xutils.
      + Change the Maintainer-field.
      + Add replaces for xinit since we now ship Xsession from x11-common.
        Ditto for xrgb as we ship rgb.txt in x11-common.
      + xserver-xorg: Add dependancy "OR xserver-xorg-video" because
        the restricted drivers provide that.
    - debian/local/Xsession:
      + If ~/.xsession-errors is bigger than 0.5MiB, truncate it to the last
        0.5MiB to avoid having it grow indefinitively. (This does not happen
        with gdm anyway since gdm cleans the file on login). (LP #60448)
    - debian/local/dexconf:
      + Uncoditionally re-enable ZAxisMapping in dexconf. (LP: #31827)
      + Add InputDevice entries for wacom.
      + Add extra bits for ps3fb xorg.conf.
      + Read xserver-xorg/config/device/extra_options key, parse it
        (first token is option name, rest of the line after first space
        is value), and add it as Option lines to the device section.
        (LP: #90109)
      + Add special case for i810 with 3M TouchScreen monitors to set a
        resolution of 800x600 and avoid probing since it will fail miserably
        in xserver-xorg.postinst. Also make sure to write Option "DisplayInfo"
        "False" in Device Section in dexconf if the above combination is
        matched otherwise the card will display extra unrequired info each
        time X attempts a startup. (touches also xserver-xorg.postinst.in)
      + Due to a very annoying DRI/DRM bug, make sure to use OldDmaInit
        when writing down the Device section for mga driver. This will make
        DRI working at least for AGP cards. PCI didn't work before and it will
        keep not working since the option does explicitly disable DRI for PCI.
        (LP: #27442)
      + Enable elographics driver when matching known machines.
      + Disable composite when using the fglrx driver. It does not support
        composition, and enabling it by default (as recently done in
        xorg-server) breaks DRI for fglrx. (LP: #90688)
    - debian/scripts/vars.i386:
      + Add xserver-xorg-input-elographics to XSERVER_XORG_INPUT_DEPENDS.
    - debian/xserver-xorg.postinst.in:
      + Add lt to list of non-Latin keymaps (LP: #38931).
      + Make sure to ask video driver on sparc even if autodetected. Some
        cards still require weird overrides (ati -> fbdev) that are not
        100% known in all combinations.
      + Skip video card autodetection if xforcevesa is set
        (LP #27020, #59618).
      + Detect keyboard layout configuration using /etc/default/console-setup
        if available.
      + Clean up duplicate keymaps in xserver-xorg.config.in and make sure
        they're all neatly alphabetised.
      + Map cf console keymap to ca(fr).
      + Map croat console keymap to hr. (LP: #43598)
      + Set default keyboard variant for French to oss (LP: #89835).
      + Map...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers