Ubuntu

d-i preseeded installation fails because keyboard-configuration/xkb-keymap is not set

Reported by Jean-Baptiste Lallement on 2011-11-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

Starting from 20111120, preseeded d-i installation fails because keyboard-configuration/xkb-keymap is not set and ask for a question to select a keymap.

Logs and preseed attached

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: console-setup 1.70ubuntu1
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.26-0ubuntu1
Architecture: amd64
Date: Wed Nov 23 23:44:49 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: console-setup
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Log file of a successful installation (20111119)

Jean-Baptiste Lallement (jibel) wrote :

log file of a broken installation (20111120)

Colin Watson (cjwatson) on 2011-11-24
Changed in console-setup (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Changed in console-setup (Ubuntu Precise):
milestone: none → precise-alpha-1
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.70ubuntu2

---------------
console-setup (1.70ubuntu2) precise; urgency=low

  * Drop the simplified keyboard-configuration/xkb-keymap question; it
    breaks existing preseeding, might confuse Ubiquity, and people are
    already used to the layout/variant questions in Ubuntu (LP: #894187).
 -- Colin Watson <email address hidden> Thu, 24 Nov 2011 15:05:27 +0000

Changed in console-setup (Ubuntu Precise):
status: Triaged → Fix Released

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/894187

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers