Debian Installer has wrong defaults when country = IM GG or JE

Bug #814448 reported by Nigel Roberts on 2011-07-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Medium
Colin Watson
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

When installing the operating system (in my case Ubuntu 11.04 64 bit Desktop) and selecting my location, the default keyboard and localisation is set to United States. For IM (Isle of Man), GG (Guernsey, Alderney and Sark) and JE (Jersey) this should be set to the UK keyboard and UK localisation as the default.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: debian-installer (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Jul 22 08:01:06 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
MachineType: Packard Bell imedia S3210
MemoryUsage:
 total used free shared buffers cached
 Mem: 2829700 1059684 1770016 0 104568 353592
 -/+ buffers/cache: 601524 2228176
 Swap: 0 0 0
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=0d2e5126-f312-427d-9c2a-6c402583e007 ro quiet splash vt.handoff=7
SourcePackage: debian-installer
UpgradeStatus: Upgraded to natty on 2011-05-28 (54 days ago)
dmi.bios.date: 11/06/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: P01-B2
dmi.board.name: WMCP78M
dmi.board.vendor: Packard Bell
dmi.chassis.type: 3
dmi.chassis.vendor: Packard Bell
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrP01-B2:bd11/06/2009:svnPackardBell:pnimediaS3210:pvr:rvnPackardBell:rnWMCP78M:rvr:cvnPackardBell:ct3:cvr:
dmi.product.name: imedia S3210
dmi.sys.vendor: Packard Bell

Colin Watson (cjwatson) wrote :

Are you sure you're using Natty? Your bug report says "InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)", and I thought that I'd fixed this bug in console-setup 1.56 which is in Natty. See bug 533003.

affects: debian-installer (Ubuntu) → console-setup (Ubuntu)
Changed in console-setup (Ubuntu):
status: New → Incomplete
Colin Watson (cjwatson) wrote :

Oh, hmm, the last comment on bug 533003 says it's still broken. I shall investigate further.

I'll retry this, either with Natty, Onieric or both. (We are using a
combination of LTS and -whatever is the latest actually released
version- ...)

Thanks for looking into this.

On 08/15/2011 04:12 PM, Colin Watson wrote:
> Are you sure you're using Natty? Your bug report says
> "InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate
> amd64 (20100928)", and I thought that I'd fixed this bug in console-
> setup 1.56 which is in Natty. See bug 533003.
>
> ** Package changed: debian-installer (Ubuntu) => console-setup (Ubuntu)
>
> ** Changed in: console-setup (Ubuntu)
> Status: New => Incomplete
>

Colin Watson (cjwatson) wrote :

Confirmed in Oneiric desktop, and also in Oneiric server provided that you accept the default for the "Country to base default locale settings on" question.

Changed in console-setup (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

Rather than using debian-installer/locale for the lookup table in keyboard-configuration.config, we need to look at the language and location directly, because some locations such as the Isle of Man don't correspond to locales.

Changed in console-setup (Ubuntu):
status: Confirmed → Triaged
Doctor Modiford (glyn-cwgsy) wrote :

I had wondered what happened to this, since the last edition I installed recently still assumes a US keyboard layout. I had thought that maybe I was misunderstood and that something had been fixed but not what I was experiencing.

I know this is no show-stopper and that there are many more important security and stability issues that require attention, but someone has gone to the trouble of including us smaller nations (including the time-zone / map selection part) and once done forever more it will be correct.

I thank you for your continued investigation and work into this matter.

Colin Watson (cjwatson) wrote :

Tediously, I think we're going to need some cooperation between console-setup and ubiquity to fix this.

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.57ubuntu24

---------------
console-setup (1.57ubuntu24) oneiric; urgency=low

  * Fix default keyboard selection for language/country combinations lacking
    a proper combined locale (LP: #814448).
 -- Colin Watson <email address hidden> Fri, 19 Aug 2011 15:13:13 +0100

Changed in console-setup (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

This fix will become visible in Oneiric installations after the next debian-installer and ubiquity uploads; probably at some point over the next week or so.

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Changed in console-setup (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.16

---------------
ubiquity (2.7.16) oneiric; urgency=low

  [ Colin Watson ]
  * Update translations from Launchpad.
  * Enable code in console-setup 1.57ubuntu24 to fix default keyboard
    selection for language/country combinations lacking a proper combined
    locale (LP: #814448).
  * Rename libwebcam to libubiwebcam to avoid clashing with the existing
    libwebcam0 package.

  [ Evan Dandrea ]
  * Move noninteractive frontend to PyGI bindings for GObject (LP:
    #829186).
  * Make the webcam page match its specified design.
  * Automatic update of included source packages: console-setup
    1.57ubuntu25.

  [ Jeremy Bicha ]
  * Allow users to enter their own mount point in the partitoner (LP: #831431)
 -- Evan Dandrea <email address hidden> Wed, 24 Aug 2011 13:58:08 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released

Also noted as #3 on https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/562640.

Just tried latest 12.04 Beta 2 and Guernsey still defaults to USA (more details posted at above link). Not tried other locales for Jersey or Isle of Man.

Has the released fix just not made it up the tree somehow?

The regular 'Desktop' edition, with the map-based location selection works correctly when Guernsey is selected. So this specifically seems related to the 'Alternative' edition (which I was using to get custom fake-raid on Intel).

Glyn, would you mind filing that bug separately, on the 'localechooser'
package? That actually has no relation to the original bug, although I
can see how it looks similar.

Glyn M Burton (modiford) wrote :

Hello Colin,

I posted on the other bug report listed here to say Guernsey has now disspapeared entirely!

I look forward to Guernsey being recognised as a civilisation again.

Best regards,

Glyn 'Modiford' B.
Guernsey, Channel Islands.

It seems to me that there needs to be some work done to ensure that changes to the official ISO list become 'sticky' and don't get undone by some careless person using an out-of-date ISO-3166 country list reference.

GG JE and IM were added to the ISO list in 2006.

AX not long after.

SX, CW and others (Dutch Caribbean) recently.

This problem is pervasive and causes real-life problems ..

While Ubuntu itself is free -- this sort of error in other circumstances -- such as using Ubuntu as an e-commerce website platform and being forced to choose a "wrong" country code can (and often does!) cause a 20% increase in the price of something (being charged VAT when it is not applicable).

This should be addressed at a strategic level .. it affects more than just the installer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers