"Keep default keyboard layout" dialog appears during Wubi install on French Windows

Bug #758584 reported by Jean-Baptiste Lallement on 2011-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

ISO Testing: Ubuntu Desktop Wubi i386/amd64 20110411.1

During the second stage of the installation an unexpected dialog with title "Keep default keyboard layout" appears.
This is similar to bug 742558

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Tue Apr 12 11:08:52 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110411.1)
ProcEnviron:
 LANGUAGE=fr_FR:en
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
Changed in ubiquity (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) wrote :

The problem is that keyboard-configuration/variantcode= isn't adequately overriding k-c's defaults, so you get the us layout with oss variant which is obvious nonsense.

affects: ubiquity (Ubuntu Natty) → console-setup (Ubuntu Natty)
Changed in console-setup (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Confirmed → Triaged
milestone: none → ubuntu-11.04-beta-2
Colin Watson (cjwatson) on 2011-04-12
Changed in console-setup (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.57ubuntu18

---------------
console-setup (1.57ubuntu18) natty; urgency=low

  * Don't use the default keyboard variant if the layout is overridden by
    preseeding (LP: #758584).
 -- Colin Watson <email address hidden> Tue, 12 Apr 2011 15:21:11 +0100

Changed in console-setup (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers