Reconfiguring keyboard layout for TTYs only works after manually invoking setupcon

Bug #713062 reported by Jan Rathmann on 2011-02-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: console-setup

Hello,

also a report from testing of Natty Alpha 2 images (amd64).

If one wants to reconfigure his keyboard layout on system consoles (TTYs), the way to this is in Natty is obviously via

dpkg-reconfigure keyboard-configuration

Now the bug is that the keyboard layout remains unchanged afterwards, even after rebooting the system.
I found out accidently that you need to run 'sudo setupcon' to activate the new layout.

So a proposed fix for this issue would be to execute setupcon automatically after 'dpkg-reconfigure keyboard-layout' was run.

Kind regards,
Jan

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: keyboard-configuration 1.57ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Fri Feb 4 13:30:14 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 LANG=de_DE.UTF-8
 LC_MESSAGES=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: console-setup

Jan Rathmann (kaiserclaudius) wrote :

The odd thing is that we already do run setupcon (unless plymouth is
still running, which I suppose is possible). In any case, that wouldn't
be sufficient to explain why it would remain unchanged after rebooting,
because setupcon doesn't do anything that persists across reboots. I
imagine that the fragile udev rules to do this have broken again.

Jan Rathmann (kaiserclaudius) wrote :

I did some further testing and could reproduce it on another new installation:

- I selected "USA" as keyboard layout during installation.
- Then on the installed system I tried to set it to German for TTYs, running 'dpkg-reconfigure keyboard-configuration'
- Even after rebooting the keyboard layout remained US.
- Executing 'sudo setupcon' activated the German layout immediately.

Then I tried to switch keyboard layout back to US the same way.
Interestingly this time running 'sudo setupcon' was not sufficiend to switch layout. I had to do another reboot afterwards to activate the new layout.

Kind regards,
Jan

Thomas Kerber (t-kerber) wrote :

Suggested fix made no difference for me, also switching from USA to german.

tags: added: iso-testing
Colin Watson (cjwatson) on 2011-03-03
Changed in console-setup (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.57ubuntu9

---------------
console-setup (1.57ubuntu9) natty; urgency=low

  * The console-setup udev rule accidentally went missing in 1.57ubuntu1.
    Reinstall it, this time in keyboard-configuration (LP: #713746).
  * Load the new keyboard configuration immediately when running
    'dpkg-reconfigure keyboard-configuration' in an installed system
    (LP: #713062).
  * Make setupcon explicitly exit 0, so that postinsts don't fail in the
    event that loadkeys can't find a console.
 -- Colin Watson <email address hidden> Thu, 03 Mar 2011 16:14:06 +0000

Changed in console-setup (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers