console-setup doesn't start

Bug #657551 reported by kolya on 2010-10-10
68
This bug affects 15 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Medium
Unassigned
Nominated for Precise by Rolf Leggewie

Bug Description

Binary package hint: console-setup

On startup console-setup doesn't startup and I have wrong font on my console - it doesn't display Cyrillic.
When I try to start it by hand I get:
xxx@xxx:~/$ sudo service console-setup start
console-setup stop/waiting

When I do dpkg-reconfigure I get console font loaded until next reboot.
I have all maveric, recently updated from 10.04. All updates installed regularly.
Please let me know if I can provide any more information.
Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: console-setup 1.34ubuntu15
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sun Oct 10 01:29:48 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ru_RU:ru:en_GB:en
 PATH=(custom, user)
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: console-setup

kolya (mar-kolya) wrote :
kolya (mar-kolya) wrote :

Looks like the problem is in upstart config for console setup:
-----------------------------
$ cat /etc/init/console-setup.conf
# console-setup - set console keymap
#
# Set the console keyboard as early as possible so that the administrator
# can interact with the system during file system checks. The keymap may be
# set on any virtual console as long as it isn't in raw mode; loadkeys will
# go and look for one such, and fail if it can't find one.

description "set console keymap and font"

start on (virtual-filesystems
          or starting rcS
          or starting mountall-shell)

task

exec loadkeys /etc/console-setup/cached.kmap.gz
-----------------------------
And I'd guess that it should call /bin/setupcon (from console-setup package) which loads both - keys and font.
Am I wrong?

ABEgorov (abegorov) wrote :

I solved the problem by executing "setupcon --save" after "dpkg-reconfigure console-setup".

QkiZ (qkiz) wrote :

Yes, it's a problem with upstart. "sudo /etc/init.d/console-setup start" doesn't change anything. I try "dpkg-reconfigure console-setup", then "sudo setupcon --save" and console preferences back to normal but only to reboot system. After reboot my console preferences is gone. But setup in /etc/default/console-setup is saved correctly.

kolya (mar-kolya) wrote :

Is there any chance to get at least some update in this problem?

Pavlo Bohmat (bohm) wrote :

console-setup_1.57ubuntu7 :FAIL

Pavlo Bohmat (bohm) wrote :

console-setup_1.57ubuntu9_all.deb: OK

QkiZ (qkiz) wrote :

Where do you download this version of console-setup?

QkiZ (qkiz) wrote :

Its version from natty. It depends on keyboard-configuration package. If you install it on maverick this generate depend errors with kdb and xserver-xorg packages. To serious errors to install it on Ubuntu 10.10.

Pavlo Bohmat (bohm) wrote :

make package has not been canceled or wait...
bug 713746: fix for natty

kolya (mar-kolya) wrote :

This is still a problem after default 12.04 installation - no Cyrillic in console. Any chance of this to be fixed?

Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in console-setup (Ubuntu):
status: New → Confirmed
martin suc (martin-suc) wrote :

same problem for uk in console.

any fix on this ?

QkiZ (qkiz) wrote :

In 12.04 problem gone.

Rolf Leggewie (r0lf) wrote :

verified in precise that "sudo service console-setup stop" does nothing and could be run ad nauseam.

Changed in console-setup (Ubuntu):
importance: Undecided → Medium
Rolf Leggewie (r0lf) wrote :

apparently this problem had been fixed in the past in console-setup_1.57ubuntu9 but came back through a regression in console-setup_1.57ubuntu17 -> see bug 713746 comment 5 and after

tags: added: precise regression-release
Krittika (krittika-kalra) wrote :
Changed in console-setup (Ubuntu):
assignee: nobody → Krittika (krittika-kalra)
Serhiy Zahoriya (xintx-ua) wrote :

No, setupcon --save doesn't help on 15.10.

QkiZ (qkiz) wrote :

Me to. After reboot console font return to default.

Serhiy Zahoriya (xintx-ua) wrote :

Worked after changing /etc/default/console-setup to

CHARMAP="UTF-8"
CODESET="Uni2"
FONTFACE="Fixed"
FONTSIZE="16"

, then unzipping the font file (don't remember where I've read that it helps):

cd /etc/console-setup
sudo gunzip -k Uni2-Fixed16.psf.gz
sudo update-initramfs -u

Changed in console-setup (Ubuntu):
assignee: Krittika (krittika-kalra) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers