Console font does not get set

Bug #632382 reported by أحمد المحمودي (Ahmed El-Mahmoudy) on 2010-09-07
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
High
Colin Watson
Precise
Undecided
Unassigned
Quantal
High
Colin Watson

Bug Description

Binary package hint: console-setup

Hello,

  I upgraded Lucid to Maverick beta yesterday, and since then the console font does not get set properly. After talking with Colin Watson, and looking at the console-setup udev rule file (/lib/udev/rules.d/85-console-setup.rules). I understand that there is a possible race with Plymouth. So as suggested by Colin I created the attached upstart job (console-font.conf) to workaround the problem, and it worked !

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: console-setup 1.34ubuntu15
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Tue Sep 7 14:36:00 2010
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en_GB:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: console-setup

Related branches

tags: added: patch
Jordy van Heeswijk (jordyvh) wrote :

I believe I'm having the same problem.
But... how should I apply this patch?

Save that patch as /etc/init/console-font.conf

Jordy van Heeswijk (jordyvh) wrote :

I still had to use chown and chmod to get the file permissions right, but then it works!
Thanks!

Lachezar Dobrev (lachezar) wrote :

Shouldn't this go into /etc/init/console-setup.conf?

Colin Watson (cjwatson) wrote :

console-setup.conf doesn't have the same 'start on', which matters.

Ivan Frederiks (idfred) wrote :

Your patch fixed this problem for me. Thank you!

Changed in console-setup (Ubuntu):
status: New → Confirmed

How about adding console-font.conf to the console-setup package ?

Btw, there seems to be another fix on LP #433897, I didn't try it though.

Colin Watson (cjwatson) wrote :

I have unduplicated this from bug 433897, based on the implicit assertion in https://code.launchpad.net/~abone/ubuntu/precise/console-setup/fix-433897/+merge/118886 that these are separate bugs. I suspect that in fact many people's problems will be fixed just by this part of it, but I wanted to make some effort to separate them out for further analysis. Here's the comment I made on the merge proposal:

  After some thought, I agree that this Upstart job is the right thing to add, and I'm going to apply this to quantal. Thanks!

  I am much less convinced by the proposal to remove OPTION=FRAMEBUFFER (and still less by the proposal to force FRAMEBUFFER=y when splash is enabled; I agree with Oliver on that). I also don't think that creating a separate option for it is the right answer. If the framebuffer isn't enabled for some other reason, then the console-setup script should not need to run in the initramfs at all (except in the case of a panic, which is handled); the fact that this shouldn't be needed is what OPTION=FRAMEBUFFER expresses. It should be sufficient for the corresponding code to run from udev rules and Upstart jobs.

  Therefore, if the udev rules and Upstart jobs aren't working properly when there is no framebuffer code in the initramfs, that is what needs to be debugged. I believe this ought to be possible without running console-setup code in the initramfs.

Changed in console-setup (Ubuntu Quantal):
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-12.10
summary: - Console font does not get set in Maverick
+ Console font does not get set
Colin Watson (cjwatson) on 2012-10-09
Changed in console-setup (Ubuntu Quantal):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.70ubuntu6

---------------
console-setup (1.70ubuntu6) quantal; urgency=low

  * debian/console-setup.console-font.upstart: Add Upstart job that sets up
    console font when plymouth-splash is starting, to work around a possible
    udev/plymouth race that would otherwise prevent the font being set
    (thanks, Ahmed El-Mahmoudy and Andrey Bondarenko; LP: #632382).
 -- Colin Watson <email address hidden> Tue, 09 Oct 2012 01:50:48 +0100

Changed in console-setup (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in console-setup (Ubuntu Precise):
status: New → Confirmed
Jiaxing Wang (hello-wjx) wrote :

Will this fix be back ported to 12.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers