keyboard switches to Arabic after jaunty upgrade

Bug #357971 reported by jtniehof on 2009-04-08
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: console-setup

I installed jaunty (fresh install) from the jaunty beta, i386 CD image. Initial reboot after install worked fine. After updating to the latest packages, on next reboot the login screen only typed in Arabic. Switching vterms to the console also didn't type in English (garbage characters). Booting a live CD and mounting the install media revealed that /etc/default/console-setup had changed XKBLAYOUT to af. Changing it back to us made the installed system work on next boot.

Fix was found in this forum thread: http://ubuntuforums.org/showthread.php?t=1111564

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: console-setup 1.28ubuntu7
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: console-setup
Uname: Linux 2.6.28-11-generic i686

jtniehof (jtniehof) wrote :
Colin Watson (cjwatson) wrote :

Thanks for your report. This is unusual; please attach /etc/default/console-setup, /var/log/installer/syslog, and /var/cache/debconf/config.dat so that we can figure out what's going on.

Changed in console-setup (Ubuntu):
status: New → Incomplete
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
jtniehof (jtniehof) wrote :
jtniehof (jtniehof) wrote :
jtniehof (jtniehof) wrote :
jtniehof (jtniehof) wrote :

Requested attachments above. Two points of interest:

syslog has a message:
Apr 8 12:49:04 ubuntu ubiquity: /usr/bin/ckbcomp: No keycodes, nor layout specified
Apr 8 12:49:04 ubuntu ubiquity: Your console font configuration will be updated the next time your system
Apr 8 12:49:04 ubuntu ubiquity: boots. If you want to update it now, run 'setupcon' from a virtual console.
I was affected by https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/346589 and clicked "continue" a few times, then "go back", then the installer seemed to hang up for a moment so I clicked "back" to the previous step (keymap selection, IIRC). Then I selected the keymap again, clicked forward, remembered the "go back" issue, clicked "go back" and waited a few minutes, at which point the partitioner started up. So all this flailing may be the key.

The other interesting thing is config.dat definitely seems to have af selected.

jtniehof (jtniehof) wrote :

(Sorry for spamming the comments)
After the last comment, I switched to a virtual console to try and run "setupcon" (just to see how it came out.) Turns out the console was still not working in English, despite X being fine. I switched back to X, ran dpkg-reconfigure console-setup. All the options going through defaulted to bog-standard US-intl...I basically hit enter a bunch of times. Once it was done, I rebooted, and now the console and X both seem to work properly.

Steve Beattie (sbeattie) wrote :

I also saw this when doing updates in a jaunty vm that incuded the latest console-setup update (1.28ubuntu7 -> 1.28ubuntu8), XKBLAYOUT in /etc/default/console-setup had somehow been set to 'af' from 'us'. Attached is the /var/cache/debconf/config.dat which indeed has console-setup/layout set to Afghanistan for some strange reason.

Steve Beattie (sbeattie) wrote :

Attaching /var/log/apt/term.log.

Steve Beattie (sbeattie) wrote :

Here's the original /var/log/installer/syslog in which the keyboard was correctly set to us.

tubegeek (tubegeek) wrote :

Same thing happened to me. Fixed as described at Sarai The Geek's blog:
http://saraithegeek.wordpress.com/2009/03/30/jaunty-default-keyboard-bug/

Happened to me as well after updating the VM installation of Jaunty.

I experienced nearly the same bug, but I did a fresh install of Jaunty.
I used the LiveCD installer. When I had to choose the keyboard layout I kept the proposed value (german) = the new feature in Jaunty when a keyboard layout automatically proposed.
When I first booted from hard disk I was unable to login because the keyboard layout had switched zo us. (I had to test my password in the field "username" to realize why the login didn't work)

I used the workaround described above to change "console-setup".
Below is the /etc/default/console-setup before I applied the changes.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL="pc105"
XKBLAYOUT=""
XKBVARIANT=""
XKBOPTIONS=""

I applied the following changes:
XKBLAYOUT="de"

The machine is a HP-laptop XT1000
quite old but 7.10 and 8.04 worked (different windows managers recommended)

Maybe this is worth a comment:

1) I used Ubuntu 9.04 RC

2) I didn't attend the installation:
started the installer by hand and when the installing procedure started I went to bed.
I remember from earlier ubuntu-version that during the install the question if I want to install/download the language packs. If no user interaction takes place does the installer download them or not? Maybe it doesn't download them which eventually leads to the keyboard problem?

Zach Erbaugh (zach) wrote :

I've hit this as well - I installed from a USB drive to a Toshiba Tecra R10-S4401, did an apt-get dist-upgrade, rebooted, and had Arabic on login.

Ori Folger (calanya+launchpad) wrote :

Happened to me as well - upgraded from 8.10, and after reboot had Hebrew on login.

I've faced the same problem with Arabic, it was working fine for many days, but once after a reboot I couldn't login to the console nor by gdm as it was typing in Arabic...
I've solved it following the same steps explain here;
http://saraithegeek.wordpress.com/2009/03/30/jaunty-default-keyboard-bug/

Sarai (saraiwashere) wrote :

I've noticed that 9 times out of 10 people say their letters show up in arabic. The first keyboard layout on the list is af, the afghan keyboard layout, which I don't think is a coincidence. However, a few people report having hebrew, leading me to suspect that there may be some confusion regarding the two alphabets. They're not difficult to tell apart, so here's a comparison between the two to help out:
http://farm4.static.flickr.com/3100/3551029805_0d825bbc11.jpg

Sarai (saraiwashere) wrote :

Hmm, that link doesn't work. Try this one instead:
http://farm4.static.flickr.com/3100/3551029805_2072d60017_o.jpg

rex_the_first (rex-the-first) wrote :

I have just convinced my sister to change to Ubuntu and then when she updated her new PC is unusable as it is in Afghan, she is going back to Windows... There have been a few console-setup, syslog, and config.dat attached. Can this bug status be changed to confirmed yet?

Colin Watson (cjwatson) on 2012-05-17
Changed in console-setup (Ubuntu):
status: Incomplete → Confirmed
assignee: Colin Watson (cjwatson) → nobody
Mörgæs (moergaes) wrote :

Closing due to age.
If a similar bug appears in 15.04 (development) please open a new report.

Changed in console-setup (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions