wrong character encoding in tty consoles after reboot

Bug #235735 reported by Dieter Moerschel on 2008-05-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Undecided
Unassigned

Bug Description

Steps that caused the bug:

1. enter a tty console
2. use midnight commander or aptitude
3. notice wrong character encoding (scrambled lineart etc...)
4. do 'sudo dpkg-reconfigure console-setup'
5. use midnight command again
6. notice that problem was fixed.
7. reboot system
8. notice that encoding is wrong again

What happens:
console-setup's data is somehow forgotten or overridden during reboot

What should happen:
Correct console configuration is remembered over reboot

notes: I encountered this bug after an update from the update manager, stock hardy did not have this problem. Hardy Proposed is activated in my repos

Reproducibilty: 100% (every time after reboot this happens)

ProblemType: Bug
Architecture: amd64
Date: Thu May 29 10:40:52 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: ubuntu-desktop 1.102
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_DK.UTF-8
SourcePackage: ubuntu-meta
Uname: Linux 2.6.24-17-generic x86_64

Dieter Moerschel (dmoer) wrote :
Dieter Moerschel (dmoer) wrote :
Dieter Moerschel (dmoer) wrote :
Nicolas Van Wambeke (nicolasvw) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in console-setup

Gökdeniz Karadağ (gokdeniz) wrote :

you should copy the font file from /usr/share/consolefonts/ to /etc/console-setup.

dpkg-reconfigure does this but somehow that may be broken.

look into /etc/default/console-setup, the font file should be named as /etc/console-setup/$CODESET-$FONTFACE$FONTSIZE.psf.gz

you should run update-initramfs -u after those changes.

Changed in console-setup:
status: New → Incomplete
Colin Watson (cjwatson) wrote :

Thanks for your report. This is also bug 130444.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers