console-setup defaults prevent using automatic highdpi fonts

Bug #1880266 reported by Dimitri John Ledkov on 2020-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Undecided
Unassigned

Bug Description

console-setup defaults prevent using automatic highdpi fonts

Kernel has built-in Terminus fonts, at multiple sizes, and it picks font based on screen resolution, including selecting high-dpi version of the font.

The autogenerated default of FONTFACE=VGA and FONTSIZE=16 for Lat15 results in tiny font getting set on high-dpi laptops. Dropping this setting, makes fonts to be of correct size on highdpi screens.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1880266

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
affects: linux (Ubuntu) → console-setup (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.195ubuntu2

---------------
console-setup (1.195ubuntu2) groovy; urgency=medium

  * Do not set default FONTFACE or FONTSIZE for Lat15, kernel has built-in
    Terminus font, at multitiple sizes, and it correctly selects low/high
    dpi font size, based on screen resolution. LP: #1880266

 -- Dimitri John Ledkov <email address hidden> Sat, 23 May 2020 04:58:43 +0100

Changed in console-setup (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers