Remove obsolete versioned dependency on initramfs-tools Edit

Bug #1721626 reported by Steve Langasek on 2017-10-05
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Steve Langasek

Bug Description

[SRU Justification]
Up until artful, console-setup declares a versioned dependency on initramfs-tools. This was an Ubuntu-specific dependency only needed for upgrades, and the version referenced is ancient (ca. 2008). In artful and later, the dependency has now been removed.

Since this is no longer relevant for upgrades and we would not otherwise have a dependency on initramfs-tools, we should drop this dependency to support building of images with initramfs-tools removed for systems that we know don't require an initramfs.

[Test case]
1. On a xenial default cloud image install, try to run 'sudo apt purge initramfs-tools'.
2. Verify that this tries to remove console-setup, console-setup-linux, and kbd.
3. Cancel the removal.
4. Install console-setup from xenial-proposed.
5. Run 'sudo apt purge initramfs-tools' again.
6. Verify that console-setup, console-setup-linux, and kbd are not removed.
7. Run 'sudo apt install --reinstall console-setup' and confirm that the package can be installed successfully without initramfs-tools installed.

[Regression Potential]
If a user needs an initramfs in order to mount their root device, and console-setup is the only package on their system which depends on initramfs-tools, it is possible that the user may remove initramfs-tools and render their system unbootable.

This is unlikely because initramfs-tools is still part of the 'minimal' seed and is therefore a dependency of ubuntu-minimal; and it remains a dependency of the generic kernel image.

Steve Langasek (vorlon) on 2017-10-05
Changed in console-setup (Ubuntu):
status: New → Fix Released
Changed in console-setup (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Steve Langasek (vorlon)

Hello Steve, or anyone else affected,

Accepted console-setup into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/console-setup/1.108ubuntu15.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in console-setup (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Steve Langasek (vorlon) wrote :

I've run through this test case and confirmed console-setup works without initramfs-tools.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Jeremy Bicha (jbicha) wrote :

Please see LP: #1723806 which suggests that there is a regression here.

Jeremy Bicha (jbicha) wrote :

I'm setting this to verification-failed because we should investigate LP: #1723806 before releasing this to -updates.

tags: added: verification-failed-xenial
removed: verification-done-xenial

On Thu, Oct 19, 2017 at 06:40:19PM -0000, Jeremy Bicha wrote:
> I'm setting this to verification-failed because we should investigate
> LP: #1723806 before releasing this to -updates.

It's fine to hold this in -proposed for right now.

Given that we have a recent spate of reports about maintainer scripts
hanging on 'plymouth --ping' due to plymouthd having hung, and console-setup
calls plymouth --ping in its postinst, I think this is not a bug in
console-setup, and therefore also not a regression. However, since any
upgrade of console-setup is going to tickle the bug for affected users, I
think we need to resolve the plymouth problem first before pushing this SRU
out.

Manfred Hampl (m-hampl) wrote :

Are you aware that ubiquity-2.21.63.5 in xenial-updates already depends on console-setup 1.108ubuntu15.4 which is only in xenial-proposed?

Eric Desrochers (slashd) wrote :

The retention of console-setup in xenial-proposed is causing a side-effect on ubiquity [2.21.63.5] installation which depend specifically on that 1.108ubuntu15.4 version[1].
IMHO ubiquity should have been put on hold as well to make sure console-setup and ubiquity were release at the same time.

If the hang cannot be fix soon, meaning that console-setup will stay in -proposed for a while or maybe eventually drop ?
Maybe we should consider rolling back ubiquity to use console-setup 1.108ubuntu15.3 ? to at least unblock the dependencies created by last console-setup change[2]

[1] root@xenial:~# apt-get install ubiquity
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ==> ubiquity : Depends: console-setup (>= 1.108ubuntu15.4) but 1.108ubuntu15.3 is to be installed <===
            Recommends: grub-pc but it is not going to be installed or
                        grub but it is not going to be installed or
                        grub-efi but it is not going to be installed
            Recommends: dmraid but it is not going to be installed
            Recommends: btrfs-tools but it is not going to be installed
            Recommends: ubuntu-drivers-common but it is not going to be installed
            Recommends: lvm2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

[2] debian/changelog

ubiquity (2.21.63.5) xenial; urgency=medium

  * Cherry-pick support for WPA2 Enterprise. LP: #1107935
  * Automatic update of included source packages: console-setup
    1.108ubuntu15.4.

 -- Dimitri John Ledkov <email address hidden> Tue, 31 Oct 2017 17:45:29 +0000

Note: If we activate xenial-proposed and then install ubiquity, it works because the dependency is met.

Thoughts ?

While I understand the impact of having console-setup potentially "hang" the system on upgrade, this isn't something that happens systematically, it's also not a regression introduced in 1.108ubuntu15.4, so what is the net benefit in not releasing this SRU? Certainly people might still upgrade to $some_version of console-setup and have a hang caused by plymouth not responding correctly to plymouth --ping?

I don't know that console-setup should be verification-fail because of that. There's an issue, sure; a regression, maybe; but neither were introduced by this particular upload.

Steve Langasek (vorlon) wrote :

On Fri, Nov 10, 2017 at 02:04:58PM -0000, Mathieu Trudel-Lapierre wrote:
> While I understand the impact of having console-setup potentially "hang"
> the system on upgrade, this isn't something that happens systematically,
> it's also not a regression introduced in 1.108ubuntu15.4, so what is the
> net benefit in not releasing this SRU? Certainly people might still
> upgrade to $some_version of console-setup and have a hang caused by
> plymouth not responding correctly to plymouth --ping?

> I don't know that console-setup should be verification-fail because of
> that. There's an issue, sure; a regression, maybe; but neither were
> introduced by this particular upload.

A functional regression that triggers on upgrade of the package, and which
causes a non-negligible number of users to have their package upgrade hang
instead of completing, should be addressed before the SRU is released.

I think we should be rolling back ubiquity, not rushing out console-setup.

Łukasz Zemczak (sil2100) wrote :

What's the situation with console-setup right now? Should this upload be left in -proposed? It's been already around very long in the verification-failed state. Is this issue here still valid? I remember seeing the plymouth --ping issue addressed and released.

Could anyone have a second look at this very old upload?

Steve Langasek (vorlon) wrote :

Thanks, now that the plymouth --ping change has landed, this should be moved to verification-done.

tags: added: verification-done-xenial
removed: verification-failed-xenial
Łukasz Zemczak (sil2100) wrote :

Before proceeding with releasing of this update, could someone re-run the test case one more time? After the package idling in -proposed for so long I think it might be unwise to publish it without checking if changes in the archive after 200 days didn't invalidate and/or introduce regressions, requiring a rebuild or a reupload. We can then publish to -updates.

Robie Basak (racb) wrote :

Resetting the tags since Łukasz has requested re-verification (see previous comment).

tags: added: verification-needed verification-needed-xenial
removed: verification-done-xenial
Łukasz Zemczak (sil2100) wrote :

After closer examination, no re-verification is indeed necessary for this package. Releasing.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.108ubuntu15.4

---------------
console-setup (1.108ubuntu15.4) xenial; urgency=medium

   * Drop dependency from console-setup to initramfs-tools |
     linux-initramfs-tool; this was a versioned dependency used for upgrades,
     now long obsolete. LP: #1721626.

 -- Steve Langasek <email address hidden> Thu, 05 Oct 2017 12:36:07 -0700

Changed in console-setup (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for console-setup has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions