/lib/systemd/system/console-setup.service has incorrect ExecStart

Bug #1511975 reported by danielmeek32 on 2015-10-31
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Medium
Unassigned

Bug Description

/lib/systemd/system/console-setup.service as provided by this package (confirmed in vivid and wily) specifies:

[Service]
Type=oneshot
ExecStart=/usr/bin/loadkeys /etc/console-setup/cached.kmap.gz

The "ExecStart" line will set the keyboard map but not the font, therefore the font remains at the default VGA font and framebuffer console mode is not enabled.

The correct line which will set up both the keyboard map and the font is:

ExecStart=/bin/setupcon

The complete modified file is attached.

I would be willing to submit a pull request on the relevant git repository if someone could point me in the right direction.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: keyboard-configuration 1.108ubuntu5 [modified: lib/systemd/system/console-setup.service]
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: MATE
Date: Sat Oct 31 16:30:27 2015
InstallationDate: Installed on 2015-10-31 (0 days ago)
InstallationMedia: Ubuntu-MATE 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
PackageArchitecture: all
SourcePackage: console-setup
UpgradeStatus: No upgrade log present (probably fresh install)

danielmeek32 (danielmeek32) wrote :
Colin Watson (cjwatson) wrote :

These are intentionally separated to avoid causing other problems (the rules for when one may safely set the font are rather complicated - with some console drivers, it's vital that the foreground virtual console not be in KD_GRAPHICS mode in order to avoid corrupting graphics memory). The font is intended to be set from /lib/udev/rules.d/85-keyboard-configuration.rules, and indeed should have already been set from an initramfs script before that. Perhaps you could debug why that isn't working for you?

danielmeek32 (danielmeek32) wrote :

Sorry about the late reply. I can't say that I know exactly how to debug it, however there is a notice in /lib/udev/rules.d/85-keyboard-configuration.rules that:

# Framebuffer console created. Set up the font on all virtual consoles
# again. This races with Plymouth if fbcon is built into the kernel; but
# the worst case should simply be that fonts don't get set up properly.

Also my initrd get regenerated when I run sudo dpkg-reconfigure console-setup however that doesn't seem to change anything.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in console-setup (Ubuntu):
status: New → Confirmed
Changed in console-setup (Ubuntu):
importance: Undecided → High
importance: High → Medium
Constantine (theaspect) wrote :

Same for 15.10 and I bet for upcoming 16.04

TJ (tj) wrote :

Should this bug be renamed to "console-setup doesn't configure Virtual Console font at start-up" ?

This seems to be what it is about and if so it still affects 16.04.

TJ (tj) wrote :

I notice that the 16.10 console-setup has expanded the /etc/init.d/console-setup script to call 'setupcon'. Maybe we just need a backport?

danielmeek32 (danielmeek32) wrote :

/etc/init.d/console-setup is the upstart script; this bug report is about the systemd script.

Jacob Becker (jabecker) wrote :

On my 16.04.3 (keyboard-configuration 1.108ubuntu15.3) the subject line is:
ExecStart=/bin/setupcon --save

So, it might have already been fixed, but further version range clarification is probably needed.

Steve Langasek (vorlon) wrote :

In disco and later, the execstart line is:

ExecStart=/lib/console-setup/console-setup.sh

so this particular bug appears to be resolved.

Changed in console-setup (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers