Console not correctly set up after boot

Bug #130444 reported by Axel Harvey on 2007-08-05
144
This bug affects 5 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
High
Colin Watson
Gutsy
Undecided
Unassigned
Hardy
High
Colin Watson
Intrepid
Undecided
Unassigned

Bug Description

This is a long-running problem with several different incarnations. Bug 91422 was caused by the splash screen forgetting to save and restore the console font when switching to and from graphics mode, fixed in Ubuntu 7.10. In https://blueprints.launchpad.net/ubuntu/+spec/hardy-console, we proposed a fix in the kernel which would deal with this problem centrally rather than having to fix every single X driver individually, and this was fixed in Ubuntu 8.04. However, Ubuntu 8.10 and Jaunty still exhibit similar symptoms, so I'm grabbing this bug to serve as a sink for duplicates.

At the moment, the console is not set up correctly because /dev/tty1, /dev/tty2, etc. do not exist at the point when console-setup's initramfs script tries to deal with this. The simple fix is to have it create those devices itself, and once I do this I find that the console is set up correctly.

I think we should backport this fix at least to hardy and intrepid, and possibly gutsy as well; I see no downside in doing so.

DEVELOPMENT BRANCH: Fixed in console-setup 1.28ubuntu3.

PATCH: http://bazaar.launchpad.net/~ubuntu-core-dev/console-setup/ubuntu/revision/86

TEST CASE: Install in Georgian (to pick a language where it's fairly obvious), and switch to Ctrl-Alt-F1 after installation. Confirm that you can type Georgian letters and that they display as something that actually looks like letters rather than blank spaces or obvious visual corruption.

Axel Harvey (xlrv) wrote :

I have just noticed that the caps lock key does not work in the virtual terminals: characters continue to appear as lower-case even when the "Caps" pilot light is on. The caps lock works properly with the gui terminal. The ordinary shift key works properly in both environments. I don't know if this is relevant information but am offering it as a possible clue.

Axel Harvey (xlrv) wrote :

UPDATE Another possible clue? -- Context is Ubuntu Feisty Fawn. This was discovered accidentally. When the grub boot starts, just after the Ubuntu logo appears on the screen but before the sign-in box comes up, I do ctrl-alt-F1 and switch to TTY display (with all the messages that are usually hidden at boot time). After a few seconds the normal character set changes to a slightly uglier one -- looking like something circa 1980 -- and a little while later the display returns by itself to gui mode and I can sign in as usual, as if I had never left the gui terminal.

Now I return to a TTY virtual terminal with the slightly primitive character set, and lo! *all the accents appear in their proper places*. There are a few minor discrepancies, the only major one being that é appears as £, but believe me I am much, much happier with the "new" arrangement; and Midnight Commander now shows up with proper borders. If I write a file in TTY and then read it in gui, the £ will show as é.

Three more points: (1) all virtual terminals are affected the same way; (2) the caps lock now works; (3) the output of stty -a is the same with this "new" arrangement as it was with the standard arrangement.

I must add I am somewhat disconcerted that the importance of this bug has not yet been determined. Even if VTs are used only for writing code, there are some people who might occasionally write comments in languages other than English (a peculiar Indo-European dialect which tries to dispense with accents). Also any display that requires borders, such as Midnight Commander, looked terrible on the standard VT arrangement; with my accidentally found "fix" I can now enjoy it in its former beauty.

Colin Watson (cjwatson) wrote :

This is a known issue with console-setup (and definitely something that's come up before, although I'm not going to go looking for the reference right now ...). Ubuntu 7.10 should improve it substantially, but there are still issues depending on the video card. We discussed this at our last developer summit, and the fix is targeted for 8.04.

Colin Watson (cjwatson) wrote :

(Actually, the 7.04 issue was mostly console-setup, while the current issue is somewhere between the kernel and X. But never mind; this is a reasonable holding area for it.)

Márcio (mvfpoa) wrote :

i'm also having this problem. In gnome-terminal i can see the accented characters in filenames. but switching to console, the accented characters are all messed. I have no way to manage accented filenames from the virtual terminals.

Márcio (mvfpoa) wrote :

Forgot to say, i'm using a brand new Hardy Heron Desktop! and if i am not wrong, filenames used to be shown correctly on Gutsy Gibbon.

Axel Harvey (xlrv) wrote :

This is most disturbing. I already skipped upgrading from 7.04 to 7.10 because I believed the problem would be fixed in 8.04 (see Colin Watson's notes above). Is there likely to be a patch or add-on fix soon so I can move on to Hardy Heron?

Colin Watson (cjwatson) on 2008-11-26
description: updated
Changed in console-setup:
assignee: nobody → kamion
importance: Medium → High
status: Confirmed → Triaged
Colin Watson (cjwatson) on 2008-11-26
Changed in console-setup:
status: Triaged → Fix Committed
Colin Watson (cjwatson) on 2008-11-26
Changed in console-setup:
assignee: nobody → kamion
importance: Undecided → High
milestone: none → ubuntu-8.04.2
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.28ubuntu3

---------------
console-setup (1.28ubuntu3) jaunty; urgency=low

  * Create /dev/tty[1-6] in our initramfs script before trying to operate on
    them (LP: #130444).

 -- Colin Watson <email address hidden> Wed, 26 Nov 2008 12:15:12 +0000

Changed in console-setup:
status: Fix Committed → Fix Released

Will there be a backport for Intrepid ?

On Wed, Nov 26, 2008 at 12:30:06PM -0000, Launchpad Bug Tracker wrote:
> This bug was fixed in the package console-setup - 1.28ubuntu3
---end quoted text---

Colin Watson (cjwatson) wrote :

Yes, that's why I targeted the bug at Intrepid - though I'm about to go on holiday and may not get to it until I get back.

description: updated
Colin Watson (cjwatson) wrote :

I've uploaded backports of this fix to gutsy-proposed, hardy-proposed, and intrepid-proposed. I'd appreciate it if somebody else in ubuntu-sru could review them.

Martin Pitt (pitti) wrote :

While the patch itself is pretty obvious and trivial, it's impact is much less so, and could uncover other problems. With hardy being LTS, it does make sense to backport it there, and we can probably find some testers there.

But since the underpinnings changed in every release (kernel fix, usplash save/restore), we can't just translate hardy/intrepid verification results to gutsy.

Since gutsy is fairly old already, and only has 4 months to live, by now people either learned to live with that problem, or use something else.

I'm also okay with intrepid, since we currently have lots of people using intrepid-proposed.

Changed in console-setup:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in console-setup:
milestone: ubuntu-8.04.2 → none
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Colin Watson (cjwatson) wrote :

I don't mind about gutsy personally; it was really just collect-the-set since the patch backported trivially. I've put the fixed package for gutsy in my PPA:

  deb http://ppa.launchpad.net/kamion/ubuntu gutsy main

Hello,

  I installed console-setup 1.28ubuntu3 from Jaunty on my Intrepid, and
  the bug got fixed). Thanks !

Martin Pitt (pitti) wrote :

No regressions for me with the intrepid update, considering verified for intrepid.

Still needs feedback for Hardy.

Changed in console-setup:
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.25ubuntu4

---------------
console-setup (1.25ubuntu4) intrepid-proposed; urgency=low

  * Create /dev/tty[1-6] in our initramfs script before trying to operate on
    them (LP: #130444).

 -- Colin Watson <email address hidden> Thu, 27 Nov 2008 19:07:15 +0000

Changed in console-setup:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Resetting verification tag for hardy. Can anyone please test the update on Hardy?

Gökdeniz Karadağ (gokdeniz) wrote :

I tested on hardy and the bug is still partially present.

First of all a tip to other users; I purged console-setup to get rid of my previous tries on keymap.gz and etc.. Reinstalled again from hardy-proposed.

I have previously removed "-8" from getty parameters at /etc/event.d/ttyX files at #273189, I put them back.

running "dpkg-reconfigure console-setup" and rebooting made the characters appear.

The remaining part of the problem is; after typing locale specific characters (çöğüş) backspace key deletes the prompt text. It is narrated in detail at #273189

This is not a very big deal but it's still a bug I think :) Is it present in intrepid or jaunty, can anyone test ?

Colin Watson (cjwatson) wrote :

Can you type the locale-specific characters at something like 'cat >/dev/null' (as opposed to a login or shell prompt)? If so, I think that is likely to be a different bug (indeed, bug 273189 is definitely distinct from this one). This bug is fixed if the characters can be typed and appear accurately at 'cat >/dev/null'.

Gökdeniz Karadağ (gokdeniz) wrote :

Yes after logging in there is no problem in both the shell prompt and the cat.

But strangely, the login prompt does not work now. non-ascii characters are not displayed *at all*. And backspace does not delete the login prompt. I'm not sure what caused this, the machine was not updated. There was an update to 'login' package, I installed it but still non-ascii chars are not printed "at login prompt only"

Colin Watson (cjwatson) wrote :

OK, thanks. I think this is an essentially unrelated bug, much closer to bug 273189 than to this one.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.21ubuntu9

---------------
console-setup (1.21ubuntu9) hardy-proposed; urgency=low

  * Create /dev/tty[1-6] in our initramfs script before trying to operate on
    them (LP: #130444).

 -- Colin Watson <email address hidden> Thu, 27 Nov 2008 19:00:39 +0000

Changed in console-setup:
status: Fix Committed → Fix Released
Erik B. Andersen (azendale) wrote :

I don't know if my problem is the same because Jaunty and karmic worked for me. Would someone look at bug 528769 and tell me if it is a duplicate or not?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers