console-cyrillic changes settings on consoles it doesn't own, causing crashes with plymouth + X

Bug #597673 reported by Evgeny Brazgin on 2010-06-23
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Plymouth
Invalid
Undecided
Unassigned
console-cyrillic (Ubuntu)
Critical
Colin Watson
Oneiric
Critical
Colin Watson

Bug Description

Binary package hint: plymouth

$ lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10

Using plymouth_0.8.2-2ubuntu2

After Xserver started, plymouthd is still running. And keys like "Alt-F1", "Alt-Left", "Ctrl-Alt-Delete" are still handled by plymouth.
So, "Alt-F1" from X directs me to tty1. "Ctrl-Alt-Delete" restarts computer.

If I stop plymouth manually and restart xserver, everything goes ok

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: plymouth 0.8.2-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-5.6-generic 2.6.35-rc3
Uname: Linux 2.6.35-5-generic i686
Architecture: i386
Date: Wed Jun 23 15:51:13 2010
DefaultPlymouth: Error: command ['readlink', '/etc/alternatives/default.plymouth'] failed with exit code 1:
MachineType: SAMSUNG ELECTRONICS CO., LTD. N140
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-5-generic root=UUID=cb9deafa-ef1a-45fd-9ebc-7dd925a4d89a ro
ProcEnviron:
 LANGUAGE=ru_RU:ru:en_GB:en
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 VGA16 VGA
SourcePackage: plymouth
TextPlymouth: Error: command ['readlink', '/etc/alternatives/text.plymouth'] failed with exit code 1:
dmi.bios.date: 08/18/2009
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 01CU.M002.20090818.CYH
dmi.board.name: N140
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr01CU.M002.20090818.CYH:bd08/18/2009:svnSAMSUNGELECTRONICSCO.,LTD.:pnN140:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnN140:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct10:cvrN/A:
dmi.product.name: N140
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Evgeny Brazgin (xapienz) wrote :
Evgeny Brazgin (xapienz) wrote :

Just today noticed, that there's no need to stop plymouth service.
I can restart X-server using Alt-E after having kdm (using kubuntu) loaded, and after this everything goes as expected - Alt-F1 doesn't switch to the first terminal.

Maybe the problem is that X-server loads too early, earlier than some service.

Evgeny Brazgin (xapienz) wrote :

It still can be confirmed.
Another netbook (eeepc 1018p), another OS (freshly installed maverick, upgraded to natty).
The problem exists.

Dmitry Shachnev (mitya57) wrote :

Just got this on Natty. Pressing Alt+F4 opens the tty4, when I press Alt+F7 back, the window is getting closed.
The same for Alt+*.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

and plymouth is running for both of you after the X server starts? How are you starting the X server? If X is started by gdm, gdm is supposed to stop plymouth before taking over the console.

Changed in plymouth (Ubuntu):
status: Confirmed → Incomplete
Evgeny Brazgin (xapienz) wrote :

I use kdm. For about two weeks I haven't been having this problem.
Some people say, it may be a problem of console-cyrillic.
If someone tests, it would be great.

Dmitry Shachnev (mitya57) wrote :

Oh yes, I installed console-cyrillic 2 days ago and now I get it.
I don't have Plymouth running, so should it be a bug in console-cyrillic instead?

Dmitry Shachnev (mitya57) wrote :

I purged console-cyrillic and the problem gone away, so I confirm it's console-cyrillic.
// I can't change the package/status since I get Launchpad timeout errors. Please change them to console-cyrillic/Confirmed.

Steve Langasek (vorlon) wrote :

Ah; sure enough, console-cyrillic incorrectly assumes that it's ok to adjust the console state during startup... which it's not. In particular, calling 'kbd_mode' when the terminal is in raw mode is a no-no.

console-cyrillic needs to be heavily refactored to use the rules described in /lib/udev/console-setup-tty. It should maybe be reduced to nothing more than a config package that sets certain defaults for console-setup.

affects: plymouth (Ubuntu) → console-cyrillic (Ubuntu)
Changed in console-cyrillic (Ubuntu):
importance: Undecided → Critical
status: Incomplete → Triaged
Changed in plymouth:
status: New → Invalid
Evgeny Brazgin (xapienz) on 2011-06-09
summary: - plymouth picking up the keyboard
+ console-cyrillic prevents from using Alt+Key keyboard combinations
+ correctly
Steve Langasek (vorlon) on 2011-06-09
summary: - console-cyrillic prevents from using Alt+Key keyboard combinations
- correctly
+ console-cyrillic changes settings on consoles it doesn't own, causing
+ crashes with plymouth + X
Colin Watson (cjwatson) on 2011-06-09
Changed in console-cyrillic (Ubuntu Oneiric):
assignee: nobody → Colin Watson (cjwatson)
milestone: none → oneiric-alpha-2
Martin Pitt (pitti) wrote :

As this package isn't installed on any of the images, it is not a milestone blocker. Moving to alpha-3 for now.

Changed in console-cyrillic (Ubuntu Oneiric):
milestone: oneiric-alpha-2 → oneiric-alpha-3

Following pitti's comments, moving this to B1

Changed in console-cyrillic (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Colin Watson (cjwatson) on 2011-08-19
Changed in console-cyrillic (Ubuntu Oneiric):
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

Fixing this to be a configuration package for console-setup is probably ultimately the right thing to do, but is an insane amount of work that I'm not sure I'm competent to do. It's not even clear to me that they're a conceptual match.

What I'm going to do for Oneiric, I'm afraid, is simply to neuter the init script so that it doesn't interfere with plymouth. You can still run cyr manually after login if you want to force its use.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-cyrillic - 0.9-16ubuntu2

---------------
console-cyrillic (0.9-16ubuntu2) oneiric; urgency=low

  * Depend on console-setup for now; console-setup-linux does not yet exist
    in Ubuntu.
  * Neuter the init script, as cyr doesn't seem to be compatible with the
    way console-setup sets up consoles in a Plymouth-safe way during boot
    (LP: #597673). You can probably still run it by hand after login.
 -- Colin Watson <email address hidden> Mon, 22 Aug 2011 19:32:04 +0100

Changed in console-cyrillic (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers